Bug 231228 - Dolphin crash after safely removing USB device
Summary: Dolphin crash after safely removing USB device
Status: RESOLVED DUPLICATE of bug 211525
Alias: None
Product: dolphin
Classification: Applications
Component: general (show other bugs)
Version: 16.12.2
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Peter Penz
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-03-18 15:47 UTC by al
Modified: 2010-03-18 16:08 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description al 2010-03-18 15:47:03 UTC
Application that crashed: dolphin
Version of the application: 1.3
KDE Version: 4.3.2 (KDE 4.3.2)
Qt Version: 4.5.2
Operating System: Linux 2.6.31-20-generic-pae i686
Distribution: Ubuntu 9.10

What I was doing when the application crashed:
Clicked button to safely remove USB devive, shortly after dolphin crashed. Happens like very 4-5 times.

 -- Backtrace:
Application: Dolphin (dolphin), signal: Segmentation fault
[KCrash Handler]
#6  0xb6175829 in QUrl::QUrl(QUrl const&) () from /usr/lib/libQtCore.so.4
#7  0xb6d94d89 in KUrl::KUrl(KUrl const&) () from /usr/lib/libkdecore.so.5
#8  0xb770a28e in KFileItem::url() const () from /usr/lib/libkio.so.5
#9  0xb76f975f in KDirModel::indexForItem(KFileItem const&) const () from /usr/lib/libkio.so.5
#10 0xb75d3a36 in KFilePreviewGenerator::Private::orderItems(KFileItemList&) () from /usr/lib/libkfile.so.4
#11 0xb75d76bd in KFilePreviewGenerator::Private::updateIcons(KFileItemList const&) () from /usr/lib/libkfile.so.4
#12 0xb75d7902 in KFilePreviewGenerator::Private::delayedIconUpdate() () from /usr/lib/libkfile.so.4
#13 0xb75d89a6 in KFilePreviewGenerator::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libkfile.so.4
#14 0xb61d7263 in QMetaObject::activate(QObject*, int, int, void**) () from /usr/lib/libQtCore.so.4
#15 0xb61d7ec2 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/libQtCore.so.4
#16 0xb6211667 in QTimer::timeout() () from /usr/lib/libQtCore.so.4
#17 0xb61dc9ae in QTimer::timerEvent(QTimerEvent*) () from /usr/lib/libQtCore.so.4
#18 0xb61d13bf in QObject::event(QEvent*) () from /usr/lib/libQtCore.so.4
#19 0xb63d6f54 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#20 0xb63de67c in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#21 0xb70e0bfa in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#22 0xb61c16cb in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#23 0xb61ee7ce in ?? () from /usr/lib/libQtCore.so.4
#24 0xb61ec0e0 in ?? () from /usr/lib/libQtCore.so.4
#25 0xb57cde88 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#26 0xb57d1730 in ?? () from /lib/libglib-2.0.so.0
#27 0xb57d1863 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#28 0xb61ec02c in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#29 0xb6477be5 in ?? () from /usr/lib/libQtGui.so.4
#30 0xb61bfc79 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#31 0xb61c00ca in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#32 0xb61c253f in QCoreApplication::exec() () from /usr/lib/libQtCore.so.4
#33 0xb63d6dd7 in QApplication::exec() () from /usr/lib/libQtGui.so.4
#34 0x0807a745 in _start ()

This bug may be a duplicate of or related to bug 230980

Reported using DrKonqi
Comment 1 Frank Reininghaus 2010-03-18 16:08:51 UTC
This crash is fixed in KDE 4.3.5 and later. Thanks for reporting!

*** This bug has been marked as a duplicate of bug 211525 ***