Bug 230980 - Dolphin crashed while starting unmount USB stick.
Summary: Dolphin crashed while starting unmount USB stick.
Status: RESOLVED DUPLICATE of bug 211525
Alias: None
Product: dolphin
Classification: Applications
Component: general (show other bugs)
Version: 16.12.2
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Peter Penz
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-03-16 15:47 UTC by Steffen Koch
Modified: 2010-03-16 16:56 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Steffen Koch 2010-03-16 15:47:21 UTC
Application that crashed: dolphin
Version of the application: 1.3
KDE Version: 4.3.2 (KDE 4.3.2)
Qt Version: 4.5.2
Operating System: Linux 2.6.31-20-generic i686
Distribution: Ubuntu 9.10

What I was doing when the application crashed:
I copied a zip file on my usb stick. When I unmount the stick with dolphin, dolphin crashed.

 -- Backtrace:
Application: Dolphin (dolphin), signal: Segmentation fault
[KCrash Handler]
#6  0x012f4829 in QUrl (this=0xbf857198, other=...) at io/qurl.cpp:3936
#7  0x01087d89 in KUrl (this=0xbf857198, _u=...) at ../../kdecore/io/kurl.cpp:468
#8  0x00a2f28e in KFileItem::url (this=0x8f51dc8) at ../../kio/kio/kfileitem.cpp:1271
#9  0x00a1e75f in KDirModel::indexForItem (this=0x9138bc0, item=...) at ../../kio/kio/kdirmodel.cpp:919
#10 0x00caba36 in KFilePreviewGenerator::Private::orderItems (this=0x94021b0, items=...) at ../../kfile/kfilepreviewgenerator.cpp:1023
#11 0x00caf6bd in KFilePreviewGenerator::Private::updateIcons (this=0x94021b0, items=...) at ../../kfile/kfilepreviewgenerator.cpp:508
#12 0x00caf902 in KFilePreviewGenerator::Private::delayedIconUpdate (this=0x94021b0) at ../../kfile/kfilepreviewgenerator.cpp:1088
#13 0x00cb09a6 in KFilePreviewGenerator::qt_metacall (this=0x9402048, _c=QMetaObject::InvokeMetaMethod, _id=14, _a=0xbf8573ec) at ./kfilepreviewgenerator.moc:95
#14 0x01356263 in QMetaObject::activate (sender=0x92c9958, from_signal_index=4, to_signal_index=4, argv=0x0) at kernel/qobject.cpp:3113
#15 0x01356ec2 in QMetaObject::activate (sender=0x92c9958, m=0x1431904, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3187
#16 0x01390667 in QTimer::timeout (this=0x92c9958) at .moc/release-shared/moc_qtimer.cpp:128
#17 0x0135b9ae in QTimer::timerEvent (this=0x92c9958, e=0xbf857880) at kernel/qtimer.cpp:261
#18 0x013503bf in QObject::event (this=0x92c9958, e=0xbf857880) at kernel/qobject.cpp:1075
#19 0x01f55f54 in QApplicationPrivate::notify_helper (this=0x8f1cf28, receiver=0x92c9958, e=0xbf857880) at kernel/qapplication.cpp:4056
#20 0x01f5d67c in QApplication::notify (this=0xbf857bec, receiver=0x92c9958, e=0xbf857880) at kernel/qapplication.cpp:3603
#21 0x0064ebfa in KApplication::notify (this=0xbf857bec, receiver=0x92c9958, event=0xbf857880) at ../../kdeui/kernel/kapplication.cpp:302
#22 0x013406cb in QCoreApplication::notifyInternal (this=0xbf857bec, receiver=0x92c9958, event=0xbf857880) at kernel/qcoreapplication.cpp:610
#23 0x0136d7ce in QCoreApplication::sendEvent (this=0x8f1fd9c) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:213
#24 QTimerInfoList::activateTimers (this=0x8f1fd9c) at kernel/qeventdispatcher_unix.cpp:572
#25 0x0136b0e0 in timerSourceDispatch (source=0x8f1fd68) at kernel/qeventdispatcher_glib.cpp:165
#26 0x06787e88 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#27 0x0678b730 in ?? () from /lib/libglib-2.0.so.0
#28 0x0678b863 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#29 0x0136b02c in QEventDispatcherGlib::processEvents (this=0x8effa30, flags=...) at kernel/qeventdispatcher_glib.cpp:327
#30 0x01ff6be5 in QGuiEventDispatcherGlib::processEvents (this=0x8effa30, flags=...) at kernel/qguieventdispatcher_glib.cpp:202
#31 0x0133ec79 in QEventLoop::processEvents (this=0xbf857b44, flags=) at kernel/qeventloop.cpp:149
#32 0x0133f0ca in QEventLoop::exec (this=0xbf857b44, flags=...) at kernel/qeventloop.cpp:201
#33 0x0134153f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#34 0x01f55dd7 in QApplication::exec () at kernel/qapplication.cpp:3525
#35 0x0807a745 in _start ()

Reported using DrKonqi
Comment 1 Frank Reininghaus 2010-03-16 16:56:51 UTC
This is fixed in KDE 4.3.5 and later. Thanks for reporting!

*** This bug has been marked as a duplicate of bug 211525 ***