Bug 230661 - Dolphin crashed while opening file with Kwrite
Summary: Dolphin crashed while opening file with Kwrite
Status: RESOLVED DUPLICATE of bug 222324
Alias: None
Product: dolphin
Classification: Applications
Component: general (show other bugs)
Version: 16.12.2
Platform: Debian unstable Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Peter Penz
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-03-14 08:43 UTC by Valery Mamonov
Modified: 2010-03-14 10:29 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Valery Mamonov 2010-03-14 08:43:15 UTC
Application: dolphin (1.4)
KDE Platform Version: 4.4.1 (KDE 4.4.1)
Qt Version: 4.6.2
Operating System: Linux 2.6.33-0.dmz.4-liquorix-amd64 x86_64
Distribution: Debian GNU/Linux unstable (sid)

-- Information about the crash:
Navigate to needed file
Open it with Kwrite
Crash!
PS
crash happens randomly

 -- Backtrace:
Application: Dolphin (dolphin), signal: Segmentation fault
[Current thread is 1 (Thread 0x7fafb7535800 (LWP 31660))]

Thread 3 (Thread 0x7fafb1811710 (LWP 31741)):
#0  pthread_cond_timedwait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:211
#1  0x0000003d80814f41 in ?? () from /usr/lib/libxine.so.1
#2  0x0000003d736068ba in start_thread (arg=<value optimized out>) at pthread_create.c:300
#3  0x0000003d746cf25d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#4  0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7fafabfff710 (LWP 32342)):
[KCrash Handler]
#5  0x0000003aeac89194 in QThreadPrivate::finish (arg=<value optimized out>) at thread/qthread_unix.cpp:280
#6  0x0000003aeac895dd in ~__pthread_cleanup_class (arg=<value optimized out>) at /usr/include/pthread.h:535
#7  QThreadPrivate::start (arg=<value optimized out>) at thread/qthread_unix.cpp:253
#8  0x0000003d736068ba in start_thread (arg=<value optimized out>) at pthread_create.c:300
#9  0x0000003d746cf25d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#10 0x0000000000000000 in ?? ()
The current source language is "auto; currently asm".

Thread 1 (Thread 0x7fafb7535800 (LWP 31660)):
#0  0x0000003d746c4283 in *__GI___poll (fds=<value optimized out>, nfds=<value optimized out>, timeout=<value optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x0000003bb6e098fa in ?? () from /usr/lib/libxcb.so.1
#2  0x0000003bb6e0b8ac in xcb_wait_for_reply () from /usr/lib/libxcb.so.1
#3  0x0000003bb724f593 in _XReply () from /usr/lib/libX11.so.6
#4  0x0000003bb722c6d7 in XGetWindowProperty () from /usr/lib/libX11.so.6
#5  0x00007fafb48ba5fb in Bespin::XProperty::handleProperty(unsigned long, unsigned long, unsigned char**, Bespin::XProperty::Type, unsigned long) () from /usr/lib/libQtBespin.so
#6  0x00007fafb4b31836 in Bespin::Style::drawWindowBg(QStyleOption const*, QPainter*, QWidget const*) const () from /usr/lib/qt4/plugins/styles/libbespin.so
#7  0x0000003bb88553e9 in QWidgetPrivate::paintBackground (this=<value optimized out>, painter=<value optimized out>, rgn=<value optimized out>, flags=<value optimized out>)
    at kernel/qwidget.cpp:2200
#8  0x0000003bb88562b4 in QWidgetPrivate::drawWidget (this=<value optimized out>, pdev=<value optimized out>, rgn=<value optimized out>, offset=<value optimized out>, flags=<value optimized out>, 
    sharedPainter=<value optimized out>, backingStore=) at kernel/qwidget.cpp:5317
#9  0x0000003bb8a0f5d5 in QWidgetBackingStore::sync (this=<value optimized out>) at painting/qbackingstore.cpp:1291
#10 0x0000003bb88471c0 in QWidgetPrivate::syncBackingStore (this=<value optimized out>) at kernel/qwidget.cpp:1672
#11 0x0000003bb884dec5 in QWidget::event (this=<value optimized out>, event=<value optimized out>) at kernel/qwidget.cpp:8291
#12 0x0000003bb8c0f05b in QMainWindow::event (this=<value optimized out>, event=<value optimized out>) at widgets/qmainwindow.cpp:1433
#13 0x0000003bbab47a53 in KXmlGuiWindow::event (this=<value optimized out>, ev=<value optimized out>) at ../../kdeui/xmlgui/kxmlguiwindow.cpp:131
#14 0x0000003bb87f78fc in QApplicationPrivate::notify_helper (this=<value optimized out>, receiver=<value optimized out>, e=<value optimized out>) at kernel/qapplication.cpp:4300
#15 0x0000003bb87fdddb in QApplication::notify (this=<value optimized out>, receiver=<value optimized out>, e=<value optimized out>) at kernel/qapplication.cpp:4183
#16 0x0000003bbaa31336 in KApplication::notify (this=<value optimized out>, receiver=<value optimized out>, event=<value optimized out>) at ../../kdeui/kernel/kapplication.cpp:302
#17 0x0000003aead7dddc in QCoreApplication::notifyInternal (this=<value optimized out>, receiver=<value optimized out>, event=<value optimized out>) at kernel/qcoreapplication.cpp:704
#18 0x0000003aead80557 in QCoreApplication::sendEvent (receiver=<value optimized out>, event_type=<value optimized out>, data=<value optimized out>)
    at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#19 QCoreApplicationPrivate::sendPostedEvents (receiver=<value optimized out>, event_type=<value optimized out>, data=<value optimized out>) at kernel/qcoreapplication.cpp:1345
#20 0x0000003aeada76f3 in QCoreApplication::sendPostedEvents (s=<value optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#21 postEventSourceDispatch (s=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:276
#22 0x0000003aea03e292 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#23 0x0000003aea0420f8 in ?? () from /lib/libglib-2.0.so.0
#24 0x0000003aea0422ac in g_main_context_iteration () from /lib/libglib-2.0.so.0
#25 0x0000003aeada7233 in QEventDispatcherGlib::processEvents (this=<value optimized out>, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:412
#26 0x0000003bb88a732e in QGuiEventDispatcherGlib::processEvents (this=<value optimized out>, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#27 0x0000003aead7c702 in QEventLoop::processEvents (this=<value optimized out>, flags=<value optimized out>) at kernel/qeventloop.cpp:149
#28 0x0000003aead7cadc in QEventLoop::exec (this=<value optimized out>, flags=<value optimized out>) at kernel/qeventloop.cpp:201
#29 0x0000003aead8081b in QCoreApplication::exec () at kernel/qcoreapplication.cpp:981
#30 0x000000000043adb5 in _start ()
The current source language is "auto; currently c".

This bug may be a duplicate of or related to bug 230517.

Possible duplicates by query: bug 230517, bug 230394, bug 229973, bug 229270, bug 229075.

Reported using DrKonqi
Comment 1 Frank Reininghaus 2010-03-14 10:29:12 UTC
Thanks for the bug report! This crash has been fixed for KDE SC 4.4.2.

*** This bug has been marked as a duplicate of bug 222324 ***