Bug 230268 - Dolphin crased when running rpmbuild in Fn 4 terminal
Summary: Dolphin crased when running rpmbuild in Fn 4 terminal
Status: RESOLVED DUPLICATE of bug 222547
Alias: None
Product: dolphin
Classification: Applications
Component: general (show other bugs)
Version: 16.12.2
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Peter Penz
URL:
Keywords:
: 249886 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-03-10 23:24 UTC by Simon Lewis
Modified: 2010-09-02 13:14 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Simon Lewis 2010-03-10 23:24:44 UTC
Application: dolphin (1.4)
KDE Platform Version: 4.4.00 (KDE 4.4.0)
Qt Version: 4.6.2
Operating System: Linux 2.6.32.9-70.fc12.x86_64 x86_64

-- Information about the crash:
Dolphin crased when running rpmbuild in Fn 4 terminal

 -- Backtrace:
Application: Dolphin (dolphin), signal: Segmentation fault
82	T_PSEUDO (SYSCALL_SYMBOL, SYSCALL_NAME, SYSCALL_NARGS)
[KCrash Handler]
#5  ref (this=0x1f69208) at /usr/include/QtCore/qatomic_x86_64.h:121
#6  QList (this=0x1f69208) at /usr/include/QtCore/qlist.h:114
#7  QForeachContainer (this=0x1f69208) at /usr/include/QtCore/qglobal.h:2227
#8  KDirWatchPrivate::Entry::propagate_dirty (this=0x1f69208) at /usr/src/debug/kdelibs-4.4.0/kio/kio/kdirwatch.cpp:416
#9  0x0000003c9a926629 in KDirWatchPrivate::Entry::propagate_dirty (this=<value optimized out>) at /usr/src/debug/kdelibs-4.4.0/kio/kio/kdirwatch.cpp:421
#10 0x0000003c9a92fd9f in KDirWatchPrivate::slotRescan (this=0x1ad3090) at /usr/src/debug/kdelibs-4.4.0/kio/kio/kdirwatch.cpp:1349
#11 0x0000003c9a930954 in KDirWatchPrivate::qt_metacall (this=0x1ad3090, _c=InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff15c82480)
    at /usr/src/debug/kdelibs-4.4.0/x86_64-redhat-linux-gnu/kio/kdirwatch_p.moc:81
#12 0x00000039f756a2af in QMetaObject::activate (sender=0x1ad30f8, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x0) at kernel/qobject.cpp:3293
#13 0x00000039f756663e in QObject::event (this=0x1ad30f8, e=0x7fff15c82bd0) at kernel/qobject.cpp:1212
#14 0x0000003c98faa9dc in QApplicationPrivate::notify_helper (this=0x1994a70, receiver=0x1ad30f8, e=0x7fff15c82bd0) at kernel/qapplication.cpp:4300
#15 0x0000003c98fb0aab in QApplication::notify (this=<value optimized out>, receiver=0x1ad30f8, e=0x7fff15c82bd0) at kernel/qapplication.cpp:4183
#16 0x0000003c9a2067a6 in KApplication::notify (this=0x7fff15c82f20, receiver=0x1ad30f8, event=0x7fff15c82bd0) at /usr/src/debug/kdelibs-4.4.0/kdeui/kernel/kapplication.cpp:302
#17 0x00000039f755774c in QCoreApplication::notifyInternal (this=0x7fff15c82f20, receiver=0x1ad30f8, event=0x7fff15c82bd0) at kernel/qcoreapplication.cpp:704
#18 0x00000039f757fe02 in sendEvent (this=0x199f540) at kernel/qcoreapplication.h:215
#19 QTimerInfoList::activateTimers (this=0x199f540) at kernel/qeventdispatcher_unix.cpp:603
#20 0x00000039f757d398 in timerSourceDispatch (source=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#21 idleTimerSourceDispatch (source=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:231
#22 0x0000003a0ee3920e in g_main_dispatch (context=0x199e520) at gmain.c:1960
#23 IA__g_main_context_dispatch (context=0x199e520) at gmain.c:2513
#24 0x0000003a0ee3cbf8 in g_main_context_iterate (context=0x199e520, block=<value optimized out>, dispatch=<value optimized out>, self=<value optimized out>) at gmain.c:2591
#25 0x0000003a0ee3cd1a in IA__g_main_context_iteration (context=0x199e520, may_block=1) at gmain.c:2654
#26 0x00000039f757d063 in QEventDispatcherGlib::processEvents (this=0x1966c60, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:412
#27 0x0000003c99049a1e in QGuiEventDispatcherGlib::processEvents (this=<value optimized out>, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#28 0x00000039f7556192 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#29 0x00000039f755645c in QEventLoop::exec (this=0x7fff15c82e70, flags=...) at kernel/qeventloop.cpp:201
#30 0x00000039f7558749 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:981
#31 0x00000000004374e5 in main (argc=<value optimized out>, argv=<value optimized out>) at /usr/src/debug/kdebase-4.4.0/apps/dolphin/src/main.cpp:101

Possible duplicates by query: bug 227694, bug 224229, bug 222547, bug 221469, bug 216086.

Reported using DrKonqi
Comment 1 Dario Andres 2010-03-12 20:36:56 UTC
Fixed in KDE SC 4.4.1. Regards

*** This bug has been marked as a duplicate of bug 222547 ***
Comment 2 Christopher Yeleighton 2010-09-02 13:14:20 UTC
*** Bug 249886 has been marked as a duplicate of this bug. ***