Bug 228850 - Spider solver falsely reports game as "not winnable"
Summary: Spider solver falsely reports game as "not winnable"
Status: RESOLVED DUPLICATE of bug 185211
Alias: None
Product: kpat
Classification: Applications
Component: solver (show other bugs)
Version: unspecified
Platform: Gentoo Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Stephan Kulow
URL:
Keywords:
: 251700 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-02-28 04:59 UTC by Scott Steger
Modified: 2011-01-26 11:59 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Savegame for the state described in this bug report (5.74 KB, application/octet-stream)
2010-02-28 05:02 UTC, Scott Steger
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Scott Steger 2010-02-28 04:59:46 UTC
Version:            (using KDE 4.3.5)
Compiler:          gcc (Gentoo 4.3.4 p1.0, pie-10.1.5) 4.3.4 
OS:                Linux
Installed from:    Gentoo Packages

The solver reports a certain Spider state as "not winnable" when it is.  I will attach a savegame for this state in a separate post.

One straightforward move results in the solver finding a solution to the game.

This bug is reproducible on both Gentoo stable (KDE 4.3.5) and Ubuntu Karmic (KDE 4.3.2).  I haven't been able to test it in KDE 4.4.x yet.
Comment 1 Scott Steger 2010-02-28 05:02:07 UTC
Created attachment 41185 [details]
Savegame for the state described in this bug report

This is a savegame exhibiting the bug.  Initially, the solver reports the state as "not winnable."  By moving the nine of spades from the leftmost column onto the ten of spades in the 5th column, the game becomes winnable.  I have successfully solved the game from this state.
Comment 2 Scott Steger 2010-02-28 05:05:09 UTC
Oh, and the KPatience version is 3.2.  I didn't see a place to enter that earlier.
Comment 3 Parker Coates 2010-02-28 05:56:13 UTC
Thanks for the report. I can reproduce with the latest trunk.
Comment 4 Parker Coates 2010-09-19 17:11:24 UTC
*** Bug 251700 has been marked as a duplicate of this bug. ***
Comment 5 Stephan Kulow 2011-01-26 11:59:31 UTC

*** This bug has been marked as a duplicate of bug 185211 ***