Bug 228379 - Random KBuildSycoca Segfault, various causes
Summary: Random KBuildSycoca Segfault, various causes
Status: RESOLVED DUPLICATE of bug 202871
Alias: None
Product: kdelibs
Classification: Frameworks and Libraries
Component: ksycoca (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: David Faure
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-02-24 22:32 UTC by eztenia
Modified: 2010-02-24 22:42 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description eztenia 2010-02-24 22:32:46 UTC
Application that crashed: kbuildsycoca4
Version of the application: 1.1
KDE Version: 4.3.2 (KDE 4.3.2)
Qt Version: 4.5.2
Operating System: Linux 2.6.31-19-generic x86_64
Distribution: Ubuntu 9.10

What I was doing when the application crashed:
I use GNOME, and this error appears twice every startup, twice every time an application is installed, and once whenever I change something in "Main Menu". It's very annoying.

 -- Backtrace:
Application: KBuildSycoca (kdeinit4), signal: Segmentation fault
The current source language is "auto; currently c".
[KCrash Handler]
#5  KSycocaEntry::offset (this=0x0) at ../../kdecore/sycoca/ksycocaentry.cpp:133
#6  0x00007f55d93175dd in KBuildMimeTypeFactory::savePatternLists (this=0x1347980, str=<value optimized out>) at ../../kded/kbuildmimetypefactory.cpp:361
#7  0x00007f55d9317a93 in KBuildMimeTypeFactory::save (this=0x1347980, str=...) at ../../kded/kbuildmimetypefactory.cpp:307
#8  0x00007f55d9310da9 in KBuildSycoca::save (this=0x17b3a80, str=0x13374a0) at ../../kded/kbuildsycoca.cpp:525
#9  0x00007f55d9313ab3 in KBuildSycoca::recreate (this=0x17b3a80) at ../../kded/kbuildsycoca.cpp:433
#10 0x00007f55d9314ee6 in kdemain (argc=<value optimized out>, argv=<value optimized out>) at ../../kded/kbuildsycoca.cpp:829
#11 0x0000000000406da8 in launch (argc=2, _name=<value optimized out>, args=<value optimized out>, cwd=<value optimized out>, envc=16, envs=<value optimized out>, reset_env=false, tty=0x0, 
    avoid_loops=false, startup_id_str=0x12aa5ad "") at ../../kinit/kinit.cpp:677
#12 0x0000000000407aa0 in handle_launcher_request (sock=7, who=<value optimized out>) at ../../kinit/kinit.cpp:1169
#13 0x0000000000407f51 in handle_requests (waitForPid=0) at ../../kinit/kinit.cpp:1362
#14 0x0000000000408bb2 in main (argc=2, argv=<value optimized out>, envp=<value optimized out>) at ../../kinit/kinit.cpp:1793

This bug may be a duplicate of or related to bug 219494

Reported using DrKonqi
Comment 1 David Faure 2010-02-24 22:42:11 UTC
Fixed in 4.3.5, please upgrade.

*** This bug has been marked as a duplicate of bug 202871 ***