Bug 219494 - KBuildSycoca randomly crashing with segmentation fault
Summary: KBuildSycoca randomly crashing with segmentation fault
Status: RESOLVED DUPLICATE of bug 202871
Alias: None
Product: kdelibs
Classification: Frameworks and Libraries
Component: ksycoca (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: David Faure
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-12-21 00:32 UTC by Scott Garrett
Modified: 2009-12-21 15:22 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Scott Garrett 2009-12-21 00:32:07 UTC
Application that crashed: kbuildsycoca4
Version of the application: 1.1
KDE Version: 4.3.4 (KDE 4.3.4)
Qt Version: 4.5.3
Operating System: Linux 2.6.32-zen2-demonmachine-06461-g4ba907a i686

What I was doing when the application crashed:
KBuildSyscoca keeps crashing with a segmentation fault.  I don't know what is causing it.  The first time, it occurred after I closed a window, again when I was playing with the panels, and again when I started KDE.

 -- Backtrace:
Application: KBuildSycoca (kdeinit4), signal: Segmentation fault
[KCrash Handler]
#6  0xb7577757 in KSycocaEntry::offset() const () from /usr/lib/libkdecore.so.5
#7  0xb417e71f in KBuildMimeTypeFactory::save(QDataStream&) () from /usr/lib/libkdeinit4_kbuildsycoca4.so
#8  0xb417741c in KBuildSycoca::save(QDataStream*) () from /usr/lib/libkdeinit4_kbuildsycoca4.so
#9  0xb417a215 in KBuildSycoca::recreate() () from /usr/lib/libkdeinit4_kbuildsycoca4.so
#10 0xb417b8cf in kdemain () from /usr/lib/libkdeinit4_kbuildsycoca4.so
#11 0x0804de42 in _start ()

This bug may be a duplicate of or related to bug 203322

Reported using DrKonqi
Comment 1 Dario Andres 2009-12-21 15:22:36 UTC
Merging with bug 202871. THanks

*** This bug has been marked as a duplicate of bug 202871 ***