Bug 227246 - konsole resizing is slow as hell
Summary: konsole resizing is slow as hell
Status: RESOLVED DUPLICATE of bug 160467
Alias: None
Product: konsole
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Mandriva RPMs Linux
: NOR normal with 40 votes (vote)
Target Milestone: ---
Assignee: Konsole Developer
URL:
Keywords:
: 216937 272763 275619 276734 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-02-16 19:38 UTC by gambas
Modified: 2011-07-29 11:44 UTC (History)
11 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description gambas 2010-02-16 19:38:35 UTC
Version:            (using KDE 4.4.0)
OS:                Linux
Installed from:    Mandriva RPMs

I have a NVIDIA card, and I use the "nouveau" driver, because desktop composition with XRender and "nouveau" is faster than with OpenGL and the NVIDIA proprietary driver!

I noticed only one problem: resizing a konsole window is slow as hell. I'm using the Terminus bitmap font with font antialiasing disabled, and 1000 lines of history.

Disabling desktop composition changes nothing.

Could it be a bug in the "nouveau" driver digged up by konsole, or could it be a bug in konsole itself?

Distribution: Mandriva 2010.0
CPU: Intel Core2 Duo E6550
Video card: NVIDIA GeForce 8300 GS
Comment 1 Dario Andres 2010-02-16 22:08:27 UTC
Does running the app as "konsole --notransparency" (as suggested on bug 216937) "fixes" this ? Regards
Comment 2 gambas 2010-02-16 23:12:17 UTC
I didn't test whayt you suggested because of the following behaviour I find very strange:

I closed the two opened konsoles, and I opened them back, and recreated exactly the same tabs, with the same profiles, and resizing works normally now. 

I have installed KDE 4.4 very recently, and so my session was not restored from hibernation, so the two konsole processes were fresh.

How is it possible???

I will see what happens the next time I restore my session.
Comment 3 gambas 2010-02-17 19:00:00 UTC
After logging out and logging in, the konsole resizing problem comes back again. Only with the restored konsole windows. Newly opened konsole windows resize slowly too now.
Comment 4 gambas 2010-02-17 19:02:00 UTC
...and running "konsole --notransparency" fixes the problem.
Comment 5 Dario Andres 2010-02-20 22:47:17 UTC
So, for the resizing issue, it could be somehow merged with bug 216937. Not sure about the second issue you mentioned (I'm not a Konsole dev)
Regards
Comment 6 gambas 2010-03-22 21:03:11 UTC
Not fixed in KDE 4.4.1
Comment 7 Vadym Krevs 2010-03-26 00:20:55 UTC
Can confirm that it is not fixed in KDE 4.4.1 from openSUSE 11.2 for x86_64 and ATI video card/latest proprietary driver.
Comment 8 gambas 2010-07-12 15:31:12 UTC
Not fixed in KDE 4.4.3, with NVIDIA proprietary driver.
Comment 9 b.schwehn 2010-07-24 13:33:01 UTC
*** This bug has been confirmed by popular vote. ***
Comment 10 Andrew M 2011-06-04 04:14:08 UTC
It's even worse in 4.7 b1.

Resizing a transparent Konsole window makes the whole screen flicker and shows blocky artefacts. If I keep resizing it the GPU will hang. Magic SysRq keys still work so it hasn't completely exploded the kernel.

It is reproducible by simply resizing a Konsole window with transparency (compositing on of course) on an Nvidia card.

Only happens with Konsole. Other windows are fine.

Running on an Nvidia 9300GM and proprietary driver 270.41.19

kernel.log gives me this:
[  156.365528] NVRM: Xid (0000:01:00): 13, 0001 00000000 00005097 000015e0 00000000 00000100
[  156.429173] NVRM: Xid (0000:01:00): 13, 0001 00000000 00005097 000015e0 00000000 00000100
[  156.573128] NVRM: Xid (0000:01:00): 13, 0001 00000000 00005097 000015e0 00000000 00000100
[  185.593947] NVRM: Xid (0000:01:00): 13, 0001 00000000 00005097 000015e0 00000000 00000100
Comment 11 Christoph Feck 2011-07-11 12:22:28 UTC
*** Bug 216937 has been marked as a duplicate of this bug. ***
Comment 12 Christoph Feck 2011-07-11 12:23:24 UTC
*** Bug 275619 has been marked as a duplicate of this bug. ***
Comment 13 Christoph Feck 2011-07-11 12:24:07 UTC
*** Bug 276734 has been marked as a duplicate of this bug. ***
Comment 14 Christoph Feck 2011-07-11 12:24:51 UTC
Someone said that for NVIDIA, this is fixed with 275.09.04 driver, see http://www.nvnews.net/vbulletin/showthread.php?t=163161
Comment 15 Christoph Feck 2011-07-11 12:25:30 UTC
*** Bug 272763 has been marked as a duplicate of this bug. ***
Comment 16 Kornel Jankowski 2011-07-22 12:42:27 UTC
In my case it manages to freeze the whole system and makes it unable to switch to a tty or to restart the X server. using KDE 4.6.5, an nvidia 9600 on the proprietary driver.
Comment 17 Ojec Borec 2011-07-22 17:49:24 UTC
In my case it freeses the whole system too. KDE 4.7 RC2 + nvidia properietary driver 270.41.19.
Comment 18 Christoph Feck 2011-07-22 20:50:19 UTC
Ojec, did you read comment #14?
Comment 19 Kornel Jankowski 2011-07-23 14:28:37 UTC
The new nvidia drives doesn't fix a thing. And, by the way, if it's the driver, then how the hell can it happen only to konsole? I used to have the same situation with emacs, and after updating emacs the situation went back to normal.
Comment 20 Christoph Feck 2011-07-23 17:01:13 UTC
Kornel, if NVIDIA still didn't fix the ARGB issues in their driver, I suggest to report it to their forum. The problem is only visible with Konsole, because it uses ARGB visuals. See comment #1.
Comment 21 Ojec Borec 2011-07-23 22:27:28 UTC
New version of drivers nvidia-drivers-275.19 helped. At least for me. Thanks you.
Comment 22 Christoph Feck 2011-07-29 11:44:33 UTC

*** This bug has been marked as a duplicate of bug 160467 ***