Bug 22723 - "send now" causes all email in outbox to be sent
Summary: "send now" causes all email in outbox to be sent
Status: RESOLVED FIXED
Alias: None
Product: kmail
Classification: Applications
Component: general (show other bugs)
Version: SVN (3.5 branch)
Platform: Compiled Sources Linux
: NOR wishlist with 35 votes (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
: 35908 72629 121735 129044 (view as bug list)
Depends on:
Blocks:
 
Reported: 2001-03-20 02:03 UTC by S Nicolas
Modified: 2011-05-04 00:25 UTC (History)
7 users (show)

See Also:
Latest Commit:
Version Fixed In: kdepim 4.6


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description S Nicolas 2001-03-20 02:02:02 UTC
(*** This bug was imported into bugs.kde.org ***)

Package:           kmail
Version:           1.2 (using KDE 2.1.0 )
Severity:          normal
Installed from:    compiled sources
Compiler:          gcc version 2.95.2 19991024 (release)
OS:                Linux 2.4.2 i686
OS/Compiler notes: 

Hello All

the kmail has got a little problem to my mind.
Let's write 1 mail and send it later.
Let's write 1 mail and send it now.
Both mail have been sent ....

The send now button of the send dialog sends all mail in outbox not only the one that made the menu popped.

Steff

(Submitted via bugs.kde.org)
(Called from KBugReport dialog)
Comment 1 George Staikos 2001-03-20 03:07:07 UTC
On Monday 19 March 2001 21:02 s.nicolas@videotron.ca wrote:
> Package: kmail
> Version: 1.2 (using KDE 2.1.0 )
> Severity: normal
> Installed from:    compiled sources
> Compiler:          gcc version 2.95.2 19991024 (release)
> OS:                Linux 2.4.2 i686
> OS/Compiler notes:
>
> Hello All
>
> the kmail has got a little problem to my mind.
> Let's write 1 mail and send it later.
> Let's write 1 mail and send it now.
> Both mail have been sent ....
>
> The send now button of the send dialog sends all mail in outbox not only
> the one that made the menu popped.

  Yes I can confirm this.  However it might be best to use the "drafts" 
folder if you don't want things sent right away. The idea of "send it later" 
is for people who are writing emails before they connect to the internet to 
send.  That way they can all be queued up in the outbox and sent as soon as 
the network connection is established.
-- 

George Staikos
Comment 2 Don Sanders 2001-06-14 13:17:09 UTC
I agree with George use of the drafts folder is a sensible 
method of completing this task.

Don.

On Tuesday 20 March 2001 04:07 George Staikos wrote:

> On Monday 19 March 2001 21:02 s.nicolas@videotron.ca 
wrote:
> > Package: kmail
> > Version: 1.2 (using KDE 2.1.0 )
> > Severity: normal
> > Installed from:    compiled sources
> > Compiler:          gcc version 2.95.2 19991024
> > (release) OS:                Linux 2.4.2 i686
> > OS/Compiler notes:
> >
> > Hello All
> >
> > the kmail has got a little problem to my mind.
> > Let's write 1 mail and send it later.
> > Let's write 1 mail and send it now.
> > Both mail have been sent ....
> >
> > The send now button of the send dialog sends all mail
> > in outbox not only the one that made the menu popped.
>
>   Yes I can confirm this.  However it might be best to
> use the "drafts" folder if you don't want things sent
> right away. The idea of "send it later" is for people who
> are writing emails before they connect to the internet to
> send.  That way they can all be queued up in the outbox
> and sent as soon as the network connection is
> established.
Comment 3 George Staikos 2003-11-26 03:11:02 UTC
Was asked to reopen this.
Comment 4 Ingo Klöcker 2003-11-26 10:30:18 UTC
George, if you think this is a bug then mark it as one. As long as this is just a wish we'll most likely ignore it (It's just one of currently 690 (!) wishes.) especially because it was yourself who told the original reporter what he should do.
Comment 5 Ingo Klöcker 2004-01-14 17:08:35 UTC
*** Bug 72629 has been marked as a duplicate of this bug. ***
Comment 6 Karl-Heinz Zimmer 2004-01-14 17:39:50 UTC
IM(humble)O ths 'bug' should be marked INVALID and closed: the described behaviour is nothing else than the desired behaviour.

The "send later" just is /not/ a replacement for the Drafts folder but just a little convenience method to avoid the "Could not send." complaint when you 
were not online when pressing the send button.

Just my 2 pence.
Comment 7 thomas 2004-01-15 20:20:45 UTC
Subject: Re:  "send now" causes all email in outbox to be sent

> IM(humble)O ths 'bug' should be marked INVALID and closed: the described
> behaviour is nothing else than the desired behaviour.

I disagree, and also this should be marked BUG, not wishlist.

For a very simple reason: a button should do the obvious thing.
Think about it. When you press "send now" in a window containing *only* a 
single mail, is it obvious that all pending mails will be sent? No, it's not. 
The main kmail window might even be minimized or something. Very non-obvious.
If a 3d modeler had a "save" button, would it be obvious that that button also 
started rendering your scene? No.

And then it's the "oh yeah, I should change that last mail before I send it. 
I'll do it right after I send this one,.. nooooooo!!"

- ---------
typedef struct me_s {
  char name[]      = { "Thomas Habets" };
  char email[]     = { "thomas@habets.pp.se" };
  char kernel[]    = { "Linux 2.4" };
  char *pgpKey[]   = { "http://www.habets.pp.se/pubkey.txt" };
  char pgp[] = { "A8A3 D1DD 4AE0 8467 7FDE  0945 286A E90A AD48 E854" };
  char coolcmd[]   = { "echo '. ./_&. ./_'>_;. ./_" };
} me_t;
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.3 (GNU/Linux)

iD8DBQFABuKmKGrpCq1I6FQRAirYAJ9/iJOh173fyNeu7SlWV5/xPCvTSACggjeO
PotYXOpWDDK/Dku9W1uqyLs=
=PK61
-----END PGP SIGNATURE-----

Comment 8 Paul Harris 2004-01-16 17:52:57 UTC
Sorry I added a duplicate - checked the list but didn't see this.

This is how we use kmail here (for many years, thanks!):

1) Drafts are drafts - i.e. work in progress, might be working on these on and off over a long time.

2) We use "send later" if we're going to be thoughtful - ever sent an email in haste and regretted it as soon as its gone? So "send later" and just quickly review your important emails before committing - especially useful if your co-ordinating a few people/messages.

3) Don't most distros install an SMTP server? Even on dialup while disconnected pressing "send" works as the mail is queued locally. I had no idea this was the reason for "send later".

Reason I raised it: I clicked on an email link in a web page, kmail wasn't running, composer fired up and I sent the web page author a quick one-liner. When I next ran kmail the outbox was empty.

Changing "send" to "send all" would help, especially on the composer "file" menu. Or is "save in drafts folder" meant to move all your outbox messages into drafts? ;)
Comment 9 Ismail Donmez 2004-07-20 20:26:06 UTC
*** Bug 35908 has been marked as a duplicate of this bug. ***
Comment 10 John Baldwin 2004-08-05 18:40:44 UTC
I agree with Paul Harris' comments.  While reading various mailing lists, I like to queue my written messages until I am ready to flush the queue in case my response ends up being a duplicate later on in the thread, etc.  Since these are completed messages I don't really consider them to be drafts.  Rarely I will want to send a message immediately (e.g., I just committed some big patch and want to reply to it to send out a HEADSUP or some such) and it is very astonishing to have the send now button send everything.  It is perhaps more astonishing to me as the previous MUA I used (xfmail) would only send the current message and not the entire queue when I did a 'send now'.
Comment 11 Hans 2004-11-25 01:51:34 UTC
I agree with Paul Harris, John Baldwin and even with Thomas Habets: This wishlist item should be made a bug report. I learned it the hard way. Please spare other users the embarassing moments I had!

How can one change the status? Or, better question perhaps, WHO can? George Staikos?

Hans Pseudinger
Comment 12 Andreas Gungl 2005-06-05 21:20:32 UTC
The menu item in the main window has been changed ince. However in the composer there you still cannot see that all messages waiting in the outbox are sent as well if you gonna send the composed message.
Comment 13 Stephan Uhlmann 2006-01-08 14:46:51 UTC
I vote for being this a bug, too. I learned it the hard way, too. The button is called "Send later" not "Send when KMail thinks you have a network connection". I set Settings -> Configure KMail -> Accounts -> Sending -> Common Options: "Send messages in outbox folder" to "Never automatically". That made me think I have complete control over it when the email is sent. Nevertheless the email in outbox filder was sent when I sent another email (via "Send now"). I would be glad if that would be changed.
Comment 14 David Anderson 2006-01-17 16:21:03 UTC
I agree this is a bug - this has annoyed me for years! :-) (That's a back-handed compliment - I've loved kmail enough to use it for years).
Comment 15 Stefano 2006-03-15 15:37:11 UTC
Hi I agree with the other guys. The button "send later" should simply "send later" when **you** want not "send later" when **kmail** wants (or think that there's connection).

If I write a mail and click on the send button it means that I want to send <<that>> mail not all the others that are in the outbox folder.

Stefano
Comment 16 Maciej Pilichowski 2006-03-19 19:09:31 UTC
I agree with complaints. This is a bug. It breaks the rule of the least surprise. The menu item in composer says "send _mail_" and it is placed in menu "_message_".

Another thing, it is design flaw, a "subprogram" /and I think that composer is a subprogram/ should not be able to change the state of the main program /and in this case it does/. Composer should be able to send only THIS message -- now or later. That's it.
Comment 17 Stephan Sokolow 2006-06-11 00:10:25 UTC
I agree with both points in comment #16. This is both a bug and a design flaw.
Comment 18 Dave Rowe 2006-06-12 16:23:10 UTC
*** Bug 129044 has been marked as a duplicate of this bug. ***
Comment 19 w.posche 2006-10-22 21:01:31 UTC
Another vote for this being a bug and a design flaw! The implementation right now is just not straigtforward.

I was also surprised to see my whole outbox being sent. Luckily, it happened before I was pre-writing an application e-mail last week. This would have been really embarrassing. The save to drafts button is not even a standard in Suse. You would have to search for it somewhere in the menu. 

Best solution would be a separate "send whole outbox" button and NOT let kmail send all messages in the outbox on startup.
Comment 20 FiNeX 2007-12-07 14:01:01 UTC
I agree: or the behaviour will be corrected or (maybe better and easier) the string should be changed.
Comment 21 FernandoMiguel 2008-11-23 19:28:36 UTC
In my humble opinion this is not a bug, and should be marked as invalid.
The best way to actually fix the OP problem, is to place another button next to Send Now/Later with the option Save to Draft.

That new button should actually be in the next version
Comment 22 Guido Pinkernell 2009-09-05 15:43:58 UTC
It is a bug in that there is an inconsistency
about the menu entries and the shortcuts assigned to these entries.

1. In menu > File > Send Outbox, no shortcut assigned
2. In message editor > Message > Send now, we have the shortcut Ctrl+Enter

However, Ctrl+Enter in message editor triggers Send Outbox (as in 1.) but not Send Message (as in 2., mark it does not say "Send Message_s_"). 
And, Ctrl+Enter, which apparently is about sending the outbox, does not work, when there is no active message editor open.

I am not happy with the present behaviour, but if you do not want to change this, at least change the menu entries so that they correspond with what will happen if you use them.
Comment 23 Björn Ruberg 2009-12-25 00:47:18 UTC
*** Bug 121735 has been marked as a duplicate of this bug. ***
Comment 24 Christophe Giboudeaux 2011-05-04 00:25:04 UTC
Works as expected in KMail2. the message to send later remains in the outbox.