Bug 226007 - knetworkmanager crash when restart
Summary: knetworkmanager crash when restart
Status: RESOLVED DUPLICATE of bug 210878
Alias: None
Product: knetworkmanager
Classification: Miscellaneous
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Will Stephenson
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-02-09 09:43 UTC by pablo
Modified: 2010-02-10 13:27 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description pablo 2010-02-09 09:43:26 UTC
Application that crashed: knetworkmanager
Version of the application: v0.9
KDE Version: 4.3.2 (KDE 4.3.2)
Qt Version: 4.5.2
Operating System: Linux 2.6.31-19-generic i686
Distribution: Ubuntu 9.10

What I was doing when the application crashed:
I have personal conection configured into my knetworkmanger and I can't access it at init but if I restart knetworkmanager (sudo service network-manager stop, and then start) then I can connect my personal networks. The problem is when I like restart network-maneger because always crash with the error I send you.

 -- Backtrace:
Application: KNetworkManager (knetworkmanager), signal: Segmentation fault
[KCrash Handler]
#6  0x00c697ee in Knm::Activatable::deviceUni() const () from /usr/lib/libknminternals.so.4
#7  0x004c80f2 in ?? () from /usr/lib/libknmservice.so.4
#8  0x004c821c in ?? () from /usr/lib/libknmservice.so.4
#9  0x004c849d in ?? () from /usr/lib/libknmservice.so.4
#10 0x004c8697 in SortedActivatableList::handleAdd(Knm::Activatable*) () from /usr/lib/libknmservice.so.4
#11 0x004b6d03 in ActivatableList::addActivatableInternal(Knm::Activatable*) () from /usr/lib/libknmservice.so.4
#12 0x004b6d9c in ActivatableList::addActivatable(Knm::Activatable*) () from /usr/lib/libknmservice.so.4
#13 0x004ba767 in WirelessNetworkInterfaceActivatableProvider::handleAdd(Knm::Connection*) () from /usr/lib/libknmservice.so.4
#14 0x004b82fe in NetworkInterfaceActivatableProvider::init() () from /usr/lib/libknmservice.so.4
#15 0x004b7520 in NetworkInterfaceMonitor::networkInterfaceAdded(QString const&) () from /usr/lib/libknmservice.so.4
#16 0x004b0a9b in NetworkInterfaceMonitor::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libknmservice.so.4
#17 0x00815263 in QMetaObject::activate(QObject*, int, int, void**) () from /usr/lib/libQtCore.so.4
#18 0x00815ec2 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/libQtCore.so.4
#19 0x004e98b3 in Solid::Control::NetworkManager::Notifier::networkInterfaceAdded(QString const&) () from /usr/lib/libsolidcontrol.so.4
#20 0x004ea346 in ?? () from /usr/lib/libsolidcontrol.so.4
#21 0x004ea3c7 in ?? () from /usr/lib/libsolidcontrol.so.4
#22 0x00815263 in QMetaObject::activate(QObject*, int, int, void**) () from /usr/lib/libQtCore.so.4
#23 0x00815ec2 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/libQtCore.so.4
#24 0x04ec0143 in NMNetworkManager::networkInterfaceAdded(QString const&) () from /usr/lib/kde4/solid_networkmanager07.so
#25 0x04ec16a8 in NMNetworkManager::deviceAdded(QDBusObjectPath const&) () from /usr/lib/kde4/solid_networkmanager07.so
#26 0x04ec487d in NMNetworkManager::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/kde4/solid_networkmanager07.so
#27 0x00815263 in QMetaObject::activate(QObject*, int, int, void**) () from /usr/lib/libQtCore.so.4
#28 0x00815ec2 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/libQtCore.so.4
#29 0x04ed0e53 in ?? () from /usr/lib/kde4/solid_networkmanager07.so
#30 0x04ed1385 in ?? () from /usr/lib/kde4/solid_networkmanager07.so
#31 0x005257b4 in ?? () from /usr/lib/libQtDBus.so.4
#32 0x0052d197 in ?? () from /usr/lib/libQtDBus.so.4
#33 0x0080f5fe in QObject::event(QEvent*) () from /usr/lib/libQtCore.so.4
#34 0x01097f54 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#35 0x0109f67c in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#36 0x002e2bfa in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#37 0x007ff6cb in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#38 0x008002b2 in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /usr/lib/libQtCore.so.4
#39 0x0080047d in QCoreApplication::sendPostedEvents(QObject*, int) () from /usr/lib/libQtCore.so.4
#40 0x0082a3ff in ?? () from /usr/lib/libQtCore.so.4
#41 0x054ebe88 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#42 0x054ef730 in ?? () from /lib/libglib-2.0.so.0
#43 0x054ef863 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#44 0x0082a02c in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#45 0x01138be5 in ?? () from /usr/lib/libQtGui.so.4
#46 0x007fdc79 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#47 0x007fe0ca in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#48 0x0080053f in QCoreApplication::exec() () from /usr/lib/libQtCore.so.4
#49 0x01097dd7 in QApplication::exec() () from /usr/lib/libQtGui.so.4
#50 0x08052905 in _start ()

This bug may be a duplicate of or related to bug 222322

Reported using DrKonqi
Comment 1 Dario Andres 2010-02-10 13:27:03 UTC
This is being tracked at bug 210878. Regards

*** This bug has been marked as a duplicate of bug 210878 ***