Bug 222322 - knetworkmanager crashes on "restart network-manager"
Summary: knetworkmanager crashes on "restart network-manager"
Status: RESOLVED DUPLICATE of bug 210878
Alias: None
Product: knetworkmanager
Classification: Miscellaneous
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Will Stephenson
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-01-12 03:16 UTC by Jeffrey Schwab
Modified: 2010-01-12 13:40 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jeffrey Schwab 2010-01-12 03:16:35 UTC
Application that crashed: knetworkmanager
Version of the application: v0.9
KDE Version: 4.3.2 (KDE 4.3.2)
Qt Version: 4.5.2
Operating System: Linux 2.6.31-17-generic x86_64
Distribution: Ubuntu 9.10

What I was doing when the application crashed:
This surely looks like a known bug.  Restarting the network manager is not something that comes up often, but my new wifi driver has been acting funkily.

 -- Backtrace:
Application: KNetworkManager (knetworkmanager), signal: Segmentation fault
[KCrash Handler]
#5  0x00007f73ff5a7c8a in Knm::Activatable::deviceUni() const () from /usr/lib/libknminternals.so.4
#6  0x00007f73ff36e193 in ?? () from /usr/lib/libknmservice.so.4
#7  0x00007f73ff36e2b3 in ?? () from /usr/lib/libknmservice.so.4
#8  0x00007f73ff36e50e in ?? () from /usr/lib/libknmservice.so.4
#9  0x00007f73ff36e72c in SortedActivatableList::handleAdd(Knm::Activatable*) () from /usr/lib/libknmservice.so.4
#10 0x00007f73ff35e06b in ActivatableList::addActivatableInternal(Knm::Activatable*) () from /usr/lib/libknmservice.so.4
#11 0x00007f73ff3615dd in WirelessNetworkInterfaceActivatableProvider::handleAdd(Knm::Connection*) () from /usr/lib/libknmservice.so.4
#12 0x00007f73ff35f490 in NetworkInterfaceActivatableProvider::init() () from /usr/lib/libknmservice.so.4
#13 0x00007f73ff35e7d8 in NetworkInterfaceMonitor::networkInterfaceAdded(QString const&) () from /usr/lib/libknmservice.so.4
#14 0x00007f73ff3581fd in NetworkInterfaceMonitor::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libknmservice.so.4
#15 0x00007f73fddbeddc in QMetaObject::activate (sender=0x1366c10, from_signal_index=<value optimized out>, to_signal_index=<value optimized out>, argv=0x13b5d8a) at kernel/qobject.cpp:3113
#16 0x00007f73feeda2c5 in Solid::Control::NetworkManager::Notifier::networkInterfaceAdded (this=0x7fff4fb225d0, _t1=<value optimized out>) at ./networkmanager.moc:101
#17 0x00007f73feedac7c in Solid::Control::NetworkManagerPrivate::qt_metacall (this=0x1366c10, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff4fb22d60)
    at ./networkmanager_p.moc:75
#18 0x00007f73fddbeddc in QMetaObject::activate (sender=0x139b0d0, from_signal_index=<value optimized out>, to_signal_index=<value optimized out>, argv=0x13b5d8a) at kernel/qobject.cpp:3113
#19 0x00007f73f44059c5 in NMNetworkManager::networkInterfaceAdded (this=0x7fff4fb225d0, _t1=<value optimized out>) at ./manager.moc:128
#20 0x00007f73f4406d84 in NMNetworkManager::deviceAdded (this=0x139b0d0, objpath=...) at ../../../solid/networkmanager-0.7/manager.cpp:199
#21 0x00007f73f4409c39 in NMNetworkManager::qt_metacall (this=0x139b0d0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff4fb22f40) at ./manager.moc:105
#22 0x00007f73fddbeddc in QMetaObject::activate (sender=0x139df00, from_signal_index=<value optimized out>, to_signal_index=<value optimized out>, argv=0x13b5d8a) at kernel/qobject.cpp:3113
#23 0x00007f73f4415282 in OrgFreedesktopNetworkManagerInterface::DeviceAdded (this=0x7fff4fb225d0, _t1=<value optimized out>) at ./nm-manager-clientinterface.moc:149
#24 0x00007f73f44156ad in OrgFreedesktopNetworkManagerInterface::qt_metacall (this=0x139df00, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff4fb233d0)
    at ./nm-manager-clientinterface.moc:96
#25 0x00007f73fe0c0ad4 in QDBusConnectionPrivate::deliverCall (this=<value optimized out>, object=<value optimized out>, msg=<value optimized out>, metaTypes=..., slotIdx=<value optimized out>)
    at qdbusintegrator.cpp:891
#26 0x00007f73fe0c7def in QDBusCallDeliveryEvent::placeMetaCall(QObject*) () from /usr/lib/libQtDBus.so.4
#27 0x00007f73fddb90f9 in QObject::event (this=0x139df00, e=0x13d2ab0) at kernel/qobject.cpp:1111
#28 0x00007f73fe4adefc in QApplicationPrivate::notify_helper (this=0x12910d0, receiver=0x139df00, e=0x13d2ab0) at kernel/qapplication.cpp:4056
#29 0x00007f73fe4b51ce in QApplication::notify (this=0x7fff4fb23d70, receiver=0x139df00, e=0x13d2ab0) at kernel/qapplication.cpp:4021
#30 0x00007f73ffbf8ab6 in KApplication::notify (this=0x7fff4fb23d70, receiver=0x139df00, event=0x13d2ab0) at ../../kdeui/kernel/kapplication.cpp:302
#31 0x00007f73fdda9c2c in QCoreApplication::notifyInternal (this=0x7fff4fb23d70, receiver=0x139df00, event=0x13d2ab0) at kernel/qcoreapplication.cpp:610
#32 0x00007f73fddaa80a in QCoreApplication::sendEvent (receiver=0x0, event_type=<value optimized out>, data=0x12674d0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:213
#33 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=<value optimized out>, data=0x12674d0) at kernel/qcoreapplication.cpp:1247
#34 0x00007f73fddd2533 in QCoreApplication::sendPostedEvents (s=<value optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#35 postEventSourceDispatch (s=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:210
#36 0x00007f73f9d29bce in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#37 0x00007f73f9d2d598 in ?? () from /lib/libglib-2.0.so.0
#38 0x00007f73f9d2d6c0 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#39 0x00007f73fddd21a6 in QEventDispatcherGlib::processEvents (this=0x1266d20, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:327
#40 0x00007f73fe5424be in QGuiEventDispatcherGlib::processEvents (this=0x7fff4fb225d0, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:202
#41 0x00007f73fdda8532 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#42 0x00007f73fdda8904 in QEventLoop::exec (this=0x7fff4fb23cc0, flags=) at kernel/qeventloop.cpp:201
#43 0x00007f73fddaaab9 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#44 0x000000000040d12f in _start ()

This bug may be a duplicate of or related to bug 222257

Reported using DrKonqi
Comment 1 Dario Andres 2010-01-12 13:40:24 UTC
This is reported at bug 210878. Regards

*** This bug has been marked as a duplicate of bug 210878 ***