Bug 225562 - Improve efficiency of tagging using group of Tags feature into list of recently assigned Tags
Summary: Improve efficiency of tagging using group of Tags feature into list of recent...
Status: RESOLVED DUPLICATE of bug 326490
Alias: None
Product: digikam
Classification: Unclassified
Component: Tags-Engine (show other bugs)
Version: 1.0.0
Platform: Debian testing Linux
: NOR wishlist with 20 votes (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords: usability
Depends on:
Blocks:
 
Reported: 2010-02-04 23:38 UTC by Reiner Nix
Modified: 2014-09-02 19:42 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Reiner Nix 2010-02-04 23:38:41 UTC
Version:            (using KDE 4.3.2)
OS:                Linux
Installed from:    Debian testing/unstable Packages

When tagging a new album or a set of images it is common that the set of tags is restricted compared with the whole set of tags. So not all tags are used but the used tags will be used many times.

In the tag editor, there are already two small buttons on the lower right dealing with tags: "Tags Already Assigned" and "Recent Tags".

Some improvement would be fine to speed up tagging as well as avoid errors on tagging:

1) Feature "Tags Recently Assigned"
The button "Tags Already Assigned" enables/disables a filter to display all tags or hide the yet not used tags for the selected image.

This could be extended to a new mode "Tags Recently Assigned". Using this mode only tags should be displayed, which are assigned within the last session. A session could be defined as of from the last program execution or until an explicit clear is invoked.

As effect of such an "Tags Recently Assigned" mode, a user can start to assign tags for a new set of images. He could either add new tags or temporarily switch to the "All Tags" mode but most the time, he can operate only with the restricted set of tags. 

Benefit of this behavoir is that the user is most the time not forced to operate on a large list of sets. So number of mouse clicks is reduced. Further he has more feedback of the tags assigned in its current session, so it is obviously that that the assigned tags will be used in a more consistent way.

2) Feature "Recent Tags" 
The button "Recent Tags" displays the list of tags which are last recently used. This history seems to be usable when assigning tags only few times. 

The problem becomes evident when applying more than one tag to more than one image. Than it would be fine if you could select multiple entries with a single operation and using this selection to assign multiple tags at the same time.

Describing the requirement from other point of view: when the last assignments of tags have used the tags A, B, and C. The it should be possible to group these into a single entry instead of assigning three tags one by one.
Comment 1 caulier.gilles 2010-02-06 09:42:17 UTC
Which version of digiKam you use exactly ?

Gilles Caulier
Comment 2 Reiner Nix 2010-02-10 01:11:45 UTC
Sorry, for the missing info. I am using digiKam 1.0.0
Comment 3 caulier.gilles 2010-02-10 06:59:34 UTC
Well, i recommend, to test 1.1.0 release or better, to try new code from trunk (1.2.0) where a lots of implementation have been rewritted using Qt4 Model View 

Gilles Caulier
Comment 4 Reiner Nix 2010-12-08 22:53:30 UTC
Sorry for the long time without update. Now I was able update and running digikam 1.2.0 (using debian testing with KDE 4.4.5).

Well some improvements are really nice. In the area to set tags, I see no major improvements. The amount of mouse clicks is still high while having a large list of tags. So having 440 tags while only 20 of them are showed I have to scroll thrugh 23 pages. This is not very enjoying.

I would highly appreciate any improvements.
Comment 5 caulier.gilles 2010-12-09 01:08:37 UTC
digiKam 1.2.0 is not the last one. 1.6.0 is the last one. update and try again...

Gilles Caulier
Comment 6 Reiner Nix 2011-11-21 20:46:00 UTC
I am using now digikam 2:1.9.0-3+b1 on debian testing and I would be very appreciate on further improvements. 


I am really sorry, I am bound to debian testing, so I could not install the latest digikam version. Of course I am looking forward to use the newer digikam versions!!!
Comment 7 caulier.gilles 2011-11-22 16:08:02 UTC
2.3.0 is the last one now. 2.4.0 will be out in december

Gilles Caulier
Comment 8 caulier.gilles 2011-12-16 13:04:17 UTC
Reiner,

This file still valid using digiKam 2.4 ?

Gilles Caulier
Comment 9 Reiner Nix 2011-12-18 22:40:47 UTC
Sorry, due to my distribution - debian testing - I have to work with digikam 1.9. I am looking forward that debian provides a newer version. For digikam 1.9 the reported issue is still true and I would highly appreciate more improvements to make tagging more efficient.

Is the description above clear or would it be helpful to describe it by other words / images?
Comment 10 caulier.gilles 2013-12-02 14:09:21 UTC
Reiner,

This entry still valid with digiKam 3.5.0 ?

Gilles Caulier
Comment 11 Reiner Nix 2014-06-03 22:23:02 UTC
Thanks to debian testing I can now use digikam 4.0. Its made good progres. 

However I like to have more of the tag efficiency and for my feeling the issues are still true.
Away from using the keyboard there are many votes to improve tagging. See https://bugs.kde.org/show_bug.cgi?id=114465.

For Info: currently I have around 34000 photos, 440 tags, 42000 tag usages. However many images are not tagged as tagging is so hard.
Comment 12 caulier.gilles 2014-09-02 09:57:52 UTC
Reiner,

This entry still valid with digiKam 4.2.0 ?

Gilles Caulier
Comment 13 caulier.gilles 2014-09-02 10:01:57 UTC

*** This bug has been marked as a duplicate of bug 326490 ***
Comment 14 Reiner Nix 2014-09-02 19:42:05 UTC
Dear Gilles,

I could verify the issue using digiKam 4.1.0 (using debian testing) and it is still valid even some improvements on tagging were done. As far as I could discover, the newly added dialog to maintain tags does not add the wished features. Perhaps it is not ready in 4.1.0? Please, correct me if I am wrong. 
I am sorry, that I have to wait until digiKam 4.2.0 becomes available for my distro. If you like, I am happy to re-check the status again later and give you feedback.

In my opinion the bug 326490 (Extending single tag to a group of tags) addresses the same problem. And the proposed solution would improve the deficiency a lot. However the proposal for 326490 is not as flexible as the proposal of this bug. For example, consider that we have had holidays with another family. There were totally 8 persons visible on a lot of images. But of course not all images were taken with all of them. So some photos are with (Anne, Katharina, Tobias and Reiner) other were with (Katharina, Tobias, Benedikt, Christian) and so on. 
As result it would be great to define an initial set used for tagging and then be freely able to choose for every (or some) of the images tags out of a variying subset of the initial set.

Many regards,
Reiner