Bug 224605 - Dolphin crash after file transfer from usb device
Summary: Dolphin crash after file transfer from usb device
Status: RESOLVED DUPLICATE of bug 223070
Alias: None
Product: dolphin
Classification: Applications
Component: general (show other bugs)
Version: 16.12.2
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Peter Penz
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-01-28 11:25 UTC by jerome.frgacic
Modified: 2010-01-28 11:32 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jerome.frgacic 2010-01-28 11:25:44 UTC
Application that crashed: dolphin
Version of the application: 1.3
KDE Version: 4.3.2 (KDE 4.3.2)
Qt Version: 4.5.2
Operating System: Linux 2.6.31-17-generic x86_64
Distribution: Ubuntu 9.10

What I was doing when the application crashed:
Dolphin crash when he finished a file transfer from an usb device

 -- Backtrace:
Application: Dolphin (dolphin), signal: Segmentation fault
[Current thread is 1 (Thread 0x7fa6ad03a750 (LWP 2753))]

Thread 2 (Thread 0x7fa691d12910 (LWP 2836)):
#0  pthread_cond_timedwait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:220
#1  0x00007fa69718cc91 in ?? () from /usr/lib/libxine.so.1
#2  0x00007fa6a52e6a04 in start_thread (arg=<value optimized out>) at pthread_create.c:300
#3  0x00007fa6a933580d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#4  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fa6ad03a750 (LWP 2753)):
[KCrash Handler]
#5  0x00007fa6acac7d03 in KFileItem::isDir (this=0x1aa28a0) at ../../kio/kio/kfileitem.cpp:969
#6  0x00007fa6acab7198 in KDirModelPrivate::removeFromNodeHash (this=0x1ab2640, node=0x1aa28a0, url=...) at ../../kio/kio/kdirmodel.cpp:200
#7  0x00007fa6acab80ab in KDirModelPrivate::_k_slotDeleteItems (this=0x1ab2640, items=<value optimized out>) at ../../kio/kio/kdirmodel.cpp:487
#8  0x00007fa6acab9b82 in KDirModel::qt_metacall (this=0x1aad2c0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff39cf0ed0) at ./kdirmodel.moc:83
#9  0x00007fa6a9a2eddc in QMetaObject::activate (sender=0x1aad2a0, from_signal_index=<value optimized out>, to_signal_index=<value optimized out>, argv=0x0) at kernel/qobject.cpp:3113
#10 0x00007fa6aca9d895 in KDirLister::itemsDeleted (this=0x1aa28a0, _t1=<value optimized out>) at ./kdirlister.moc:289
#11 0x00007fa6aca9e5d1 in KDirLister::Private::emitItemsDeleted (this=0x1ab3160, _items=<value optimized out>) at ../../kio/kio/kdirlister.cpp:2351
#12 0x00007fa6acaad57e in KDirListerCache::itemsDeleted (this=0xf18ea0, listers=<value optimized out>, deletedItems=...) at ../../kio/kio/kdirlister.cpp:1697
#13 0x00007fa6acaaefca in KDirListerCache::slotFilesRemoved (this=0xf18ea0, fileList=<value optimized out>) at ../../kio/kio/kdirlister.cpp:808
#14 0x00007fa6acaaf454 in KDirListerCache::slotFilesRemoved (this=0xf18ea0, fileList=<value optimized out>) at ../../kio/kio/kdirlister.cpp:763
#15 0x00007fa6acaafdb0 in KDirListerCache::qt_metacall (this=0xf18ea0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff39cf1350) at ./kdirlister_p.moc:92
#16 0x00007fa6a9a2eddc in QMetaObject::activate (sender=0xf0fef0, from_signal_index=<value optimized out>, to_signal_index=<value optimized out>, argv=0x0) at kernel/qobject.cpp:3113
#17 0x00007fa6acabb115 in OrgKdeKDirNotifyInterface::FilesRemoved (this=0x1aa28a0, _t1=<value optimized out>) at ./kdirnotify.moc:125
#18 0x00007fa6acabb290 in OrgKdeKDirNotifyInterface::qt_metacall (this=0xf0fef0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff39cf1610) at ./kdirnotify.moc:83
#19 0x00007fa6aa8e4ad4 in QDBusConnectionPrivate::deliverCall (this=<value optimized out>, object=<value optimized out>, msg=<value optimized out>, metaTypes=..., slotIdx=<value optimized out>)
    at qdbusintegrator.cpp:891
#20 0x00007fa6aa8ebdef in QDBusCallDeliveryEvent::placeMetaCall(QObject*) () from /usr/lib/libQtDBus.so.4
#21 0x00007fa6a9a290f9 in QObject::event (this=0xf0fef0, e=0x19953a0) at kernel/qobject.cpp:1111
#22 0x00007fa6a9eacefc in QApplicationPrivate::notify_helper (this=0xce2ce0, receiver=0xf0fef0, e=0x19953a0) at kernel/qapplication.cpp:4056
#23 0x00007fa6a9eb41ce in QApplication::notify (this=0x7fff39cf1fb0, receiver=0xf0fef0, e=0x19953a0) at kernel/qapplication.cpp:4021
#24 0x00007fa6ab1e1ab6 in KApplication::notify (this=0x7fff39cf1fb0, receiver=0xf0fef0, event=0x19953a0) at ../../kdeui/kernel/kapplication.cpp:302
#25 0x00007fa6a9a19c2c in QCoreApplication::notifyInternal (this=0x7fff39cf1fb0, receiver=0xf0fef0, event=0x19953a0) at kernel/qcoreapplication.cpp:610
#26 0x00007fa6a9a1a80a in QCoreApplication::sendEvent (receiver=0x0, event_type=<value optimized out>, data=0xcb84d0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:213
#27 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=<value optimized out>, data=0xcb84d0) at kernel/qcoreapplication.cpp:1247
#28 0x00007fa6a9a42533 in QCoreApplication::sendPostedEvents (s=<value optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#29 postEventSourceDispatch (s=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:210
#30 0x00007fa6a5537bce in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#31 0x00007fa6a553b598 in ?? () from /lib/libglib-2.0.so.0
#32 0x00007fa6a553b6c0 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#33 0x00007fa6a9a421a6 in QEventDispatcherGlib::processEvents (this=0xcb7d20, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:327
#34 0x00007fa6a9f414be in QGuiEventDispatcherGlib::processEvents (this=0x1aa28a0, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:202
#35 0x00007fa6a9a18532 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#36 0x00007fa6a9a18904 in QEventLoop::exec (this=0x7fff39cf1f00, flags=) at kernel/qeventloop.cpp:201
#37 0x00007fa6a9a1aab9 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#38 0x0000000000439555 in _start ()
The current source language is "auto; currently asm".
The current source language is "auto; currently c".

This bug may be a duplicate of or related to bug 223070

Reported using DrKonqi
Comment 1 Peter Penz 2010-01-28 11:32:14 UTC

*** This bug has been marked as a duplicate of bug 223070 ***