Bug 223070 - dolphin crashed after completing copying some folders
Summary: dolphin crashed after completing copying some folders
Status: RESOLVED DUPLICATE of bug 196695
Alias: None
Product: dolphin
Classification: Applications
Component: general (show other bugs)
Version: 16.12.2
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Peter Penz
URL:
Keywords:
: 224605 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-01-17 03:46 UTC by Alex Poovathingal
Modified: 2010-01-28 11:32 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alex Poovathingal 2010-01-17 03:46:15 UTC
Application that crashed: dolphin
Version of the application: 1.3
KDE Version: 4.3.2 (KDE 4.3.2)
Qt Version: 4.5.2
Operating System: Linux 2.6.31-17-generic i686
Distribution: Ubuntu 9.10

 -- Backtrace:
Application: Dolphin (dolphin), signal: Segmentation fault
[Current thread is 1 (Thread 0xb7726920 (LWP 4950))]

Thread 2 (Thread 0xb25ffb70 (LWP 4968)):
#0  0x009c7422 in __kernel_vsyscall ()
#1  0x00ee1142 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib/tls/i686/cmov/libpthread.so.0
#2  0x0142f8d4 in pthread_cond_timedwait () from /lib/tls/i686/cmov/libc.so.6
#3  0x068509ff in ?? () from /usr/lib/libxine.so.1
#4  0x00edc80e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#5  0x014228de in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 1 (Thread 0xb7726920 (LWP 4950)):
[KCrash Handler]
#6  0x00ce9038 in KFileItem::isDir (this=0x94cc768) at ../../kio/kio/kfileitem.cpp:969
#7  0x00cd7192 in KDirModelPrivate::removeFromNodeHash (this=0x94cc8c0, node=0x94cc768, url=...) at ../../kio/kio/kdirmodel.cpp:200
#8  0x00cd808a in KDirModelPrivate::_k_slotDeleteItems (this=0x94cc8c0, items=...) at ../../kio/kio/kdirmodel.cpp:487
#9  0x00cd9d50 in KDirModel::qt_metacall (this=0x94ccc08, _c=QMetaObject::InvokeMetaMethod, _id=23, _a=0xbff37fd8) at ./kdirmodel.moc:83
#10 0x01951263 in QMetaObject::activate (sender=0x94cddd8, from_signal_index=17, to_signal_index=17, argv=0xbff37fd8) at kernel/qobject.cpp:3113
#11 0x01951ec2 in QMetaObject::activate (sender=0x94cddd8, m=0x80b7410, local_signal_index=13, argv=0xbff37fd8) at kernel/qobject.cpp:3187
#12 0x00cbc373 in KDirLister::itemsDeleted (this=0x94cddd8, _t1=...) at ./kdirlister.moc:289
#13 0x00cbd3f9 in KDirLister::Private::emitItemsDeleted (this=0x94cc860, _items=...) at ../../kio/kio/kdirlister.cpp:2351
#14 0x00cccee6 in KDirListerCache::itemsDeleted (this=0x948d428, listers=..., deletedItems=...) at ../../kio/kio/kdirlister.cpp:1697
#15 0x00ccea12 in KDirListerCache::slotFilesRemoved (this=0x948d428, fileList=...) at ../../kio/kio/kdirlister.cpp:808
#16 0x00ccee48 in KDirListerCache::slotFilesRemoved (this=0x948d428, fileList=...) at ../../kio/kio/kdirlister.cpp:763
#17 0x00ccf885 in KDirListerCache::qt_metacall (this=0x948d428, _c=QMetaObject::InvokeMetaMethod, _id=5, _a=0xbff382f8) at ./kdirlister_p.moc:92
#18 0x01951263 in QMetaObject::activate (sender=0x9483480, from_signal_index=9, to_signal_index=9, argv=0xbff382f8) at kernel/qobject.cpp:3113
#19 0x01951ec2 in QMetaObject::activate (sender=0x9483480, m=0xe4e294, local_signal_index=4, argv=0xbff382f8) at kernel/qobject.cpp:3187
#20 0x00cdb4b3 in OrgKdeKDirNotifyInterface::FilesRemoved (this=0x9483480, _t1=...) at ./kdirnotify.moc:125
#21 0x00cdb6b5 in OrgKdeKDirNotifyInterface::qt_metacall (this=0x9483480, _c=QMetaObject::InvokeMetaMethod, _id=9, _a=0xbff3847c) at ./kdirnotify.moc:83
#22 0x0086c7b4 in QDBusConnectionPrivate::deliverCall (this=0x92e36d0, object=0x9483480, msg=..., metaTypes=..., slotIdx=9) at qdbusintegrator.cpp:891
#23 0x00874197 in QDBusCallDeliveryEvent::placeMetaCall(QObject*) () from /usr/lib/libQtDBus.so.4
#24 0x0194b5fe in QObject::event (this=0x9483480, e=0x9b8bc78) at kernel/qobject.cpp:1111
#25 0x01f01f54 in QApplicationPrivate::notify_helper (this=0x92f2e18, receiver=0x9483480, e=0x9b8bc78) at kernel/qapplication.cpp:4056
#26 0x01f0967c in QApplication::notify (this=0xbff38c8c, receiver=0x9483480, e=0x9b8bc78) at kernel/qapplication.cpp:3603
#27 0x01196bfa in KApplication::notify (this=0xbff38c8c, receiver=0x9483480, event=0x9b8bc78) at ../../kdeui/kernel/kapplication.cpp:302
#28 0x0193b6cb in QCoreApplication::notifyInternal (this=0xbff38c8c, receiver=0x9483480, event=0x9b8bc78) at kernel/qcoreapplication.cpp:610
#29 0x0193c2b2 in QCoreApplication::sendEvent (receiver=0x0, event_type=0, data=0x92cd148) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:213
#30 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x92cd148) at kernel/qcoreapplication.cpp:1247
#31 0x0193c47d in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1140
#32 0x019663ff in QCoreApplication::sendPostedEvents (s=0x92f1cc0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#33 postEventSourceDispatch (s=0x92f1cc0) at kernel/qeventdispatcher_glib.cpp:210
#34 0x03762e88 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#35 0x03766730 in ?? () from /lib/libglib-2.0.so.0
#36 0x03766863 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#37 0x0196602c in QEventDispatcherGlib::processEvents (this=0x92cccc8, flags=...) at kernel/qeventdispatcher_glib.cpp:327
#38 0x01fa2be5 in QGuiEventDispatcherGlib::processEvents (this=0x92cccc8, flags=...) at kernel/qguieventdispatcher_glib.cpp:202
#39 0x01939c79 in QEventLoop::processEvents (this=0xbff38be4, flags=) at kernel/qeventloop.cpp:149
#40 0x0193a0ca in QEventLoop::exec (this=0xbff38be4, flags=...) at kernel/qeventloop.cpp:201
#41 0x0193c53f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#42 0x01f01dd7 in QApplication::exec () at kernel/qapplication.cpp:3525
#43 0x0807a745 in _start ()

Reported using DrKonqi
Comment 1 Frank Reininghaus 2010-01-17 18:07:34 UTC
Thanks for the bug report! This looks like a crash that has been reported already.

*** This bug has been marked as a duplicate of bug 196695 ***
Comment 2 Peter Penz 2010-01-28 11:32:14 UTC
*** Bug 224605 has been marked as a duplicate of this bug. ***