Bug 224297 - Plasma widget segmentation fault when reloading network-manager service
Summary: Plasma widget segmentation fault when reloading network-manager service
Status: RESOLVED DUPLICATE of bug 210878
Alias: None
Product: knetworkmanager
Classification: Miscellaneous
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Will Stephenson
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-01-26 10:20 UTC by Martin Kalén
Modified: 2010-01-26 12:51 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
/etc/network/interfaces (204 bytes, text/plain)
2010-01-26 10:23 UTC, Martin Kalén
Details
ifconfig -v -a output (2.04 KB, text/plain)
2010-01-26 10:23 UTC, Martin Kalén
Details
PCI devices (248 bytes, text/plain)
2010-01-26 10:26 UTC, Martin Kalén
Details
USB device (86 bytes, text/plain)
2010-01-26 10:27 UTC, Martin Kalén
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Kalén 2010-01-26 10:20:51 UTC
Application that crashed: knetworkmanager
Version of the application: v0.9
KDE Version: 4.3.2 (KDE 4.3.2)
Qt Version: 4.5.2
Operating System: Linux 2.6.31-17-generic x86_64
Distribution: Ubuntu 9.10

What I was doing when the application crashed:
KNetworkManager's KDE4 plasma widget often crashes with segmentation fault on service restart. Command line: "sudo /etc/init.d/network-manager restart". I have static interfaces defined in /etc/network/interfaces. Looks similar to #222257/#210878.

 -- Backtrace:
Application: Knetworkmanager (knetworkmanager), signal: Segmentation fault
The current source language is "auto; currently c".
[KCrash Handler]
#5  QBasicAtomicInt::ref (this=0x1ac5550) at /usr/include/qt4/QtCore/qatomic_x86_64.h:121
#6  QString (this=0x1ac5550) at /usr/include/qt4/QtCore/qstring.h:712
#7  Knm::Activatable::deviceUni (this=0x1ac5550) at /build/buildd/plasma-widget-networkmanagement-0.9~svn1029786+ag1/libs/internals/activatable.cpp:51
#8  0x00007fa6bc1fd193 in compareDevices (first=<value optimized out>, second=0x1ac5550) at /build/buildd/plasma-widget-networkmanagement-0.9~svn1029786+ag1/libs/service/sortedactivatablelist.cpp:264
#9  0x00007fa6bc1fd2b3 in activatableLessThan (first=0x7fff53c8aab0, second=0x1ac5550) at /build/buildd/plasma-widget-networkmanagement-0.9~svn1029786+ag1/libs/service/sortedactivatablelist.cpp:173
#10 0x00007fa6bc1fd50e in qSortHelper<QList<Knm::Activatable*>::iterator, Knm::Activatable*, bool (*)(Knm::Activatable const*, Knm::Activatable const*)> (start=)
    at /usr/include/qt4/QtCore/qalgorithms.h:379
#11 0x00007fa6bc1fd72c in qSort<QList<Knm::Activatable*>::iterator, bool (*)(Knm::Activatable const*, Knm::Activatable const*)> (this=0x1a60430, activatable=<value optimized out>)
    at /usr/include/qt4/QtCore/qalgorithms.h:204
#12 SortedActivatableList::handleAdd (this=0x1a60430, activatable=<value optimized out>) at /build/buildd/plasma-widget-networkmanagement-0.9~svn1029786+ag1/libs/service/sortedactivatablelist.cpp:100
#13 0x00007fa6bc1ed06b in ActivatableList::addActivatableInternal (this=0x1a7e310, activatable=0x1b1a710)
    at /build/buildd/plasma-widget-networkmanagement-0.9~svn1029786+ag1/libs/service/activatablelist.cpp:94
#14 0x00007fa6bc1f05dd in WirelessNetworkInterfaceActivatableProvider::handleAdd (this=0x1b09ea0, addedConnection=<value optimized out>)
    at /build/buildd/plasma-widget-networkmanagement-0.9~svn1029786+ag1/libs/service/wirelessnetworkinterfaceactivatableprovider.cpp:143
#15 0x00007fa6bc1ee490 in NetworkInterfaceActivatableProvider::init (this=0x1b09ea0)
    at /build/buildd/plasma-widget-networkmanagement-0.9~svn1029786+ag1/libs/service/networkinterfaceactivatableprovider.cpp:64
#16 0x00007fa6bc1ed7d8 in NetworkInterfaceMonitor::networkInterfaceAdded (this=<value optimized out>, uni=...)
    at /build/buildd/plasma-widget-networkmanagement-0.9~svn1029786+ag1/libs/service/networkinterfacemonitor.cpp:79
#17 0x00007fa6bc1e71fd in NetworkInterfaceMonitor::qt_metacall (this=0x1ad05a0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff53c8b110)
    at /build/buildd/plasma-widget-networkmanagement-0.9~svn1029786+ag1/obj-x86_64-linux-gnu/libs/service/moc_networkinterfacemonitor.cpp:69
#18 0x00007fa6bac4dddc in QMetaObject::activate (sender=0x1a7e020, from_signal_index=<value optimized out>, to_signal_index=<value optimized out>, argv=0x1ac3c0a) at kernel/qobject.cpp:3113
#19 0x00007fa6bbd692c5 in Solid::Control::NetworkManager::Notifier::networkInterfaceAdded (this=0x7fff53c8aab0, _t1=<value optimized out>) at ./networkmanager.moc:101
#20 0x00007fa6bbd69c7c in Solid::Control::NetworkManagerPrivate::qt_metacall (this=0x1a7e020, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff53c8b240)
    at ./networkmanager_p.moc:75
#21 0x00007fa6bac4dddc in QMetaObject::activate (sender=0x1a61e60, from_signal_index=<value optimized out>, to_signal_index=<value optimized out>, argv=0x1ac3c0a) at kernel/qobject.cpp:3113
#22 0x00007fa6b1b669c5 in NMNetworkManager::networkInterfaceAdded (this=0x7fff53c8aab0, _t1=<value optimized out>) at ./manager.moc:128
#23 0x00007fa6b1b67d84 in NMNetworkManager::deviceAdded (this=0x1a61e60, objpath=...) at ../../../solid/networkmanager-0.7/manager.cpp:199
#24 0x00007fa6b1b6ac39 in NMNetworkManager::qt_metacall (this=0x1a61e60, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff53c8b420) at ./manager.moc:105
#25 0x00007fa6bac4dddc in QMetaObject::activate (sender=0x1abab50, from_signal_index=<value optimized out>, to_signal_index=<value optimized out>, argv=0x1ac3c0a) at kernel/qobject.cpp:3113
#26 0x00007fa6b1b76282 in OrgFreedesktopNetworkManagerInterface::DeviceAdded (this=0x7fff53c8aab0, _t1=<value optimized out>) at ./nm-manager-clientinterface.moc:149
#27 0x00007fa6b1b766ad in OrgFreedesktopNetworkManagerInterface::qt_metacall (this=0x1abab50, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff53c8b8b0)
    at ./nm-manager-clientinterface.moc:96
#28 0x00007fa6baf4fad4 in QDBusConnectionPrivate::deliverCall (this=<value optimized out>, object=<value optimized out>, msg=<value optimized out>, metaTypes=..., slotIdx=<value optimized out>)
    at qdbusintegrator.cpp:891
#29 0x00007fa6baf56def in QDBusCallDeliveryEvent::placeMetaCall(QObject*) () from /usr/lib/libQtDBus.so.4
#30 0x00007fa6bac480f9 in QObject::event (this=0x1abab50, e=0x1b06e90) at kernel/qobject.cpp:1111
#31 0x00007fa6bb33cefc in QApplicationPrivate::notify_helper (this=0x1979dd0, receiver=0x1abab50, e=0x1b06e90) at kernel/qapplication.cpp:4056
#32 0x00007fa6bb3441ce in QApplication::notify (this=0x7fff53c8c250, receiver=0x1abab50, e=0x1b06e90) at kernel/qapplication.cpp:4021
#33 0x00007fa6bca87ab6 in KApplication::notify (this=0x7fff53c8c250, receiver=0x1abab50, event=0x1b06e90) at ../../kdeui/kernel/kapplication.cpp:302
#34 0x00007fa6bac38c2c in QCoreApplication::notifyInternal (this=0x7fff53c8c250, receiver=0x1abab50, event=0x1b06e90) at kernel/qcoreapplication.cpp:610
#35 0x00007fa6bac3980a in QCoreApplication::sendEvent (receiver=0x0, event_type=<value optimized out>, data=0x19524d0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:213
#36 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=<value optimized out>, data=0x19524d0) at kernel/qcoreapplication.cpp:1247
#37 0x00007fa6bac61533 in QCoreApplication::sendPostedEvents (s=<value optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#38 postEventSourceDispatch (s=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:210
#39 0x00007fa6b6bb8bce in g_main_dispatch (context=0x197c530) at /build/buildd/glib2.0-2.22.3/glib/gmain.c:1960
#40 IA__g_main_context_dispatch (context=0x197c530) at /build/buildd/glib2.0-2.22.3/glib/gmain.c:2513
#41 0x00007fa6b6bbc598 in g_main_context_iterate (context=0x197c530, block=<value optimized out>, dispatch=<value optimized out>, self=<value optimized out>)
    at /build/buildd/glib2.0-2.22.3/glib/gmain.c:2591
#42 0x00007fa6b6bbc6c0 in IA__g_main_context_iteration (context=0x197c530, may_block=1) at /build/buildd/glib2.0-2.22.3/glib/gmain.c:2654
#43 0x00007fa6bac611a6 in QEventDispatcherGlib::processEvents (this=0x1951d20, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:327
#44 0x00007fa6bb3d14be in QGuiEventDispatcherGlib::processEvents (this=0x7fff53c8aab0, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:202
#45 0x00007fa6bac37532 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#46 0x00007fa6bac37904 in QEventLoop::exec (this=0x7fff53c8c1a0, flags=) at kernel/qeventloop.cpp:201
#47 0x00007fa6bac39ab9 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#48 0x000000000040d12f in main (argc=<value optimized out>, argv=<value optimized out>) at /build/buildd/plasma-widget-networkmanagement-0.9~svn1029786+ag1/monolithic/main.cpp:45

This bug may be a duplicate of or related to bug 222257

Reported using DrKonqi
Comment 1 Martin Kalén 2010-01-26 10:23:14 UTC
Created attachment 40243 [details]
/etc/network/interfaces
Comment 2 Martin Kalén 2010-01-26 10:23:56 UTC
Created attachment 40244 [details]
ifconfig -v -a output
Comment 3 Martin Kalén 2010-01-26 10:26:44 UTC
Created attachment 40245 [details]
PCI devices

Output from "lspci | grep -i ethernet"
Comment 4 Martin Kalén 2010-01-26 10:27:20 UTC
Created attachment 40246 [details]
USB device

Output from "lsusb | grep -i wireless"
Comment 5 Dario Andres 2010-01-26 12:51:13 UTC
Thanks for all the information. This is being tracked at bug 210878. Regards

*** This bug has been marked as a duplicate of bug 210878 ***