Bug 222257 - knetworkmanager crashes when starting/restarting network-manager
Summary: knetworkmanager crashes when starting/restarting network-manager
Status: RESOLVED DUPLICATE of bug 210878
Alias: None
Product: knetworkmanager
Classification: Miscellaneous
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Will Stephenson
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-01-11 18:46 UTC by Markus Hinkelmann
Modified: 2010-01-12 13:13 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
backtrace of knetworkmanager crash produced using procedure from comment #1 (6.99 KB, application/octet-stream)
2010-01-12 10:45 UTC, Markus Hinkelmann
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Markus Hinkelmann 2010-01-11 18:46:40 UTC
Application: knetworkmanager (v0.9)
KDE Platform Version: 4.3.90 (KDE 4.3.90 (KDE 4.4 RC1))
Qt Version: 4.6.0
Operating System: Linux 2.6.31-17-generic i686
Distribution: Ubuntu 9.10

-- Information about the crash:
After switching on wireless on my laptop by pressing the corresponding wifi on button knetworkmanager didn't automatically connect to the internet. Hence, I tried to restart network-manager using
sudo restart network-manager
Then, knetworkmanager crashed. I was able to reproduce this behavior several times and it turns out that knetworkmanager actually crashes when network-manager is started.
[knetworkmanager and network-manager running]
sudo stop network-manager
sudo start network-manager
[crash]

I'm using KDE from the kubuntu ppa.

The crash can be reproduced some of the time.

 -- Backtrace:
Application: KNetworkManager (knetworkmanager), signal: Aborted
[KCrash Handler]
#6  0x00793422 in __kernel_vsyscall ()
#7  0x007be4d1 in *__GI_raise (sig=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
#8  0x007c1932 in *__GI_abort () at abort.c:92
#9  0x007f4ee5 in __libc_message (do_abort=2, fmt=0x8b8578 "*** glibc detected *** %s: %s: 0x%s ***\n") at ../sysdeps/unix/sysv/linux/libc_fatal.c:189
#10 0x007feff1 in malloc_printerr (action=<value optimized out>, str=0x6 <Address 0x6 out of bounds>, ptr=0x98ed4f8) at malloc.c:6217
#11 0x00803836 in *__GI___libc_free (mem=0x6) at malloc.c:3677
#12 0x0815ea1d in qFree (ptr=0x98ed4f8) at global/qmalloc.cpp:60
#13 0x081ae8e0 in QString::free (d=0x98ed4f8) at tools/qstring.cpp:1108
#14 0x00dae163 in ~QString (first=0x98f9a98, second=0x98ed4e8) at /usr/include/qt4/QtCore/qstring.h:866
#15 compareDevices (first=0x98f9a98, second=0x98ed4e8) at /build/buildd/plasma-widget-networkmanagement-0.9~svn1029786+ag1/libs/service/sortedactivatablelist.cpp:264
#16 0x00dae21c in activatableLessThan (first=0x98f9a98, second=0x98ed4e8) at /build/buildd/plasma-widget-networkmanagement-0.9~svn1029786+ag1/libs/service/sortedactivatablelist.cpp:173
#17 0x00dae49d in qSortHelper<QList<Knm::Activatable*>::iterator, Knm::Activatable*, bool (*)(Knm::Activatable const*, Knm::Activatable const*)> (start=<value optimized out>, end=)
    at /usr/include/qt4/QtCore/qalgorithms.h:379
#18 0x00dae697 in qSort<QList<Knm::Activatable*>::iterator, bool (*)(Knm::Activatable const*, Knm::Activatable const*)> (this=0x98fda28, activatable=0x98f9a98)
    at /usr/include/qt4/QtCore/qalgorithms.h:204
#19 SortedActivatableList::handleAdd (this=0x98fda28, activatable=0x98f9a98) at /build/buildd/plasma-widget-networkmanagement-0.9~svn1029786+ag1/libs/service/sortedactivatablelist.cpp:100
#20 0x00d9cd03 in ActivatableList::addActivatableInternal (this=0x98b9d78, activatable=0x98f9a98)
    at /build/buildd/plasma-widget-networkmanagement-0.9~svn1029786+ag1/libs/service/activatablelist.cpp:94
#21 0x00d9cd9c in ActivatableList::addActivatable (this=0x98b9d78, activatable=0x6) at /build/buildd/plasma-widget-networkmanagement-0.9~svn1029786+ag1/libs/service/activatablelist.cpp:82
#22 0x00da0d95 in WirelessNetworkInterfaceActivatableProvider::handleAdd (this=0x98d03d8, addedConnection=0x98fb7a0)
    at /build/buildd/plasma-widget-networkmanagement-0.9~svn1029786+ag1/libs/service/wirelessnetworkinterfaceactivatableprovider.cpp:132
#23 0x00da10d9 in WirelessNetworkInterfaceActivatableProvider::networkAppeared (this=0x98d03d8, ssid=...)
    at /build/buildd/plasma-widget-networkmanagement-0.9~svn1029786+ag1/libs/service/wirelessnetworkinterfaceactivatableprovider.cpp:176
#24 0x00da1a89 in WirelessNetworkInterfaceActivatableProvider (this=0x98d03d8, connectionList=0x98acbb8, activatableList=0x98b9d78, interface=0x994db60, parent=0x98ef470, 
    __in_chrg=<value optimized out>, __vtt_parm=<value optimized out>)
    at /build/buildd/plasma-widget-networkmanagement-0.9~svn1029786+ag1/libs/service/wirelessnetworkinterfaceactivatableprovider.cpp:76
#25 0x00d9d56c in NetworkInterfaceMonitor::networkInterfaceAdded (this=0x98ef470, uni=...)
    at /build/buildd/plasma-widget-networkmanagement-0.9~svn1029786+ag1/libs/service/networkinterfacemonitor.cpp:71
#26 0x00d96a9b in NetworkInterfaceMonitor::qt_metacall (this=0x98ef470, _c=QMetaObject::InvokeMetaMethod, _id=4, _a=0xbfb4b9c8)
    at /build/buildd/plasma-widget-networkmanagement-0.9~svn1029786+ag1/obj-i486-linux-gnu/libs/service/moc_networkinterfacemonitor.cpp:69
#27 0x0826b11a in QMetaObject::metacall (object=0x98ef470, cl=2287, idx=4, argv=0xbfb4b9c8) at kernel/qmetaobject.cpp:237
#28 0x0827989b in QMetaObject::activate (sender=0x98d6a08, m=0xbc2560, local_signal_index=1, argv=0xbfb4b9c8) at kernel/qobject.cpp:3294
#29 0x00ba3ad3 in Solid::Control::NetworkManager::Notifier::networkInterfaceAdded (this=0x98d6a08, _t1=...) at ./networkmanager.moc:107
#30 0x00ba4566 in Solid::Control::NetworkManagerPrivate::_k_networkInterfaceAdded (this=0x98d6a08, uni=...) at ../../../../libs/solid/control/networkmanager.cpp:197
#31 0x00ba45e7 in Solid::Control::NetworkManagerPrivate::qt_metacall (this=0x98d6a08, _c=QMetaObject::InvokeMetaMethod, _id=10, _a=0xbfb4bb38) at ./networkmanager_p.moc:81
#32 0x0826b11a in QMetaObject::metacall (object=0x98d6a08, cl=2287, idx=10, argv=0xbfb4bb38) at kernel/qmetaobject.cpp:237
#33 0x0827989b in QMetaObject::activate (sender=0x98e82f0, m=0x2104a70, local_signal_index=1, argv=0xbfb4bb38) at kernel/qobject.cpp:3294
#34 0x020ec203 in NMNetworkManager::networkInterfaceAdded (this=0x98e82f0, _t1=...) at ./manager.moc:134
#35 0x020ecada in NMNetworkManager::deviceAdded (this=0x98e82f0, objpath=...) at ../../../solid/networkmanager-0.7/manager.cpp:199
#36 0x020f0a6d in NMNetworkManager::qt_metacall (this=0x98e82f0, _c=QMetaObject::InvokeMetaMethod, _id=20, _a=0xbfb4bcd8) at ./manager.moc:111
#37 0x0826b11a in QMetaObject::metacall (object=0x98e82f0, cl=2287, idx=20, argv=0xbfb4bcd8) at kernel/qmetaobject.cpp:237
#38 0x0827989b in QMetaObject::activate (sender=0x98e8b38, m=0x2105a80, local_signal_index=0, argv=0xbfb4bcd8) at kernel/qobject.cpp:3294
#39 0x020fb323 in OrgFreedesktopNetworkManagerInterface::DeviceAdded (this=0x98e8b38, _t1=...) at ./nm-manager-clientinterface.moc:155
#40 0x020fb895 in OrgFreedesktopNetworkManagerInterface::qt_metacall (this=0x98e8b38, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0xbfb4bf1c) at ./nm-manager-clientinterface.moc:102
#41 0x00c389f4 in QDBusConnectionPrivate::deliverCall (this=0x98b78b0, object=0x98e8b38, msg=..., metaTypes=..., slotIdx=5) at qdbusintegrator.cpp:904
#42 0x00c40cf7 in QDBusCallDeliveryEvent::placeMetaCall (this=0x9941d58, object=0x98e8b38) at qdbusintegrator_p.h:101
#43 0x082768ae in QObject::event (this=0x98e8b38, e=0x9941d58) at kernel/qobject.cpp:1260
#44 0x00eef19c in QApplicationPrivate::notify_helper (this=0x981dbc8, receiver=0x98e8b38, e=0x9941d58) at kernel/qapplication.cpp:4242
#45 0x00ef5df7 in QApplication::notify (this=0xbfb4c770, receiver=0x98e8b38, e=0x9941d58) at kernel/qapplication.cpp:3661
#46 0x002ed67a in KApplication::notify (this=0xbfb4c770, receiver=0x98e8b38, event=0x9941d58) at ../../kdeui/kernel/kapplication.cpp:302
#47 0x08265eab in QCoreApplication::notifyInternal (this=0xbfb4c770, receiver=0x98e8b38, event=0x9941d58) at kernel/qcoreapplication.cpp:704
#48 0x082688e3 in QCoreApplication::sendEvent (receiver=0x0, event_type=0, data=0x97fce38) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#49 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x97fce38) at kernel/qcoreapplication.cpp:1345
#50 0x08268a4d in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1238
#51 0x082920df in QCoreApplication::sendPostedEvents (s=0x981fd20) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#52 postEventSourceDispatch (s=0x981fd20) at kernel/qeventdispatcher_glib.cpp:276
#53 0x06688e88 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#54 0x0668c730 in ?? () from /lib/libglib-2.0.so.0
#55 0x0668c863 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#56 0x08291bd5 in QEventDispatcherGlib::processEvents (this=0x981d7e8, flags=...) at kernel/qeventdispatcher_glib.cpp:407
#57 0x00facb75 in QGuiEventDispatcherGlib::processEvents (this=0x981d7e8, flags=...) at kernel/qguieventdispatcher_glib.cpp:202
#58 0x082644c9 in QEventLoop::processEvents (this=0xbfb4c6d4, flags=) at kernel/qeventloop.cpp:149
#59 0x0826491a in QEventLoop::exec (this=0xbfb4c6d4, flags=...) at kernel/qeventloop.cpp:201
#60 0x08268b0f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:981
#61 0x00eef237 in QApplication::exec () at kernel/qapplication.cpp:3570
#62 0x08052905 in main (argc=1, argv=0xbfb4c8c4) at /build/buildd/plasma-widget-networkmanagement-0.9~svn1029786+ag1/monolithic/main.cpp:45

Possible duplicates by query: bug 220452, bug 187667.

Reported using DrKonqi
Comment 1 Dario Andres 2010-01-12 00:20:43 UTC
This could be related to the glibc bug : bug 196207.
Check this:
- Quit knetworkmanager
- Start Konsole
- Type "export QT_NO_GLIB=1" + Enter
- Type "export MALLOC_CHECK_=" + Enter
- Type "knetworkmanager" + Enter
- Repeat the situation and check if it crashes or not
If it doesn't crash, then it is likely to be bug 196207. 
If it crashes, the backtrace could be different, and then it could be bug 210878 or bug 215918.  
Thanks
Comment 2 Markus Hinkelmann 2010-01-12 10:45:24 UTC
Created attachment 39809 [details]
backtrace of knetworkmanager crash produced using procedure from comment #1
Comment 3 Markus Hinkelmann 2010-01-12 10:47:05 UTC
Hi,
I checked your procedure, knetworkmanager still crashes. You'll find the backtrace attached above. 
Some more information: The crash happened on my laptop using wifi and a wpa secured network. If I disable wireless connections or use a wired connection instead, then knetworkmanager does not crash. As soon as I enable wireless and restart network-manager the crash appears.

bye
Markus
Comment 4 Dario Andres 2010-01-12 13:13:20 UTC
This is bug 210878. Merging. Thanks

*** This bug has been marked as a duplicate of bug 210878 ***