Bug 224061 - dolphin crash after umount usb key
Summary: dolphin crash after umount usb key
Status: RESOLVED DUPLICATE of bug 211525
Alias: None
Product: dolphin
Classification: Applications
Component: general (show other bugs)
Version: 16.12.2
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Peter Penz
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-01-24 18:03 UTC by Raphael
Modified: 2010-01-24 20:10 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Raphael 2010-01-24 18:03:23 UTC
Application that crashed: dolphin
Version of the application: 1.3
KDE Version: 4.3.4 (KDE 4.3.4)
Qt Version: 4.5.2
Operating System: Linux 2.6.31-17-generic x86_64
Distribution: Ubuntu 9.10

What I was doing when the application crashed:
repetively mount/umount usb key, and dolphin crashed

 -- Backtrace:
Application: Dolphin (dolphin), signal: Segmentation fault
[Current thread is 1 (Thread 0x7fe6cd0fc750 (LWP 29460))]

Thread 2 (Thread 0x7fe6b8545910 (LWP 7817)):
#0  pthread_cond_timedwait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:220
#1  0x00007fe6b7878c91 in ?? () from /usr/lib/libxine.so.1
#2  0x00007fe6c53a9a04 in start_thread (arg=<value optimized out>) at pthread_create.c:300
#3  0x00007fe6c93f880d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#4  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fe6cd0fc750 (LWP 29460)):
[KCrash Handler]
#5  0x00007fe6c9a93720 in QUrl::QUrl(QUrl const&) () from /usr/lib/libQtCore.so.4
#6  0x00007fe6cace2339 in KUrl::KUrl(KUrl const&) () from /usr/lib/libkdecore.so.5
#7  0x00007fe6ccb8eec0 in KFileItem::url() const () from /usr/lib/libkio.so.5
#8  0x00007fe6ccb7f6e4 in KDirModel::indexForItem(KFileItem const&) const () from /usr/lib/libkio.so.5
#9  0x00007fe6cc823960 in KFilePreviewGenerator::Private::orderItems(KFileItemList&) () from /usr/lib/libkfile.so.4
#10 0x00007fe6cc827662 in KFilePreviewGenerator::Private::updateIcons(KFileItemList const&) () from /usr/lib/libkfile.so.4
#11 0x00007fe6cc8278bf in KFilePreviewGenerator::Private::delayedIconUpdate() () from /usr/lib/libkfile.so.4
#12 0x00007fe6cc828935 in KFilePreviewGenerator::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libkfile.so.4
#13 0x00007fe6c9af1ddc in QMetaObject::activate(QObject*, int, int, void**) () from /usr/lib/libQtCore.so.4
#14 0x00007fe6c9aebd83 in QObject::event(QEvent*) () from /usr/lib/libQtCore.so.4
#15 0x00007fe6c9f6fefc in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#16 0x00007fe6c9f771ce in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#17 0x00007fe6cb2a8e56 in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#18 0x00007fe6c9adcc2c in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#19 0x00007fe6c9b07862 in ?? () from /usr/lib/libQtCore.so.4
#20 0x00007fe6c9b0525d in ?? () from /usr/lib/libQtCore.so.4
#21 0x00007fe6c55fabce in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#22 0x00007fe6c55fe598 in ?? () from /lib/libglib-2.0.so.0
#23 0x00007fe6c55fe6c0 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#24 0x00007fe6c9b051a6 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#25 0x00007fe6ca0044be in ?? () from /usr/lib/libQtGui.so.4
#26 0x00007fe6c9adb532 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#27 0x00007fe6c9adb904 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#28 0x00007fe6c9addab9 in QCoreApplication::exec() () from /usr/lib/libQtCore.so.4
#29 0x0000000000439555 in _start ()
The current source language is "auto; currently asm".
The current source language is "auto; currently c".

This bug may be a duplicate of or related to bug 223551

Reported using DrKonqi
Comment 1 Dario Andres 2010-01-24 20:10:19 UTC
Fixed in KDE SC 4.4 ande 4.3.5
Regards

*** This bug has been marked as a duplicate of bug 211525 ***