Bug 223551 - dolphin crashed on plugging/unplugging pen drive repeately
Summary: dolphin crashed on plugging/unplugging pen drive repeately
Status: RESOLVED DUPLICATE of bug 211525
Alias: None
Product: dolphin
Classification: Applications
Component: general (show other bugs)
Version: 16.12.2
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Peter Penz
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-01-20 11:01 UTC by meding
Modified: 2010-01-20 11:14 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description meding 2010-01-20 11:01:35 UTC
Application that crashed: dolphin
Version of the application: 1.3
KDE Version: 4.3.2 (KDE 4.3.2)
Qt Version: 4.5.2
Operating System: Linux 2.6.31-17-generic i686
Distribution: Ubuntu 9.10

What I was doing when the application crashed:
I was using a Kingston Data Traveler (2GB) pen drive to move files between systems. Dolphin crashed after unplugging the drive. It worked just fine 2 or 3 times prior to that.


 -- Backtrace:
Application: Dolphin (dolphin), signal: Segmentation fault
[KCrash Handler]
#7  0x05822829 in QUrl::QUrl(QUrl const&) () from /usr/lib/libQtCore.so.4
#8  0x00bb1d89 in KUrl::KUrl(KUrl const&) () from /usr/lib/libkdecore.so.5
#9  0x0022528e in KFileItem::url() const () from /usr/lib/libkio.so.5
#10 0x0021475f in KDirModel::indexForItem(KFileItem const&) const () from /usr/lib/libkio.so.5
#11 0x009c7a36 in KFilePreviewGenerator::Private::orderItems(KFileItemList&) () from /usr/lib/libkfile.so.4
#12 0x009cb6bd in KFilePreviewGenerator::Private::updateIcons(KFileItemList const&) () from /usr/lib/libkfile.so.4
#13 0x009cb902 in KFilePreviewGenerator::Private::delayedIconUpdate() () from /usr/lib/libkfile.so.4
#14 0x009cc9a6 in KFilePreviewGenerator::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libkfile.so.4
#15 0x05884263 in QMetaObject::activate(QObject*, int, int, void**) () from /usr/lib/libQtCore.so.4
#16 0x05884ec2 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/libQtCore.so.4
#17 0x058be667 in QTimer::timeout() () from /usr/lib/libQtCore.so.4
#18 0x058899ae in QTimer::timerEvent(QTimerEvent*) () from /usr/lib/libQtCore.so.4
#19 0x0587e3bf in QObject::event(QEvent*) () from /usr/lib/libQtCore.so.4
#20 0x0168cf54 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#21 0x0169467c in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#22 0x01001bfa in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#23 0x0586e6cb in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#24 0x0589b7ce in ?? () from /usr/lib/libQtCore.so.4
#25 0x058990e0 in ?? () from /usr/lib/libQtCore.so.4
#26 0x0133de88 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#27 0x01341730 in ?? () from /lib/libglib-2.0.so.0
#28 0x01341863 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#29 0x0589902c in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#30 0x0172dbe5 in ?? () from /usr/lib/libQtGui.so.4
#31 0x0586cc79 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#32 0x0586d0ca in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#33 0x0586f53f in QCoreApplication::exec() () from /usr/lib/libQtCore.so.4
#34 0x0168cdd7 in QApplication::exec() () from /usr/lib/libQtGui.so.4
#35 0x0807a745 in _start ()

This bug may be a duplicate of or related to bug 223549

Reported using DrKonqi
Comment 1 Peter Penz 2010-01-20 11:14:07 UTC

*** This bug has been marked as a duplicate of bug 211525 ***