Bug 223549 - Dolphin crashes when USB key unpluged
Summary: Dolphin crashes when USB key unpluged
Status: RESOLVED DUPLICATE of bug 211525
Alias: None
Product: dolphin
Classification: Applications
Component: general (show other bugs)
Version: 16.12.2
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Peter Penz
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-01-20 10:47 UTC by dr1ver38
Modified: 2010-01-20 11:13 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description dr1ver38 2010-01-20 10:47:34 UTC
Application that crashed: dolphin
Version of the application: 1.3
KDE Version: 4.3.2 (KDE 4.3.2)
Qt Version: 4.5.2
Operating System: Linux 2.6.31-15-generic i686
Distribution: Ubuntu 9.10

What I was doing when the application crashed:
USB Key SanDisk Cruzer Titanium
All programs and files on the key were closed just before, but Dolphin must hasn't got the time to close behind.

 -- Backtrace:
Application: Dolphin (dolphin), signal: Segmentation fault
[KCrash Handler]
#6  0x012c7829 in QUrl::QUrl(QUrl const&) () from /usr/lib/libQtCore.so.4
#7  0x0105ad89 in KUrl::KUrl(KUrl const&) () from /usr/lib/libkdecore.so.5
#8  0x00b5e28e in KFileItem::url() const () from /usr/lib/libkio.so.5
#9  0x00b4d75f in KDirModel::indexForItem(KFileItem const&) const () from /usr/lib/libkio.so.5
#10 0x0017fa36 in KFilePreviewGenerator::Private::orderItems(KFileItemList&) () from /usr/lib/libkfile.so.4
#11 0x001836bd in KFilePreviewGenerator::Private::updateIcons(KFileItemList const&) () from /usr/lib/libkfile.so.4
#12 0x00183902 in KFilePreviewGenerator::Private::delayedIconUpdate() () from /usr/lib/libkfile.so.4
#13 0x001849a6 in KFilePreviewGenerator::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libkfile.so.4
#14 0x01329263 in QMetaObject::activate(QObject*, int, int, void**) () from /usr/lib/libQtCore.so.4
#15 0x01329ec2 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/libQtCore.so.4
#16 0x01363667 in QTimer::timeout() () from /usr/lib/libQtCore.so.4
#17 0x0132e9ae in QTimer::timerEvent(QTimerEvent*) () from /usr/lib/libQtCore.so.4
#18 0x013233bf in QObject::event(QEvent*) () from /usr/lib/libQtCore.so.4
#19 0x05feef54 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#20 0x05ff667c in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#21 0x005a3bfa in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#22 0x013136cb in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#23 0x013407ce in ?? () from /usr/lib/libQtCore.so.4
#24 0x0133e0e0 in ?? () from /usr/lib/libQtCore.so.4
#25 0x0887ce88 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#26 0x08880730 in ?? () from /lib/libglib-2.0.so.0
#27 0x08880863 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#28 0x0133e02c in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#29 0x0608fbe5 in ?? () from /usr/lib/libQtGui.so.4
#30 0x01311c79 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#31 0x013120ca in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#32 0x0131453f in QCoreApplication::exec() () from /usr/lib/libQtCore.so.4
#33 0x05feedd7 in QApplication::exec() () from /usr/lib/libQtGui.so.4
#34 0x0807a745 in _start ()

This bug may be a duplicate of or related to bug 222577

Reported using DrKonqi
Comment 1 Peter Penz 2010-01-20 11:13:28 UTC

*** This bug has been marked as a duplicate of bug 211525 ***