Bug 222577 - dolphin (and all desktop)crashed after unplugging usb drive
Summary: dolphin (and all desktop)crashed after unplugging usb drive
Status: RESOLVED DUPLICATE of bug 211525
Alias: None
Product: dolphin
Classification: Applications
Component: general (show other bugs)
Version: 16.12.2
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Peter Penz
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-01-13 19:55 UTC by EHRepli
Modified: 2010-01-14 11:55 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description EHRepli 2010-01-13 19:55:28 UTC
Application that crashed: dolphin
Version of the application: 1.3
KDE Version: 4.3.2 (KDE 4.3.2)
Qt Version: 4.5.2
Operating System: Linux 2.6.31-17-generic x86_64
Distribution: Ubuntu 9.10

What I was doing when the application crashed:
unmonted usb drive, and dolpihn and desktop crashed seconds after getting me back to the login screen

 -- Backtrace:
Application: Dolphin (dolphin), signal: Segmentation fault
[KCrash Handler]
#5  0x00007f6b5bc77720 in QUrl::QUrl(QUrl const&) () from /usr/lib/libQtCore.so.4
#6  0x00007f6b5cec5fc9 in KUrl::KUrl(KUrl const&) () from /usr/lib/libkdecore.so.5
#7  0x00007f6b5ed6eec0 in KFileItem::url() const () from /usr/lib/libkio.so.5
#8  0x00007f6b5ed5f6e4 in KDirModel::indexForItem(KFileItem const&) const () from /usr/lib/libkio.so.5
#9  0x00007f6b5ea03920 in KFilePreviewGenerator::Private::orderItems(KFileItemList&) () from /usr/lib/libkfile.so.4
#10 0x00007f6b5ea07622 in KFilePreviewGenerator::Private::updateIcons(KFileItemList const&) () from /usr/lib/libkfile.so.4
#11 0x00007f6b5ea0787f in KFilePreviewGenerator::Private::delayedIconUpdate() () from /usr/lib/libkfile.so.4
#12 0x00007f6b5ea088f5 in KFilePreviewGenerator::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libkfile.so.4
#13 0x00007f6b5bcd5ddc in QMetaObject::activate(QObject*, int, int, void**) () from /usr/lib/libQtCore.so.4
#14 0x00007f6b5bccfd83 in QObject::event(QEvent*) () from /usr/lib/libQtCore.so.4
#15 0x00007f6b5c153efc in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#16 0x00007f6b5c15b1ce in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#17 0x00007f6b5d488ab6 in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#18 0x00007f6b5bcc0c2c in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#19 0x00007f6b5bceb862 in ?? () from /usr/lib/libQtCore.so.4
#20 0x00007f6b5bce925d in ?? () from /usr/lib/libQtCore.so.4
#21 0x00007f6b577debce in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#22 0x00007f6b577e2598 in ?? () from /lib/libglib-2.0.so.0
#23 0x00007f6b577e26c0 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#24 0x00007f6b5bce91a6 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#25 0x00007f6b5c1e84be in ?? () from /usr/lib/libQtGui.so.4
#26 0x00007f6b5bcbf532 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#27 0x00007f6b5bcbf904 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#28 0x00007f6b5bcc1ab9 in QCoreApplication::exec() () from /usr/lib/libQtCore.so.4
#29 0x0000000000439555 in _start ()

This bug may be a duplicate of or related to bug 214941

Reported using DrKonqi
Comment 1 Frank Reininghaus 2010-01-14 11:55:54 UTC
Thanks for the bug report! This crash will be fixed in KDE SC 4.4.

*** This bug has been marked as a duplicate of bug 211525 ***