Bug 223432 (clientmodel.cpp:77) - "Walk Through Desktops" crashes
Summary: "Walk Through Desktops" crashes
Status: RESOLVED FIXED
Alias: clientmodel.cpp:77
Product: kwin
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
: 225917 228339 228629 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-01-19 18:28 UTC by Andre Woebbeking
Modified: 2010-02-26 17:54 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (3.98 KB, text/plain)
2010-02-26 11:32 UTC, Bartemius Crouch
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andre Woebbeking 2010-01-19 18:28:26 UTC
Application: kwin (4.3.90 (KDE 4.3.90 (KDE 4.4 RC1)))
KDE Platform Version: 4.3.90 (KDE 4.3.90 (KDE 4.4 RC1)) (Compiled from sources)
Qt Version: 4.6.1
Operating System: Linux 2.6.32-trunk-amd64 x86_64
Distribution: Debian GNU/Linux unstable (sid)

-- Information about the crash:
This is maybe related to windows opened or closed while I'm pressing the shortcut. 

Another reason could be that I press the shortcut only for a very short time to switch to the last shown desktop.

The crash can be reproduced some of the time.

 -- Backtrace:
Application: KWin (kwin), signal: Segmentation fault
The current source language is "auto; currently c".
[KCrash Handler]
#5  0x00000000011fd0e0 in ?? ()
#6  0x00007f034ba17039 in KWin::TabBox::ClientModel::data (this=0x134ad70, index=<value optimized out>, role=<value optimized out>) at /D/src/kde4/4.4/kdebase/workspace/kwin/tabbox/clientmodel.cpp:77
#7  0x00007f034ba1bc21 in KWin::TabBox::TabBoxHandlerPrivate::updateHighlightWindows (this=0x12735a0) at /D/src/kde4/4.4/kdebase/workspace/kwin/tabbox/tabboxhandler.cpp:237
#8  0x00007f034ba11c9e in KWin::TabBox::TabBox::qt_metacall (this=0x1373370, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=<value optimized out>)
    at /D/build/kde4/4.4/kdebase/workspace/kwin/tabbox.moc:72
#9  0x00007f034a17c07f in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /D/src/kde4/qt/lib/libQtCore.so.4
#10 0x00007f034a177d93 in QObject::event(QEvent*) () from /D/src/kde4/qt/lib/libQtCore.so.4
#11 0x00007f034a510100 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /D/src/kde4/qt/lib/libQtGui.so.4
#12 0x00007f034a518047 in QApplication::notify(QObject*, QEvent*) () from /D/src/kde4/qt/lib/libQtGui.so.4
#13 0x00007f034b39331a in KApplication::notify (this=0x7fffd10a7a40, receiver=0x13733b8, event=0x7fffd10a76e0) at /D/src/kde4/4.4/kdelibs/kdeui/kernel/kapplication.cpp:302
#14 0x00007f034a166bec in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /D/src/kde4/qt/lib/libQtCore.so.4
#15 0x00007f034a19757a in QTimerInfoList::activateTimers() () from /D/src/kde4/qt/lib/libQtCore.so.4
#16 0x00007f034a193ce8 in idleTimerSourceDispatch(_GSource*, int (*)(void*), void*) () from /D/src/kde4/qt/lib/libQtCore.so.4
#17 0x00007f034457890e in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#18 0x00007f034457c2c8 in ?? () from /lib/libglib-2.0.so.0
#19 0x00007f034457c3f0 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#20 0x00007f034a1939b3 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /D/src/kde4/qt/lib/libQtCore.so.4
#21 0x00007f034a5c904e in QGuiEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /D/src/kde4/qt/lib/libQtGui.so.4
#22 0x00007f034a1653e2 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /D/src/kde4/qt/lib/libQtCore.so.4
#23 0x00007f034a1657bc in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /D/src/kde4/qt/lib/libQtCore.so.4
#24 0x00007f034a167d9b in QCoreApplication::exec() () from /D/src/kde4/qt/lib/libQtCore.so.4
#25 0x00007f034ba0fd7b in kdemain (argc=<value optimized out>, argv=<value optimized out>) at /D/src/kde4/4.4/kdebase/workspace/kwin/main.cpp:526
#26 0x00007f0347311abd in __libc_start_main (main=<value optimized out>, argc=<value optimized out>, ubp_av=<value optimized out>, init=<value optimized out>, fini=<value optimized out>, 
    rtld_fini=<value optimized out>, stack_end=0x7fffd10a7f48) at libc-start.c:222
#27 0x0000000000400869 in _start ()

Reported using DrKonqi
Comment 1 Martin Flöser 2010-02-24 18:01:30 UTC
*** Bug 228339 has been marked as a duplicate of this bug. ***
Comment 2 Bartemius Crouch 2010-02-26 11:32:18 UTC
Created attachment 41131 [details]
New crash information added by DrKonqi

Stack trace looks remarkably similar, I'm quite sure I have the same bug.

It happens sometimes on desktop switching. I cannot reproduce it consistently, but it happens multiple times a day. Tried different window decorations, that didn't help. I have compositing on and use the animation where the screen moves sideways to a different desktop.

Using KDE from the Kunbuntu backports PPA, with debug symbols installed separately.
Comment 3 Martin Flöser 2010-02-26 15:31:56 UTC
*** Bug 225917 has been marked as a duplicate of this bug. ***
Comment 4 Martin Flöser 2010-02-26 15:32:03 UTC
*** Bug 228629 has been marked as a duplicate of this bug. ***
Comment 5 Martin Flöser 2010-02-26 17:50:48 UTC
SVN commit 1096422 by graesslin:

Do not activate highlight windows in desktop switching. This fixes a crash in walk through desktops.
BUG: 223432

 M  +1 -1      tabboxhandler.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1096422
Comment 6 Martin Flöser 2010-02-26 17:54:57 UTC
SVN commit 1096424 by graesslin:

Backport rev 1096422:
Do not activate highlight windows in desktop switching. This fixes a crash in walk through desktops.
CCBUG: 223432


 M  +1 -1      tabboxhandler.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1096424