Bug 208033 - Kile crashes when closing
Summary: Kile crashes when closing
Status: RESOLVED DUPLICATE of bug 200450
Alias: None
Product: kile
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Michel Ludwig
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-09-21 00:07 UTC by jchampavere
Modified: 2009-09-21 01:22 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jchampavere 2009-09-21 00:07:22 UTC
Application that crashed: kile
Version of the application: 2.0.83
KDE Version: 4.3.1 (KDE 4.3.1)
Qt Version: 4.5.2
Operating System: Linux 2.6.30-1-686 i686
Distribution: Debian GNU/Linux testing (squeeze)

What I was doing when the application crashed:
Kile crashes when closing either one file of the current project or the whole application. This does not always happen, but it happens "randomly" without visible reason…

 -- Backtrace:
Application: Kile (kile), signal: Segmentation fault
[KCrash Handler]
#6  0xb3c8111f in KateSmartCursor::setPositionInternal (this=0xb02b610, pos=..., internal=true) at ../../kate/smart/katesmartcursor.cpp:186
#7  0xb3c81508 in KateSmartCursor::translate (this=0xb02b610, edit=...) at ../../kate/smart/katesmartcursor.cpp:305
#8  0xb3c86bc1 in KateSmartGroup::translateChanged (this=0xaabb4c0, edit=...) at ../../kate/smart/katesmartmanager.cpp:464
#9  0xb3c8a477 in KateSmartManager::slotTextChanged (this=0xaaba658, edit=0xaabb830) at ../../kate/smart/katesmartmanager.cpp:368
#10 0xb3c8a824 in KateSmartManager::qt_metacall (this=0xaaba658, _c=QMetaObject::InvokeMetaMethod, _id=1, _a=0xbff6307c) at ./katesmartmanager.moc:74
#11 0xb6b5cb33 in QMetaObject::activate (sender=0xaabc0d0, from_signal_index=4, to_signal_index=4, argv=0xbff6307c) at kernel/qobject.cpp:3112
#12 0xb6b5d782 in QMetaObject::activate (sender=0xaabc0d0, m=0xb3d8fcc4, local_signal_index=0, argv=0xbff6307c) at kernel/qobject.cpp:3186
#13 0xb3c59323 in KateEditHistory::editDone (this=0xaabc0d0, _t1=0xaabb830) at ./kateedit.moc:78
#14 0xb3c30f43 in KateDocument::closeUrl (this=0xaabc250) at ../../kate/document/katedocument.cpp:3606
#15 0x082cf310 in _start ()

Reported using DrKonqi
Comment 1 Dario Andres 2009-09-21 01:22:52 UTC
The backtrace is related to bug 204737 / bug 200450. Thanks

*** This bug has been marked as a duplicate of bug 200450 ***