Bug 222709 - akonadiresource crashed opening vcf-file recouce properties in kaddressbook (kontact)
Summary: akonadiresource crashed opening vcf-file recouce properties in kaddressbook (...
Status: RESOLVED DUPLICATE of bug 222547
Alias: None
Product: Akonadi
Classification: Frameworks and Libraries
Component: VCard file resource (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Volker Krause
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-01-14 14:13 UTC by Florian Reinhard
Modified: 2010-01-15 01:20 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Florian Reinhard 2010-01-14 14:13:32 UTC
Application: akonadi_vcard_resource (0.1)
KDE Platform Version: 4.3.90 (KDE 4.3.90 (KDE 4.4 RC1))
Qt Version: 4.6.0
Operating System: Linux 2.6.31-16-generic i686
Distribution: Ubuntu 9.10

-- Information about the crash:
* couldn't edit a contact
* opened the properties for the corresponding addressbook (vcf file resource)
* saw read only is not checked
* tried to edit againm didn't work
* opened the properties dialog once again => crash

 -- Backtrace:
Application: Akonadi Resource (akonadi_vcard_resource), signal: Segmentation fault
[KCrash Handler]
#6  QBasicAtomicInt::ref (this=0x8f90794) at /usr/include/qt4/QtCore/qatomic_i386.h:120
#7  QList (this=0x8f90794) at /usr/include/qt4/QtCore/qlist.h:114
#8  QForeachContainer (this=0x8f90794) at /usr/include/qt4/QtCore/qglobal.h:2229
#9  KDirWatchPrivate::Entry::propagate_dirty (this=0x8f90794) at ../../kio/kio/kdirwatch.cpp:416
#10 0x00aa3ab1 in KDirWatchPrivate::Entry::propagate_dirty (this=0x8f6033c) at ../../kio/kio/kdirwatch.cpp:421
#11 0x00aad7a1 in KDirWatchPrivate::slotRescan (this=0x8f0e1b8) at ../../kio/kio/kdirwatch.cpp:1349
#12 0x00aae383 in KDirWatchPrivate::qt_metacall (this=0x8f0e1b8, _c=QMetaObject::InvokeMetaMethod, _id=4, _a=0xbf82aa7c) at ./kdirwatch_p.moc:81
#13 0x0042d11a in QMetaObject::metacall (object=0x8f0e1b8, cl=QMetaObject::ReadProperty, idx=4, argv=0xbf82aa7c) at kernel/qmetaobject.cpp:237
#14 0x0043b89b in QMetaObject::activate (sender=0x8f0e200, m=0x53c5a4, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3294
#15 0x0048d1c7 in QTimer::timeout (this=0x8f0e200) at .moc/release-shared/moc_qtimer.cpp:134
#16 0x00443b4e in QTimer::timerEvent (this=0x8f0e200, e=0xbf82af40) at kernel/qtimer.cpp:271
#17 0x00438704 in QObject::event (this=0x8f0e200, e=0x8f90794) at kernel/qobject.cpp:1224
#18 0x0501719c in QApplicationPrivate::notify_helper (this=0x8e159e0, receiver=0x8f0e200, e=0xbf82af40) at kernel/qapplication.cpp:4242
#19 0x0501ddf7 in QApplication::notify (this=0xbf82b2a0, receiver=0x8f0e200, e=0xbf82af40) at kernel/qapplication.cpp:3661
#20 0x00f3f67a in KApplication::notify (this=0xbf82b2a0, receiver=0x8f0e200, event=0xbf82af40) at ../../kdeui/kernel/kapplication.cpp:302
#21 0x00427eab in QCoreApplication::notifyInternal (this=0xbf82b2a0, receiver=0x8f0e200, event=0xbf82af40) at kernel/qcoreapplication.cpp:704
#22 0x00457286 in QCoreApplication::sendEvent (this=0x8e18c34) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#23 QTimerInfoList::activateTimers (this=0x8e18c34) at kernel/qeventdispatcher_unix.cpp:603
#24 0x00453f17 in timerSourceDispatch (source=0x8e187b8) at kernel/qeventdispatcher_glib.cpp:184
#25 idleTimerSourceDispatch (source=0x8e187b8) at kernel/qeventdispatcher_glib.cpp:231
#26 0x03512e88 in g_main_dispatch (context=0x8e17510) at /build/buildd/glib2.0-2.22.3/glib/gmain.c:1960
#27 IA__g_main_context_dispatch (context=0x8e17510) at /build/buildd/glib2.0-2.22.3/glib/gmain.c:2513
#28 0x03516730 in g_main_context_iterate (context=0x8e17510, block=<value optimized out>, dispatch=1, self=0x8e02810) at /build/buildd/glib2.0-2.22.3/glib/gmain.c:2591
#29 0x03516863 in IA__g_main_context_iteration (context=0x8e17510, may_block=1) at /build/buildd/glib2.0-2.22.3/glib/gmain.c:2654
#30 0x00453bd5 in QEventDispatcherGlib::processEvents (this=0x8e159c0, flags=...) at kernel/qeventdispatcher_glib.cpp:407
#31 0x050d4b75 in QGuiEventDispatcherGlib::processEvents (this=0x8e159c0, flags=...) at kernel/qguieventdispatcher_glib.cpp:202
#32 0x004264c9 in QEventLoop::processEvents (this=0xbf82b204, flags=) at kernel/qeventloop.cpp:149
#33 0x0042691a in QEventLoop::exec (this=0xbf82b204, flags=...) at kernel/qeventloop.cpp:201
#34 0x0042ab0f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:981
#35 0x05017237 in QApplication::exec () at kernel/qapplication.cpp:3570
#36 0x0021af63 in Akonadi::ResourceBase::init (r=0x8f06560) at ../../akonadi/resourcebase.cpp:219
#37 0x08056343 in ?? ()
#38 0x07b8fb56 in __libc_start_main (main=0x80562c0, argc=3, ubp_av=0xbf82b384, init=0x805bd90 <__libc_csu_init>, fini=0x805bd80 <__libc_csu_fini>, rtld_fini=0x98bd20 <_dl_fini>, 
    stack_end=0xbf82b37c) at libc-start.c:220
#39 0x08050711 in _start ()

Possible duplicates by query: bug 222547, bug 221469.

Reported using DrKonqi
Comment 1 Dario Andres 2010-01-15 01:20:28 UTC
The crash is related to KIO, merging with bug 222547. Thanks

*** This bug has been marked as a duplicate of bug 222547 ***