Bug 214941 - dolphin crashes after disconnecting USB drive
Summary: dolphin crashes after disconnecting USB drive
Status: RESOLVED DUPLICATE of bug 211525
Alias: None
Product: dolphin
Classification: Applications
Component: general (show other bugs)
Version: 16.12.2
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Peter Penz
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-11-17 11:00 UTC by Stefan Götz
Modified: 2009-11-17 11:37 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan Götz 2009-11-17 11:00:34 UTC
Application that crashed: dolphin
Version of the application: 1.3
KDE Version: 4.3.2 (KDE 4.3.2)
Qt Version: 4.5.2
Operating System: Linux 2.6.31-14-generic i686
Distribution: Ubuntu 9.10

What I was doing when the application crashed:
In dolphin, 'safely removed' USB drive, unplugged it, and opened a different bookmark in dolphin which made it crash

 -- Backtrace:
Application: Dolphin (dolphin), signal: Segmentation fault
[KCrash Handler]
#6  0x00bc2829 in QUrl::QUrl(QUrl const&) () from /usr/lib/libQtCore.so.4
#7  0x0039dd89 in KUrl::KUrl(KUrl const&) () from /usr/lib/libkdecore.so.5
#8  0x00e5828e in KFileItem::url() const () from /usr/lib/libkio.so.5
#9  0x00e4775f in KDirModel::indexForItem(KFileItem const&) const () from /usr/lib/libkio.so.5
#10 0x006a1a36 in KFilePreviewGenerator::Private::orderItems(KFileItemList&) () from /usr/lib/libkfile.so.4
#11 0x006a56bd in KFilePreviewGenerator::Private::updateIcons(KFileItemList const&) () from /usr/lib/libkfile.so.4
#12 0x006a5902 in KFilePreviewGenerator::Private::delayedIconUpdate() () from /usr/lib/libkfile.so.4
#13 0x006a69a6 in KFilePreviewGenerator::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libkfile.so.4
#14 0x00c24263 in QMetaObject::activate(QObject*, int, int, void**) () from /usr/lib/libQtCore.so.4
#15 0x00c24ec2 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/libQtCore.so.4
#16 0x00c5e667 in QTimer::timeout() () from /usr/lib/libQtCore.so.4
#17 0x00c299ae in QTimer::timerEvent(QTimerEvent*) () from /usr/lib/libQtCore.so.4
#18 0x00c1e3bf in QObject::event(QEvent*) () from /usr/lib/libQtCore.so.4
#19 0x07225f54 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#20 0x0722d67c in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#21 0x011d0bfa in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#22 0x00c0e6cb in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#23 0x00c3b7ce in ?? () from /usr/lib/libQtCore.so.4
#24 0x00c390e0 in ?? () from /usr/lib/libQtCore.so.4
#25 0x07d5ae78 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#26 0x07d5e720 in ?? () from /lib/libglib-2.0.so.0
#27 0x07d5e853 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#28 0x00c3902c in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#29 0x072c6be5 in ?? () from /usr/lib/libQtGui.so.4
#30 0x00c0cc79 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#31 0x00c0d0ca in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#32 0x00c0f53f in QCoreApplication::exec() () from /usr/lib/libQtCore.so.4
#33 0x07225dd7 in QApplication::exec() () from /usr/lib/libQtGui.so.4
#34 0x0807a745 in _start ()

This bug may be a duplicate of or related to bug 214285

Reported using DrKonqi
Comment 1 Frank Reininghaus 2009-11-17 11:37:29 UTC
Thanks for the bug report! This crash has been reported already.

*** This bug has been marked as a duplicate of bug 211525 ***