Bug 221533 - Cannot connect to openfire jabber server
Summary: Cannot connect to openfire jabber server
Status: RESOLVED UNMAINTAINED
Alias: None
Product: kopete
Classification: Unclassified
Component: general (show other bugs)
Version: 0.80.2
Platform: Fedora RPMs Linux
: NOR normal with 292 votes (vote)
Target Milestone: ---
Assignee: Kopete Developers
URL:
Keywords:
: 238160 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-01-06 15:14 UTC by sukesh
Modified: 2021-03-10 17:48 UTC (History)
23 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description sukesh 2010-01-06 15:14:56 UTC
Version:           0.80.2 (using KDE 4.3.4)
OS:                Linux
Installed from:    Fedora RPMs

Since upgrading to Fedora 12 I can no longer connect to an Openfire Jabber server (v3.6.4) with my account. 

I can successfully connect with pidgin and empathy to the same account. 

I also have a Fedora 11 laptop with all recent updates and that still works fine. Incidentally this is also running Kopete 0.80.2 on KDE 4.3.4

I get these errors in my .xsession-errors when connecting

kdeinit4: preparing to launch /usr/bin/kopete
Calling appendChild() on a null node does nothing.
Calling appendChild() on a null node does nothing.
Calling appendChild() on a null node does nothing.
JingleSessionManager::JingleSessionManager created.
Creating the PushJingleSession task....
Object::connect: No such signal XMPP::JingleSessionManager::incomingSession()


After a while Kopete gives an error saying it could not establish a TLS session
Comment 1 Salvatore Cristofaro 2010-01-22 12:09:27 UTC
I can't connect to Openfire server too

.xsession-errors

X Error: BadWindow (invalid Window parameter) 3
  Major opcode: 20 (X_GetProperty)
  Resource id:  0x4babee6
Unknown signature value:  0
Unknown signature value:  0
X Error: BadWindow (invalid Window parameter) 3
  Major opcode: 20 (X_GetProperty)
  Resource id:  0x4badf8c
Unknown signature value:  0
X Error: BadWindow (invalid Window parameter) 3
  Major opcode: 20 (X_GetProperty)
  Resource id:  0x4bae237
Unknown signature value:  0
X Error: BadWindow (invalid Window parameter) 3
  Major opcode: 20 (X_GetProperty)
  Resource id:  0x4bae910
Unknown signature value:  0
X Error: BadWindow (invalid Window parameter) 3
  Major opcode: 20 (X_GetProperty)
  Resource id:  0x4baeb88

Using Kubuntu 9.10 

Kopete Versione 0.80.2
Con KDE 4.3.2 (KDE 4.3.2)
Comment 2 csocratess 2010-02-03 06:32:11 UTC
Cannot connect to gchat from Kopete
Using kopete version 0.80.2(Using KDE 4.3.4) 
Below is the error message i got.

Creating the PushJingleSession task....
Object::connect: No such signal XMPP::JingleSessionManager::incomingSession()
Comment 3 Todd Zimmerman 2010-02-06 04:13:41 UTC
I am seeing this bug also.

Just upgraded to Fedora 12 and my SSL Kopete connection to a Openfire Jabber server fails silently after attempting to connect for a couple of minutes.  

Here is the complete command line session... although I'm not sure anything is relevant.  The appendChild errors notes seemed to come up before connection attempt, so I would rule those out.  Not so sure about the Jingle errors - but I have my doubts they are connected also.

% kopete --nofork  
Calling appendChild() on a null node does nothing.
Calling appendChild() on a null node does nothing.
Calling appendChild() on a null node does nothing.
Calling appendChild() on a null node does nothing.
JingleSessionManager::JingleSessionManager created. 
Creating the PushJingleSession task.... 
Object::connect: No such signal XMPP::JingleSessionManager::incomingSession()
Creating the PushJingleSession task.... 
Object::connect: No such signal XMPP::JingleSessionManager::incomingSession()


Other relevant info:

1. I run the server also - and have ports 5222 and 5223 open (5223 old style SSL)
2. This worked consistently in Fedora 11 and past for years.
3. I can see packets arriving at the server on initial connection attempt however nothing after server ack
4. Non SSL connections work in kopete
5. Empathy works in all modes (non SSL, SSL to 5223 and old style SSL to 5222)

Anywhere else I can find logs?
Comment 4 sukesh 2010-03-05 10:46:17 UTC
I dont know if this is related but I have also discovered that PSI has the same issue.

Im using

Fedora12 with all updates as of (5/3/10)
Psi 0.14
Qt 4.6.2

I try to connect to the same jabber server as I discussed before and get similair symptoms. After a while PSI errors with "TLS Handshake error"

The thing to note is that Kopete and PSI are both based on Qt
Comment 5 sukesh 2010-03-22 12:13:17 UTC
I have found that PSI jabber client cannot establish a connection either.

The one things these 2 clients have in common is that they are both QT based clients and hence use QCA to establish encryption. 

This may be a problem with QCA rather than the kopete software itself
Comment 6 William Haller 2010-04-21 23:25:04 UTC
Not sure about the SSL problems, but I can't get non-SSL to connect either to an openfire server. F11 connects fine. After the upgrade to F12, it fails. Pidgin connects fine SSL or non-SSL on 5222 or 5223.
Comment 7 Jaroslav Tulach 2010-05-28 07:41:40 UTC
*** Bug 238160 has been marked as a duplicate of this bug. ***
Comment 8 Jaroslav Tulach 2010-05-28 07:47:13 UTC
I can confirm the same problems. kopete and psi cannot connect to Google Talk. 
pidgin can. The difference seems to be QCA. The root problem seems to be:

Object::connect: No such signal XMPP::JingleSessionManager::incomingSession()

Someone shall change the subject line of the bug to include the "No such signal" error message. I don't have permissions to do it.
Comment 9 Bart 2010-06-23 10:56:23 UTC
Same problem over here, trying to connect to google talk:

--
Unknown signature value:  795 
--

Kopete version  1.0.80
                os build: 4:4.4.85-0ubuntu2

libqca2 version: 2.0.2
                os build: 2.0.2-1ubuntu2
Comment 10 Robin 2010-07-02 10:56:58 UTC
My kopete could connect to Google Talk before I did below.

I was following the url below for using MSN via Google Talk with transport servers using psi.

http://lifehacker.com/289097/chat-with-aim-msn-yahoo-and-other-contacts-over-
google-talk

After I did above, and not going well, I switched back to Kopete, and it couldn't connect to Google Talk anymore. I launched kopete from terminal and i get:

Unknown signature value:  795 

It occurs everytime I try to set status online.

My kopete version is: 4:4.4.5-0ubuntu1~lucid1~ppa1
Comment 11 Bart 2010-07-20 22:56:01 UTC
Maybe we should drop kopete from kde, and include pidgin by default, that's the only way to get something working.
Comment 12 Roman Stanec 2010-07-29 13:21:22 UTC
*** This bug has been confirmed by popular vote. ***
Comment 13 Roman Stanec 2010-07-29 13:25:11 UTC
same on FC13, tried kopete from svn, revision 1156603:
When I'm trying to connect to corporate jabber account, I see these log messages in the terminal:

JingleSessionManager::JingleSessionManager created. 
Creating the PushJingleSession task.... 
Object::connect: No such signal XMPP::JingleSessionManager::incomingSession()
Unknown signature value:  795 
Unknown signature value:  795 
Unknown signature value:  668 
Unknown signature value:  795 
Unknown signature value:  668 
Unknown signature value:  795 
Unknown signature value:  668

and no connection to jabber account is available.

I would set the priority to high.
Comment 14 Ken Koster 2010-08-20 22:25:15 UTC
Still a problem with recent development versions.

Version 1.0.80
Using KDE Development Platform 4.5.65 (KDE 4.5.65 (KDE 4.6 >= 20100819)) "release 1" on top off OpenSuse 11.3

Since I control the Openfire server I did some testing today and found that the problem seems to be with TLS support.  If I disable TLS and enable only the old SSL method on the server Kopete will succesfully connect.
Comment 15 lazx888 2010-08-25 02:58:58 UTC
Here is the error message that is logged when kopete attempts to connect to openfire:

2010.02.19 12:01:04 Closing session due to exception: (SOCKET, R: /127.0.1.1:33753, L: /127.0.1.1:5222, S: 0.0.0.0/0.0.0.0:5222)
org.apache.mina.filter.codec.ProtocolDecoderException: java.lang.Exception: Disallowed character (Hexdump: 80 62 01 03 01 00 39 00 00 00 20 00 00 04 01 00 80 00 00 05 00 00 2F 00 00 33 00 00 32 00 00 0A 07 00 C0 00 00 16 00 00 13 00 00 09 06 00 40 00 00 15 00 00 12 00 00 03 02 00 80 00 00 08 00 00 14 00 00 11 4B 7E 6F 70 A7 61 72 41 DF CB 80 47 07 08 5F 5E B1 9D BF BE 0E A2 BE D7 5B 6C D8 65 29 3E 55 FA)
at org.apache.mina.filter.codec.ProtocolCodecFilter.messageReceived(ProtocolCodecFilter.java:170)

at org.apache.mina.common.support.AbstractIoFilterChain.callNextMessageReceived(AbstractIoFilterChain.java:299)

at org.apache.mina.common.support.AbstractIoFilterChain.access$1100(AbstractIoFilterChain.java:53)

at org.apache.mina.common.support.AbstractIoFilterChain$EntryImpl$1.messageReceived(AbstractIoFilterChain.java:648)

at org.apache.mina.filter.executor.ExecutorFilter.processEvent(ExecutorFilter.java:239)

at org.apache.mina.filter.executor.ExecutorFilter$ProcessEventsRunnable.run(ExecutorFilter.java:283)

at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)

at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)

at org.apache.mina.util.NamePreservingRunnable.run(NamePreservingRunnable.java:51)

at java.lang.Thread.run(Thread.java:619)
Caused by: java.lang.Exception: Disallowed character
at org.jivesoftware.openfire.nio.XMLLightweightParser.read(XMLLightweightParser.java:211)

at org.jivesoftware.openfire.nio.XMPPDecoder.doDecode(XMPPDecoder.java:32)
at org.apache.mina.filter.codec.CumulativeProtocolDecoder.decode(CumulativeProtocolDecoder.java:133)

at org.apache.mina.filter.codec.ProtocolCodecFilter.messageReceived(ProtocolCodecFilter.java:163)

        ... 9 more

(copied from http://dev.eclipse.org/mhonarc/lists/ecf-dev/msg03380.html - exactly same as what I saw in my openfire logs though)


Psi (which uses QCA also) can connect to my openfire server OKAY.  If I recall correctly, kopete and psi were both not able to connect in April 2010.
Comment 16 Jens Lang 2010-09-26 17:05:20 UTC
This seems to be a problem with qca-ossl as described here: https://bugs.archlinux.org/task/19175?dev=280 . If I apply this patch to qca-ossl, it works for me: https://bugs.archlinux.org/task/19175?getfile=5727 (Ubuntu Maverick).
Comment 17 romabysen 2010-11-17 06:20:13 UTC
I can confirm this bug on Kubuntu 10.10/KDE 4.5.1. Both Psi and Kopete fail to connect to our openfire server while Gajim,Tkabber and qutIM can connect just fine.
Comment 18 Ron Eggler 2010-12-15 04:15:25 UTC
no resolution to that yet?
Comment 19 YeHaa 2011-01-06 13:39:36 UTC
For what it's worth: I'm experiencing this error with my gmail-account.

If there's something I can do to verify/diagnose this problem apart from posting my console-output, I'd be happy to help.

Qt: 4.7.0
KDE: 4.5.90 (4.6 RC1)
Kopete: 1.0.80
Kubuntu 10.04

Symptom:
- Goggle-Talk Account offline

Sample console-output:
~$ kopete
kopete(7510)/kio (KDirWatch) KDirWatchPrivate::removeEntry: doesn't know "/home/xxx/.kde/share/apps/kabc" 
QInotifyFileSystemWatcherEngine::addPaths: inotify_add_watch failed: Datei oder Verzeichnis nicht gefunden
QFileSystemWatcher: failed to add paths: /home/xxx/.config/ibus/bus
Bus::open: Can not get ibus-daemon's address. 
IBusInputContext::createInputContext: no connection to ibus-daemon 
kopete(7510)/kdecore (KLibrary) kde4Factory: The library "/usr/lib/kde4/kopete_history.so" does not offer a qt_plugin_instance function.
kopete(7510)/libkopete Kopete::PluginManager::loadPluginInternal: Unable to find a plugin named ' "" '! 
kopete(7510)/libkopete Kopete::PluginManager::loadPluginInternal: Unable to find a plugin named ' "" '! 
kopete(7510)/libkopete Kopete::PluginManager::loadPluginInternal: Unable to find a plugin named ' "" '! 
Unknown signature value:  795 
Unknown signature value:  795 
Unknown signature value:  795 
Unknown signature value:  795 
Unknown signature value:  795 
Unknown signature value:  795 
Unknown signature value:  795 
Unknown signature value:  795 
Unknown signature value:  795 
Unknown signature value:  795 
Unknown signature value:  795 
Unknown signature value:  795
Comment 20 Ed Cates 2011-01-06 16:24:15 UTC
I have been having this issue with Kopete and our Openfire server for most of this year, on various distributions.  I finally got sick of Pidgin, and started looking into it.

For those of you who control, or can influence, their Openfire configurations, under Server Settings -> Security Settings, set "Client Connection Security" as follows:
*Custom
  Old SSL method:  *Available
  TLS method:  *Required

That fixed my connectivity issues with Kopete (running KDE-unstable on FC14 right now, and kde 4.6 betas on Ubuntu 10.10).
Comment 21 Marc Schoechlin 2011-01-29 17:31:08 UTC
This problem now remains for many months :-) On
Comment 22 Apoorv Parle 2011-02-01 20:32:44 UTC
I'm also unable to connect to GTalk using Kopete on port 443. But this happens only when I'm behind a proxy. If I'm not behind a proxy and port 5223 is open kopete connects to gtalk fine.

The patch in 16th comment https://bugs.kde.org/show_bug.cgi?id=221533#c16
is not useful. I am facing same problem even after applying the patch as well.
Comment 23 ufa 2011-09-14 15:36:21 UTC
It bugs me too, and affects PSI. Maybe something related to some QT library :(
Comment 24 Alex 2011-11-02 22:36:19 UTC
I've problems too, to connect to openfire server, that keeps me from switching from pidgin.
Comment 25 jmeidal 2011-12-06 17:04:40 UTC
I'm also having this issue with OpenSUSE 12.1 and Kopete connecting to an OpenFire XMPP private server.

My XML Console gives me something like:
<?xml version="1.0"?>

<stream:stream xmlns:stream="http://etherx.jabber.org/streams" xmlns="jabber:client" to="domain.com">

<?xml version='1.0' encoding='UTF-8'?><stream:stream xmlns:stream="http://etherx.jabber.org/streams" xmlns="jabber:client" from="dc2" id="17a600f4" xml:lang="en">

<iq type="get" to="domain.org" id="auth_1">
<query xmlns="jabber:iq:auth">
<username>user</username>
</query>
</iq>

<iq from="domain.com" type="error" id="auth_1" to="dc2/17a600f4">
<query xmlns="jabber:iq:auth">
<username>user</username>
</query>
<error type="modify" code="400">
<bad-request xmlns="urn:ietf:params:xml:ns:xmpp-stanzas"/>
</error>
</iq>
Comment 26 Alex 2013-01-25 14:38:52 UTC
I still have the problem of being unable to connect to openfire jabber server, is there any workaround for this?

Some help would be really, really appreciated...
Comment 27 Daniel Shafer 2014-12-14 09:12:23 UTC
Still over a year later and this problem has not been looked at or anything.
Comment 28 Daniel Shafer 2015-08-26 18:20:27 UTC
I would like to mentioned that this appears to be fixed in Telepathy 15.08

I am again able to connect to my OpenFire Server.
Comment 29 Justin Zobel 2021-03-09 22:41:17 UTC
Thank you for the bug report.

As this report hasn't seen any changes in 5 years or more, we ask if you can please confirm that the issue still persists.

If this bug is no longer persisting or relevant please change the status to resolved.
Comment 30 Jaroslav Tulach 2021-03-10 17:48:59 UTC
I am not using Jabber neither Kopete anymore.