Bug 221331 - konqueror crashed when printing
Summary: konqueror crashed when printing
Status: RESOLVED DUPLICATE of bug 264985
Alias: None
Product: konqueror
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-01-05 04:49 UTC by Vladimir Dergachev
Modified: 2011-02-06 17:06 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vladimir Dergachev 2010-01-05 04:49:28 UTC
Application that crashed: konqueror
Version of the application: 4.3.2 (KDE 4.3.2)
KDE Version: 4.3.2 (KDE 4.3.2)
Qt Version: 4.5.2
Operating System: Linux 2.6.31-16-generic x86_64
Distribution: Ubuntu 9.10

What I was doing when the application crashed:
konqueror crashed after I started printing a "printer-friendly" window open by javascript from another page.

 -- Backtrace:
Application: Konqueror (kdeinit4), signal: Segmentation fault
The current source language is "auto; currently c".
[Current thread is 1 (Thread 0x7f6311d7b750 (LWP 31042))]

Thread 4 (Thread 0x7f62f7a84910 (LWP 31365)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:261
#1  0x00007f63117f74fb in QWaitConditionPrivate::wait (this=<value optimized out>, mutex=0x4069ef0, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:87
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0x4069ef0, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:159
#3  0x00007f630fd4343e in QFileInfoGatherer::run (this=<value optimized out>) at dialogs/qfileinfogatherer.cpp:207
#4  0x00007f63117f6445 in QThreadPrivate::start (arg=0x4069ee0) at thread/qthread_unix.cpp:188
#5  0x00007f630e56ca04 in start_thread (arg=<value optimized out>) at pthread_create.c:300
#6  0x00007f630f14c7bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#7  0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7f62f8b85910 (LWP 31366)):
#0  0x00007f630f140373 in *__GI___poll (fds=<value optimized out>, nfds=<value optimized out>, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f630e7c137c in g_main_context_poll (context=0x306aa30, block=<value optimized out>, dispatch=<value optimized out>, self=<value optimized out>)
    at /build/buildd/glib2.0-2.22.3/glib/gmain.c:2904
#2  g_main_context_iterate (context=0x306aa30, block=<value optimized out>, dispatch=<value optimized out>, self=<value optimized out>) at /build/buildd/glib2.0-2.22.3/glib/gmain.c:2586
#3  0x00007f630e7c16c0 in IA__g_main_context_iteration (context=0x306aa30, may_block=1) at /build/buildd/glib2.0-2.22.3/glib/gmain.c:2654
#4  0x00007f63119051fe in QEventDispatcherGlib::processEvents (this=0x51062a0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:329
#5  0x00007f63118db532 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#6  0x00007f63118db904 in QEventLoop::exec (this=0x7f62f8b85010, flags=) at kernel/qeventloop.cpp:201
#7  0x00007f63117f36cb in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:487
#8  0x00007f63118beb78 in QInotifyFileSystemWatcherEngine::run (this=0x354cda0) at io/qfilesystemwatcher_inotify.cpp:214
#9  0x00007f63117f6445 in QThreadPrivate::start (arg=0x354cda0) at thread/qthread_unix.cpp:188
#10 0x00007f630e56ca04 in start_thread (arg=<value optimized out>) at pthread_create.c:300
#11 0x00007f630f14c7bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#12 0x0000000000000000 in ?? ()
The current source language is "auto; currently asm".

Thread 2 (Thread 0x7f62f2fec910 (LWP 31367)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:261
#1  0x00007f63117f74fb in QWaitConditionPrivate::wait (this=<value optimized out>, mutex=0x40688a8, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:87
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0x40688a8, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:159
#3  0x00007f630dc2e78c in QHostInfoAgent::run (this=0x4068890) at kernel/qhostinfo.cpp:260
#4  0x00007f63117f6445 in QThreadPrivate::start (arg=0x4068890) at thread/qthread_unix.cpp:188
#5  0x00007f630e56ca04 in start_thread (arg=<value optimized out>) at pthread_create.c:300
#6  0x00007f630f14c7bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#7  0x0000000000000000 in ?? ()
The current source language is "auto; currently c".

Thread 1 (Thread 0x7f6311d7b750 (LWP 31042)):
[KCrash Handler]
#5  0x00007f62fde08cb6 in khtml::RenderBlock::clearChildOfPageBreaks (this=0x3732c10, child=0x3732e08, pageBreakInfo=..., marginInfo=<value optimized out>)
    at ../../khtml/rendering/render_block.cpp:1667
#6  0x00007f62fde0945b in khtml::RenderBlock::layoutBlockChildren (this=0x3732c10, relayoutChildren=<value optimized out>) at ../../khtml/rendering/render_block.cpp:1604
#7  0x00007f62fde097fd in khtml::RenderBlock::layoutBlock (this=0x3732c10, relayoutChildren=true) at ../../khtml/rendering/render_block.cpp:835
#8  0x00007f62fde62d62 in khtml::RenderCanvas::layout (this=0x3732c10) at ../../khtml/rendering/render_canvas.cpp:187
#9  0x00007f62fdcdd8e4 in khtml::RenderObject::layoutIfNeeded (this=<value optimized out>, quick=<value optimized out>) at ../../khtml/rendering/render_object.h:477
#10 KHTMLView::print (this=<value optimized out>, quick=<value optimized out>) at ../../khtml/khtmlview.cpp:3254
#11 0x00007f62fdd3581c in KHTMLPartBrowserExtension::qt_metacall (this=0x3230860, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffcf0a2fc0) at ./khtml_ext.moc:97
#12 0x00007f63118f1ddc in QMetaObject::activate (sender=0x272ec80, from_signal_index=<value optimized out>, to_signal_index=<value optimized out>, argv=0x5ed) at kernel/qobject.cpp:3113
#13 0x00007f630f8870a7 in QAction::triggered (this=0x0, _t1=false) at .moc/release-shared/moc_qaction.cpp:236
#14 0x00007f630f8884ef in QAction::activate (this=0x272ec80, event=<value optimized out>) at kernel/qaction.cpp:1160
#15 0x00007f630fc74ecd in QMenuPrivate::activateCausedStack (this=<value optimized out>, causedStack=..., action=0x272ec80, action_e=QAction::Trigger, self=true) at widgets/qmenu.cpp:967
#16 0x00007f630fc7adea in QMenuPrivate::activateAction (this=0x2bd16e0, action=0x272ec80, action_e=QAction::Trigger, self=<value optimized out>) at widgets/qmenu.cpp:1060
#17 0x00007f63105962be in KMenu::mouseReleaseEvent (this=0x2ba8600, e=0x3732c10) at ../../kdeui/widgets/kmenu.cpp:456
#18 0x00007f630f8db9c0 in QWidget::event (this=0x2ba8600, event=0x7fffcf0a39e0) at kernel/qwidget.cpp:7549
#19 0x00007f630fc7d5ab in QMenu::event (this=0x2ba8600, e=0x7fffcf0a39e0) at widgets/qmenu.cpp:2353
#20 0x00007f630f88cefc in QApplicationPrivate::notify_helper (this=0x2453be0, receiver=0x2ba8600, e=0x7fffcf0a39e0) at kernel/qapplication.cpp:4056
#21 0x00007f630f894011 in QApplication::notify (this=<value optimized out>, receiver=0x2ba8600, e=0x7fffcf0a39e0) at kernel/qapplication.cpp:3758
#22 0x00007f63104c3ab6 in KApplication::notify (this=0x7fffcf0a5a40, receiver=0x2ba8600, event=0x7fffcf0a39e0) at ../../kdeui/kernel/kapplication.cpp:302
#23 0x00007f63118dcc2c in QCoreApplication::notifyInternal (this=0x7fffcf0a5a40, receiver=0x2ba8600, event=0x7fffcf0a39e0) at kernel/qcoreapplication.cpp:610
#24 0x00007f630f8938e0 in QCoreApplication::sendSpontaneousEvent (receiver=0x2ba8600, event=0x7fffcf0a39e0, alienWidget=0x0, nativeWidget=0x2ba8600, buttonDown=<value optimized out>, 
    lastMouseReceiver=<value optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:216
#25 QApplicationPrivate::sendMouseEvent (receiver=0x2ba8600, event=0x7fffcf0a39e0, alienWidget=0x0, nativeWidget=0x2ba8600, buttonDown=<value optimized out>, lastMouseReceiver=<value optimized out>)
    at kernel/qapplication.cpp:2924
#26 0x00007f630f8f9e2e in QETWidget::translateMouseEvent (this=0x2ba8600, event=<value optimized out>) at kernel/qapplication_x11.cpp:4343
#27 0x00007f630f8f8aa9 in QApplication::x11ProcessEvent (this=<value optimized out>, event=0x7fffcf0a5510) at kernel/qapplication_x11.cpp:3550
#28 0x00007f630f921d0c in x11EventSourceDispatch (s=<value optimized out>, callback=<value optimized out>, user_data=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:146
#29 0x00007f630e7bdbce in g_main_dispatch (context=0x2456520) at /build/buildd/glib2.0-2.22.3/glib/gmain.c:1960
#30 IA__g_main_context_dispatch (context=0x2456520) at /build/buildd/glib2.0-2.22.3/glib/gmain.c:2513
#31 0x00007f630e7c1598 in g_main_context_iterate (context=0x2456520, block=<value optimized out>, dispatch=<value optimized out>, self=<value optimized out>)
    at /build/buildd/glib2.0-2.22.3/glib/gmain.c:2591
#32 0x00007f630e7c16c0 in IA__g_main_context_iteration (context=0x2456520, may_block=1) at /build/buildd/glib2.0-2.22.3/glib/gmain.c:2654
#33 0x00007f63119051a6 in QEventDispatcherGlib::processEvents (this=0x23bd040, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:327
#34 0x00007f630f9214be in QGuiEventDispatcherGlib::processEvents (this=0x0, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:202
#35 0x00007f63118db532 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#36 0x00007f63118db904 in QEventLoop::exec (this=0x7fffcf0a5840, flags=) at kernel/qeventloop.cpp:201
#37 0x00007f63118ddab9 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#38 0x00007f63094a3e26 in kdemain (argc=<value optimized out>, argv=<value optimized out>) at ../../../../apps/konqueror/src/konqmain.cpp:271
#39 0x0000000000406da8 in launch (argc=2, _name=<value optimized out>, args=<value optimized out>, cwd=<value optimized out>, envc=16, envs=<value optimized out>, reset_env=false, tty=0x0, 
    avoid_loops=false, startup_id_str=0x240e0e4 "expedition;1262662364;210468;29147_TIME153431539") at ../../kinit/kinit.cpp:677
#40 0x0000000000407aa0 in handle_launcher_request (sock=7, who=<value optimized out>) at ../../kinit/kinit.cpp:1169
#41 0x0000000000407f51 in handle_requests (waitForPid=0) at ../../kinit/kinit.cpp:1362
#42 0x0000000000408bb2 in main (argc=2, argv=<value optimized out>, envp=<value optimized out>) at ../../kinit/kinit.cpp:1793
The current source language is "auto; currently asm".
The current source language is "auto; currently c".

This bug may be a duplicate of or related to bug 188152

Reported using DrKonqi
Comment 1 Maksim Orlovich 2011-02-06 17:06:36 UTC

*** This bug has been marked as a duplicate of bug 264985 ***