Bug 188152 - crashes when using printer friendly dialogue
Summary: crashes when using printer friendly dialogue
Status: RESOLVED WORKSFORME
Alias: None
Product: konqueror
Classification: Applications
Component: general (show other bugs)
Version: 4.2.1
Platform: openSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-03-26 11:34 UTC by Gerry Gavigan
Modified: 2009-06-16 12:38 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gerry Gavigan 2009-03-26 11:34:15 UTC
Version:            (using KDE 4.2.1)
OS:                Linux
Installed from:    SuSE RPMs

using latest OpenSUSE RPMs

This web page has a print option which produces a "printer friendly" 

http://www.timesonline.co.uk/tol/life_and_style/education/article5941532.ece

Attempting to print that page crashes Konqueror (reproducible)



Although apparently useless, this is the crash report I got

[Thread debugging using libthread_db enabled]
[New Thread 0x9eb89b90 (LWP 6112)]
[New Thread 0xb1bf8b90 (LWP 6111)]
[New Thread 0x9fac5b90 (LWP 6094)]
0xffffe430 in __kernel_vsyscall ()
[Current thread is 1 (Thread 0xb5e72700 (LWP 6076))]

Thread 4 (Thread 0x9fac5b90 (LWP 6094)):
#0  0xffffe430 in __kernel_vsyscall ()
#1  0xb6537411 in select () from /lib/libc.so.6
#2  0xb72b2dc7 in ?? () from /usr/lib/libQtCore.so.4
#3  0xb71e385e in ?? () from /usr/lib/libQtCore.so.4
#4  0xb71811b5 in start_thread () from /lib/libpthread.so.0
#5  0xb653e3be in clone () from /lib/libc.so.6

Thread 3 (Thread 0xb1bf8b90 (LWP 6111)):
#0  0xffffe430 in __kernel_vsyscall ()
#1  0xb7184c35 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0xb71e4872 in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib/libQtCore.so.4
#3  0xb6e5401a in ?? () from /usr/lib/libQtGui.so.4
#4  0xb71e385e in ?? () from /usr/lib/libQtCore.so.4
#5  0xb71811b5 in start_thread () from /lib/libpthread.so.0
#6  0xb653e3be in clone () from /lib/libc.so.6

Thread 2 (Thread 0x9eb89b90 (LWP 6112)):
#0  0xb6265223 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#1  0xb72fdfd7 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#2  0xb72d201a in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#3  0xb72d21da in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#4  0xb71e0559 in QThread::exec() () from /usr/lib/libQtCore.so.4
#5  0xb72b637b in ?? () from /usr/lib/libQtCore.so.4
#6  0xb71e385e in ?? () from /usr/lib/libQtCore.so.4
#7  0xb71811b5 in start_thread () from /lib/libpthread.so.0
#8  0xb653e3be in clone () from /lib/libc.so.6

Thread 1 (Thread 0xb5e72700 (LWP 6076)):
#0  0xffffe430 in __kernel_vsyscall ()
#1  0xb6506e96 in nanosleep () from /lib/libc.so.6
#2  0xb6506c7e in sleep () from /lib/libc.so.6
#3  0xb78e0bfa in ?? () from /usr/lib/libkdeui.so.5
#4  0xb78e162c in KCrash::defaultCrashHandler(int) () from /usr/lib/libkdeui.so.5
#5  <signal handler called>
#6  0xb3dbf3a4 in ?? () from /usr/lib/libkhtml.so.5
#7  0xb3dc0955 in ?? () from /usr/lib/libkhtml.so.5
#8  0xb3dc0e9f in ?? () from /usr/lib/libkhtml.so.5
#9  0xb3e1c5c8 in ?? () from /usr/lib/libkhtml.so.5
#10 0xb3c7f465 in KHTMLView::print(bool) () from /usr/lib/libkhtml.so.5
#11 0xb3eff76b in ?? () from /usr/lib/libkhtml.so.5
#12 0xb3b4613d in KJS::JSObject::call(KJS::ExecState*, KJS::JSObject*, KJS::List const&) () from /usr/lib/libkjs.so.4
#13 0xb3b632bb in ?? () from /usr/lib/libkjs.so.4
#14 0xb3b42373 in KJS::FunctionImp::callAsFunction(KJS::ExecState*, KJS::JSObject*, KJS::List const&) () from /usr/lib/libkjs.so.4
#15 0xb3b4613d in KJS::JSObject::call(KJS::ExecState*, KJS::JSObject*, KJS::List const&) () from /usr/lib/libkjs.so.4
#16 0xb3f1de4d in ?? () from /usr/lib/libkhtml.so.5
#17 0xb3d17ab3 in ?? () from /usr/lib/libkhtml.so.5
#18 0xb3d17f9c in ?? () from /usr/lib/libkhtml.so.5
#19 0xb3d18046 in ?? () from /usr/lib/libkhtml.so.5
#20 0xb3c7c81d in KHTMLView::dispatchMouseEvent(int, DOM::NodeImpl*, DOM::NodeImpl*, bool, int, QMouseEvent*, bool, int, int) () from /usr/lib/libkhtml.so.5
#21 0xb3c89046 in KHTMLView::mouseReleaseEvent(QMouseEvent*) () from /usr/lib/libkhtml.so.5
#22 0xb6a04a72 in QWidget::event(QEvent*) () from /usr/lib/libQtGui.so.4
#23 0xb6d3ab03 in QFrame::event(QEvent*) () from /usr/lib/libQtGui.so.4
#24 0xb3c8725f in KHTMLView::widgetEvent(QEvent*) () from /usr/lib/libkhtml.so.5
#25 0xb3c874cd in KHTMLView::eventFilter(QObject*, QEvent*) () from /usr/lib/libkhtml.so.5
#26 0xb72d2b3a in QCoreApplicationPrivate::sendThroughObjectEventFilters(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#27 0xb69ac8da in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#28 0xb69b5111 in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#29 0xb7874a3d in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#30 0xb72d3961 in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#31 0xb69b439e in QApplicationPrivate::sendMouseEvent(QWidget*, QMouseEvent*, QWidget*, QWidget*, QWidget**, QPointer<QWidget>&) () from /usr/lib/libQtGui.so.4
#32 0xb6a1e756 in ?? () from /usr/lib/libQtGui.so.4
#33 0xb6a1db05 in QApplication::x11ProcessEvent(_XEvent*) () from /usr/lib/libQtGui.so.4
#34 0xb6a460ca in ?? () from /usr/lib/libQtGui.so.4
#35 0xb62619a8 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#36 0xb6265063 in ?? () from /usr/lib/libglib-2.0.so.0
#37 0xb6265221 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#38 0xb72fdfb8 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#39 0xb6a457c5 in ?? () from /usr/lib/libQtGui.so.4
#40 0xb72d201a in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#41 0xb72d21da in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#42 0xb72d4895 in QCoreApplication::exec() () from /usr/lib/libQtCore.so.4
#43 0xb69ac777 in QApplication::exec() () from /usr/lib/libQtGui.so.4
#44 0xb7f9cadf in kdemain () from /usr/lib/libkdeinit4_konqueror.so
#45 0x08048772 in _start ()
Comment 1 Gerry Gavigan 2009-03-26 11:41:35 UTC
Trying same in Firefox I see the "to be printed" page was waiting to connect to js.forrestersurveys.com, and killing that page brought up the printer dialogue
Comment 2 Dario Andres 2009-03-26 13:03:49 UTC
Here using:

Qt: 4.5.0 + qt-copy-patches-936035
KDE: 4.2.67 (KDE 4.2.67 (KDE 4.3 >= 20090318))
kdelibs svn rev. 944348 / kdebase svn rev. 944348
on ArchLinux i686 - Kernel 2.6.28.7

I can't reproduce the crash. I could succesfully print to a PDF file (I have no printers installed)
Comment 3 Gerry Gavigan 2009-03-26 17:42:34 UTC
Printing to a pdf caused the crash too so it seems that a later version of KDE cures it.

I'll take your lead on closing the bug.
Comment 4 Dario Andres 2009-04-01 22:47:25 UTC
Please, can you install the "kdelibs5-debuginfo" package and paste here a new backtrace ? Thanks
Comment 5 Gerry Gavigan 2009-04-02 14:03:39 UTC
I installed kdelibs4-debuginfo (I don't have access to "kdelibs5-debuginfo" but suspect that's a finger slip)

Do I have to enable anything? 

I tried again, but got the "backtrace appears to be of no use" but here it is anyway

This backtrace appears to be of no use.
This is probably because your packages are built in a way which prevents creation of proper backtraces, or the stack frame was seriously corrupted in the crash.

[?1034h(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread 0xb0c4ab90 (LWP 6853)]
[New Thread 0xb0449b90 (LWP 6852)]
[New Thread 0xafc48b90 (LWP 6838)]
[New Thread 0xb1b30b90 (LWP 6813)]
0xffffe430 in __kernel_vsyscall ()
[Current thread is 1 (Thread 0xb5da5700 (LWP 6729))]

Thread 5 (Thread 0xb1b30b90 (LWP 6813)):
#0  0xffffe430 in __kernel_vsyscall ()
#1  0xb64676a7 in poll () from /lib/libc.so.6
#2  0xb6031640 in ?? () from /lib/libresolv.so.2
#3  0xb602fa73 in __libc_res_nquery () from /lib/libresolv.so.2
#4  0xb603007b in ?? () from /lib/libresolv.so.2
#5  0xb6030275 in __libc_res_nsearch () from /lib/libresolv.so.2
#6  0xb0fa5c9e in _nss_dns_gethostbyname3_r () from /lib/libnss_dns.so.2
#7  0xb0fa5f9b in _nss_dns_gethostbyname2_r () from /lib/libnss_dns.so.2
#8  0xb64583da in ?? () from /lib/libc.so.6
#9  0xb645a40f in getaddrinfo () from /lib/libc.so.6
#10 0xb7a4ca2f in ?? () from /usr/lib/libQtNetwork.so.4
#11 0xb7a445ba in QHostInfo::fromName(QString const&) () from /usr/lib/libQtNetwork.so.4
#12 0xb7c489fd in ?? () from /usr/lib/libkio.so.5
#13 0xb7c49911 in ?? () from /usr/lib/libkio.so.5
#14 0xb710c924 in ?? () from /usr/lib/libQtCore.so.4
#15 0xb711685e in ?? () from /usr/lib/libQtCore.so.4
#16 0xb70b41b5 in start_thread () from /lib/libpthread.so.0
#17 0xb64713be in clone () from /lib/libc.so.6

Thread 4 (Thread 0xafc48b90 (LWP 6838)):
#0  0xffffe430 in __kernel_vsyscall ()
#1  0xb646a411 in select () from /lib/libc.so.6
#2  0xb71e5dc7 in ?? () from /usr/lib/libQtCore.so.4
#3  0xb711685e in ?? () from /usr/lib/libQtCore.so.4
#4  0xb70b41b5 in start_thread () from /lib/libpthread.so.0
#5  0xb64713be in clone () from /lib/libc.so.6

Thread 3 (Thread 0xb0449b90 (LWP 6852)):
#0  0xffffe430 in __kernel_vsyscall ()
#1  0xb70b7c35 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0xb7117872 in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib/libQtCore.so.4
#3  0xb6d8701a in ?? () from /usr/lib/libQtGui.so.4
#4  0xb711685e in ?? () from /usr/lib/libQtCore.so.4
#5  0xb70b41b5 in start_thread () from /lib/libpthread.so.0
#6  0xb64713be in clone () from /lib/libc.so.6

Thread 2 (Thread 0xb0c4ab90 (LWP 6853)):
#0  0xffffe430 in __kernel_vsyscall ()
#1  0xb64676a7 in poll () from /lib/libc.so.6
#2  0xb6197ef2 in ?? () from /usr/lib/libglib-2.0.so.0
#3  0xb6198221 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#4  0xb7230fd7 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#5  0xb720501a in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#6  0xb72051da in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#7  0xb7113559 in QThread::exec() () from /usr/lib/libQtCore.so.4
#8  0xb71e937b in ?? () from /usr/lib/libQtCore.so.4
#9  0xb711685e in ?? () from /usr/lib/libQtCore.so.4
#10 0xb70b41b5 in start_thread () from /lib/libpthread.so.0
#11 0xb64713be in clone () from /lib/libc.so.6

Thread 1 (Thread 0xb5da5700 (LWP 6729)):
#0  0xffffe430 in __kernel_vsyscall ()
#1  0xb6439e96 in nanosleep () from /lib/libc.so.6
#2  0xb6439c7e in sleep () from /lib/libc.so.6
#3  0xb7813bfa in ?? () from /usr/lib/libkdeui.so.5
#4  0xb781462c in KCrash::defaultCrashHandler(int) () from /usr/lib/libkdeui.so.5
#5  <signal handler called>
#6  0xb3cf73a4 in ?? () from /usr/lib/libkhtml.so.5
#7  0xb3cf8955 in ?? () from /usr/lib/libkhtml.so.5
#8  0xb3cf8e9f in ?? () from /usr/lib/libkhtml.so.5
#9  0xb3d545c8 in ?? () from /usr/lib/libkhtml.so.5
#10 0xb3bb7465 in KHTMLView::print(bool) () from /usr/lib/libkhtml.so.5
#11 0xb3e3776b in ?? () from /usr/lib/libkhtml.so.5
#12 0xb3a7e13d in KJS::JSObject::call (this=0x8d063f0, exec=0xbfa3b46c, thisObj=0xb12e0100, args=@0xbfa3b3f4) at /usr/src/debug/kdelibs-4.2.1/kjs/object.cpp:69
#13 0xb3a9b2bb in KJS::Machine::runBlock (exec=0xbfa3b46c, codeBlock=@0x8d063f0, parentExec=0x8d18290) at codes.def:1192
#14 0xb3a7a373 in KJS::FunctionImp::callAsFunction (this=0xb10f6080, exec=0x8d18290, thisObj=0xb10f6040, args=@0xbfa3b5b8) at /usr/src/debug/kdelibs-4.2.1/kjs/function.cpp:144
#15 0xb3a7e13d in KJS::JSObject::call (this=0x8d063f0, exec=0x8d18290, thisObj=0xb10f6040, args=@0xbfa3b5b8) at /usr/src/debug/kdelibs-4.2.1/kjs/object.cpp:69
#16 0xb3e55e4d in ?? () from /usr/lib/libkhtml.so.5
#17 0xb3c4fab3 in ?? () from /usr/lib/libkhtml.so.5
#18 0xb3c4ff9c in ?? () from /usr/lib/libkhtml.so.5
#19 0xb3c50046 in ?? () from /usr/lib/libkhtml.so.5
#20 0xb3bb481d in KHTMLView::dispatchMouseEvent(int, DOM::NodeImpl*, DOM::NodeImpl*, bool, int, QMouseEvent*, bool, int, int) () from /usr/lib/libkhtml.so.5
#21 0xb3bc1046 in KHTMLView::mouseReleaseEvent(QMouseEvent*) () from /usr/lib/libkhtml.so.5
#22 0xb6937a72 in QWidget::event(QEvent*) () from /usr/lib/libQtGui.so.4
#23 0xb6c6db03 in QFrame::event(QEvent*) () from /usr/lib/libQtGui.so.4
#24 0xb3bbf25f in KHTMLView::widgetEvent(QEvent*) () from /usr/lib/libkhtml.so.5
#25 0xb3bbf4cd in KHTMLView::eventFilter(QObject*, QEvent*) () from /usr/lib/libkhtml.so.5
#26 0xb7205b3a in QCoreApplicationPrivate::sendThroughObjectEventFilters(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#27 0xb68df8da in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#28 0xb68e8111 in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#29 0xb77a7a3d in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#30 0xb7206961 in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#31 0xb68e739e in QApplicationPrivate::sendMouseEvent(QWidget*, QMouseEvent*, QWidget*, QWidget*, QWidget**, QPointer<QWidget>&) () from /usr/lib/libQtGui.so.4
#32 0xb6951756 in ?? () from /usr/lib/libQtGui.so.4
#33 0xb6950b05 in QApplication::x11ProcessEvent(_XEvent*) () from /usr/lib/libQtGui.so.4
#34 0xb69790ca in ?? () from /usr/lib/libQtGui.so.4
#35 0xb61949a8 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#36 0xb6198063 in ?? () from /usr/lib/libglib-2.0.so.0
#37 0xb6198221 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#38 0xb7230fb8 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#39 0xb69787c5 in ?? () from /usr/lib/libQtGui.so.4
#40 0xb720501a in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#41 0xb72051da in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#42 0xb7207895 in QCoreApplication::exec() () from /usr/lib/libQtCore.so.4
#43 0xb68df777 in QApplication::exec() () from /usr/lib/libQtGui.so.4
#44 0xb7ecfadf in kdemain () from /usr/lib/libkdeinit4_konqueror.so
#45 0x08048772 in _start ()
Comment 6 Dario Andres 2009-04-02 14:27:40 UTC
Mh, you are right, it seems that the SuSe package is called "kdelibs4-debuginfo" (each distro uses its own naming scheme, I get confused from time to time )

You got debug information for some other KDE functions from KDELIBs but not from KHTML (where the application is crashed)
Comment 7 Gerry Gavigan 2009-04-02 15:50:48 UTC
tried kdebase4-debuginfo but that's not use either. Couldn't find a khtml-debuginfo
Comment 8 Gerry Gavigan 2009-04-03 02:01:00 UTC
still present in 4.2.2
Comment 9 Gerry Gavigan 2009-04-12 13:53:46 UTC
I now seems to have a useful backtrace (kdelibs4-debuginfo installed)

Application: Konqueror (konqueror), signal SIGSEGV
[Current thread is 1 (Thread 0xb5d68700 (LWP 6278))]

Thread 5 (Thread 0xb1adab90 (LWP 6293)):
#0  0xffffe430 in __kernel_vsyscall ()
#1  0xb707af62 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0xb70da84c in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib/libQtCore.so.4
#3  0xb70cf9c6 in ?? () from /usr/lib/libQtCore.so.4
#4  0xb70d985e in ?? () from /usr/lib/libQtCore.so.4
#5  0xb70771b5 in start_thread () from /lib/libpthread.so.0
#6  0xb64343be in clone () from /lib/libc.so.6

Thread 4 (Thread 0xb1268b90 (LWP 6294)):
#0  0xffffe430 in __kernel_vsyscall ()
#1  0xb642d411 in select () from /lib/libc.so.6
#2  0xb71a8dc7 in ?? () from /usr/lib/libQtCore.so.4
#3  0xb70d985e in ?? () from /usr/lib/libQtCore.so.4
#4  0xb70771b5 in start_thread () from /lib/libpthread.so.0
#5  0xb64343be in clone () from /lib/libc.so.6

Thread 3 (Thread 0xaf729b90 (LWP 6327)):
#0  0xffffe430 in __kernel_vsyscall ()
#1  0xb707ac35 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0xb70da872 in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib/libQtCore.so.4
#3  0xb6d4a01a in ?? () from /usr/lib/libQtGui.so.4
#4  0xb70d985e in ?? () from /usr/lib/libQtCore.so.4
#5  0xb70771b5 in start_thread () from /lib/libpthread.so.0
#6  0xb64343be in clone () from /lib/libc.so.6

Thread 2 (Thread 0xaef28b90 (LWP 6328)):
#0  0xb707a0a1 in pthread_mutex_unlock () from /lib/libpthread.so.0
#1  0xb6157846 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#2  0xb615b063 in ?? () from /usr/lib/libglib-2.0.so.0
#3  0xb615b221 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#4  0xb71f3fd7 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#5  0xb71c801a in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#6  0xb71c81da in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#7  0xb70d6559 in QThread::exec() () from /usr/lib/libQtCore.so.4
#8  0xb71ac37b in ?? () from /usr/lib/libQtCore.so.4
#9  0xb70d985e in ?? () from /usr/lib/libQtCore.so.4
#10 0xb70771b5 in start_thread () from /lib/libpthread.so.0
#11 0xb64343be in clone () from /lib/libc.so.6

Thread 1 (Thread 0xb5d68700 (LWP 6278)):
[KCrash Handler]
#6  khtml::RenderBlock::clearChildOfPageBreaks (this=0xa8bae40, child=0xa8baf84, pageBreakInfo=@0xbfb007a0, marginInfo=@0xbfb00794)
    at /usr/src/debug/kdelibs-4.2.2/khtml/rendering/render_block.cpp:1656
#7  0xb3ccbca5 in khtml::RenderBlock::layoutBlockChildren (this=0xa8bae40, relayoutChildren=true) at /usr/src/debug/kdelibs-4.2.2/khtml/rendering/render_block.cpp:1593
#8  0xb3ccc1ef in khtml::RenderBlock::layoutBlock (this=0xa8bae40, relayoutChildren=true) at /usr/src/debug/kdelibs-4.2.2/khtml/rendering/render_block.cpp:835
#9  0xb3d28088 in khtml::RenderCanvas::layout (this=0xa8bae40) at /usr/src/debug/kdelibs-4.2.2/khtml/rendering/render_canvas.cpp:193
#10 0xb3b90b15 in KHTMLView::print (this=0xbb48b18, quick=false) at /usr/src/debug/kdelibs-4.2.2/khtml/rendering/render_object.h:477
#11 0xb3e0bf1d in KJS::WindowFunc::callAsFunction (this=0xafcb44a0, exec=0xbfb0144c, thisObj=0xb1290640, args=@0xbfb013d4) at /usr/src/debug/kdelibs-4.2.2/khtml/ecma/kjs_window.cpp:2111
#12 0xb3a5363d in KJS::JSObject::call (this=0xa8bae40, exec=0xbfb0144c, thisObj=0xb1290640, args=@0xbfb013d4) at /usr/src/debug/kdelibs-4.2.2/kjs/object.cpp:69
#13 0xb3a707bb in KJS::Machine::runBlock (exec=0xbfb0144c, codeBlock=@0xa8bae40, parentExec=0xa9f4680) at codes.def:1192
#14 0xb3a4f873 in KJS::FunctionImp::callAsFunction (this=0xafcb4500, exec=0xa9f4680, thisObj=0xafd57320, args=@0xbfb01598) at /usr/src/debug/kdelibs-4.2.2/kjs/function.cpp:144
#15 0xb3a5363d in KJS::JSObject::call (this=0xa8bae40, exec=0xa9f4680, thisObj=0xafd57320, args=@0xbfb01598) at /usr/src/debug/kdelibs-4.2.2/kjs/object.cpp:69
#16 0xb3e2a1ed in KJS::JSEventListener::handleEvent (this=0xc6b91f8, evt=@0xbfb015e0) at /usr/src/debug/kdelibs-4.2.2/khtml/ecma/kjs_events.cpp:106
#17 0xb3c244b3 in DOM::NodeImpl::handleLocalEvents (this=0xc6b9148, evt=0xc8428f8, useCapture=false) at /usr/src/debug/kdelibs-4.2.2/khtml/xml/dom_nodeimpl.cpp:727
#18 0xb3c2499c in DOM::NodeImpl::dispatchGenericEvent (this=0xc6b9148, evt=0xc8428f8) at /usr/src/debug/kdelibs-4.2.2/khtml/xml/dom_nodeimpl.cpp:499
#19 0xb3c24a46 in DOM::NodeImpl::dispatchEvent (this=0xc6b9148, evt=0xc8428f8, exceptioncode=@0xbfb01778, tempEvent=true) at /usr/src/debug/kdelibs-4.2.2/khtml/xml/dom_nodeimpl.cpp:451
#20 0xb3b88f8d in KHTMLView::dispatchMouseEvent (this=0xbb48b18, eventId=3, targetNode=0xc6b9148, targetNodeNonShared=0xaf26418, cancelable=<value optimized out>, detail=1, _mouse=0xbfb01824, 
    setUnder=true, mouseEventType=1, orient=0) at /usr/src/debug/kdelibs-4.2.2/khtml/khtmlview.cpp:3752
#21 0xb3b95756 in KHTMLView::mouseReleaseEvent (this=0xbb48b18, _mouse=0xbfb01eb8) at /usr/src/debug/kdelibs-4.2.2/khtml/khtmlview.cpp:1647
#22 0xb68faa72 in QWidget::event(QEvent*) () from /usr/lib/libQtGui.so.4
#23 0xb6c30b03 in QFrame::event(QEvent*) () from /usr/lib/libQtGui.so.4
#24 0xb3b9396f in KHTMLView::widgetEvent (this=0xbb48b18, e=0xbfb01eb8) at /usr/src/debug/kdelibs-4.2.2/khtml/khtmlview.cpp:2396
#25 0xb3b93bdd in KHTMLView::eventFilter (this=0xbb48b18, o=0x91d93e0, e=0xbfb01eb8) at /usr/src/debug/kdelibs-4.2.2/khtml/khtmlview.cpp:2260
#26 0xb71c8b3a in QCoreApplicationPrivate::sendThroughObjectEventFilters(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#27 0xb68a28da in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#28 0xb68ab111 in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#29 0xb776cded in KApplication::notify (this=0xbfb028e0, receiver=0x91d93e0, event=0xbfb01eb8) at /usr/src/debug/kdelibs-4.2.2/kdeui/kernel/kapplication.cpp:307
#30 0xb71c9961 in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#31 0xb68aa39e in QApplicationPrivate::sendMouseEvent(QWidget*, QMouseEvent*, QWidget*, QWidget*, QWidget**, QPointer<QWidget>&) () from /usr/lib/libQtGui.so.4
#32 0xb6914756 in ?? () from /usr/lib/libQtGui.so.4
#33 0xb6913b05 in QApplication::x11ProcessEvent(_XEvent*) () from /usr/lib/libQtGui.so.4
#34 0xb693c0ca in ?? () from /usr/lib/libQtGui.so.4
#35 0xb61579a8 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#36 0xb615b063 in ?? () from /usr/lib/libglib-2.0.so.0
#37 0xb615b221 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#38 0xb71f3fb8 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#39 0xb693b7c5 in ?? () from /usr/lib/libQtGui.so.4
#40 0xb71c801a in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#41 0xb71c81da in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#42 0xb71ca895 in QCoreApplication::exec() () from /usr/lib/libQtCore.so.4
#43 0xb68a2777 in QApplication::exec() () from /usr/lib/libQtGui.so.4
#44 0xb7e969bf in kdemain () from /usr/lib/libkdeinit4_konqueror.so
#45 0x08048772 in _start ()
Comment 10 Dario Andres 2009-04-25 14:14:03 UTC
This looks a lot like bug 163840 which seems to be related.
Thanks for the backtrace.
Comment 11 Gerry Gavigan 2009-06-16 12:38:44 UTC
Cured in later versions