Bug 220507 - Crash (SIGSEGV) in Solid::Control::PowerManager
Summary: Crash (SIGSEGV) in Solid::Control::PowerManager
Status: RESOLVED DUPLICATE of bug 219333
Alias: None
Product: solid
Classification: Frameworks and Libraries
Component: general (show other bugs)
Version: unspecified
Platform: Debian testing Unspecified
: NOR crash (vote)
Target Milestone: ---
Assignee: Kevin Ottens
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-12-29 12:11 UTC by Gunter Ohrner
Modified: 2009-12-29 15:36 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gunter Ohrner 2009-12-29 12:11:28 UTC
Version:            (using KDE 4.3.4)
Installed from:    Debian testing/unstable Packages

Since some time KDE 4.3.4 is basically unusuable as plasma-desktop crashes immediately during login.

This crash is caused by the battery applet which in turn causes a crash in Solid.

This crash may be related to bugs #217425, #217316 and #219095 but does not seem to be identical, as the topmost stack frames differ.


Application: Plasma-ArbeitsflÀche (kdeinit4), signal: Segmentation fault
[KCrash Handler]
#6  0xb75b0417 in QtPrivate::QStringList_contains (that=0xbfce8a38, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#7  0xa8212914 in HalPower::brightness(QString const&) () from /usr/lib/kde4/solid_hal_power.so
#8  0xa8a90d04 in Solid::Control::PowerManager::brightness(QString const&) () from /usr/lib/libsolidcontrol.so.4
#9  0xa8a4887d in ?? () from /usr/lib/kde4/plasma_applet_battery.so
#10 0xb542dfe1 in Plasma::ExtenderPrivate::loadExtenderItems (this=0x9abae70) at ../../plasma/extender.cpp:659
#11 0xb542ee5c in Extender (this=0x9b011d0, applet=0x95af1e8) at ../../plasma/extender.cpp:114
#12 0xb53f0a58 in Plasma::Applet::extender (this=0x95af1e8) at ../../plasma/applet.cpp:688
#13 0xa8a4c361 in ?? () from /usr/lib/kde4/plasma_applet_battery.so
#14 0xb54184af in Plasma::Corona::loadLayout (this=0x9128e88, configName=...) at ../../plasma/corona.cpp:377
#15 0xb5419f21 in Plasma::Corona::initializeLayout (this=0x9128e88, configName=...) at ../../plasma/corona.cpp:324
#16 0xb428cf76 in ?? () from /usr/lib/libkdeinit4_plasma-desktop.so
#17 0xb428d27a in ?? () from /usr/lib/libkdeinit4_plasma-desktop.so
#18 0xb428d4d3 in ?? () from /usr/lib/libkdeinit4_plasma-desktop.so
#19 0xb7664303 in QMetaObject::activate (sender=0x91632e0, from_signal_index=4, to_signal_index=4, argv=0x0) at kernel/qobject.cpp:3112
#20 0xb7664f42 in QMetaObject::activate (sender=0x91632e0, m=0xb773fd88, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3186
#21 0xb766a007 in QSingleShotTimer::timeout (this=0x91632e0) at .moc/release-shared/qtimer.moc:76
#22 0xb766a12c in QSingleShotTimer::timerEvent (this=0x91632e0) at kernel/qtimer.cpp:298
#23 0xb765f39f in QObject::event (this=0x91632e0, e=0xbfce991c) at kernel/qobject.cpp:1074
#24 0xb62eea94 in QApplicationPrivate::notify_helper (this=0x90f0438, receiver=0x91632e0, e=0xbfce991c) at kernel/qapplication.cpp:4065
#25 0xb62f6bee in QApplication::notify (this=0x90ea5e8, receiver=0x91632e0, e=0xbfce991c) at kernel/qapplication.cpp:3605
#26 0xb6d3862d in KApplication::notify (this=0x90ea5e8, receiver=0x91632e0, event=0xbfce991c) at ../../kdeui/kernel/kapplication.cpp:302
#27 0xb764f1eb in QCoreApplication::notifyInternal (this=0x90ea5e8, receiver=0x91632e0, event=0xbfce991c) at kernel/qcoreapplication.cpp:610
#28 0xb767de21 in QCoreApplication::sendEvent (this=0x90f2e44) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:213
#29 QTimerInfoList::activateTimers (this=0x90f2e44) at kernel/qeventdispatcher_unix.cpp:580
#30 0xb767a2e4 in timerSourceDispatch (source=0x90f2e10) at kernel/qeventdispatcher_glib.cpp:184
#31 0xb5ed8b38 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#32 0xb5edc3d0 in ?? () from /lib/libglib-2.0.so.0
#33 0xb5edc503 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#34 0xb767a041 in QEventDispatcherGlib::processEvents (this=0x90f0228, flags=...) at kernel/qeventdispatcher_glib.cpp:407
#35 0xb638e305 in QGuiEventDispatcherGlib::processEvents (this=0x90f0228, flags=...) at kernel/qguieventdispatcher_glib.cpp:202
#36 0xb764d83a in QEventLoop::processEvents (this=0xbfce9b90, flags=...) at kernel/qeventloop.cpp:149
#37 0xb764dc82 in QEventLoop::exec (this=0xbfce9b90, flags=...) at kernel/qeventloop.cpp:201
#38 0xb76500d9 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#39 0xb62ee917 in QApplication::exec () at kernel/qapplication.cpp:3525
#40 0xb42705cd in kdemain () from /usr/lib/libkdeinit4_plasma-desktop.so
#41 0x0804e291 in launch (argc=1, _name=0x90d1f7c "/usr/bin/plasma-desktop", args=0x90d1f94 "", cwd=0x0, envc=0, envs=0x90d1f98 "", reset_env=false, tty=0x0, avoid_loops=false, 
    startup_id_str=0x805105f "0") at ../../kinit/kinit.cpp:677
#42 0x0804ea15 in handle_launcher_request (sock=7, who=<value optimized out>) at ../../kinit/kinit.cpp:1169
#43 0x0804ee5b in handle_requests (waitForPid=0) at ../../kinit/kinit.cpp:1362
#44 0x0804f689 in main (argc=2, argv=0xbfcea404, envp=0xbfcea410) at ../../kinit/kinit.cpp:1793
Comment 1 Jonathan Thomas 2009-12-29 15:03:25 UTC

*** This bug has been marked as a duplicate of bug 217316 ***
Comment 2 Gunter Ohrner 2009-12-29 15:35:55 UTC
Are you sure that bug #217316 really is the same issue?

According to http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=556468 the issue in #217316 should have been fixed in the version of solid installed on my system, and this exact crash is another bug uncovered by the fix of the bug described in #217316.

However, in this case, my bug report looks as if it is a duplicate of bug #219333 (https://bugs.kde.org/show_bug.cgi?id=219333)...
Comment 3 Gunter Ohrner 2009-12-29 15:36:34 UTC

*** This bug has been marked as a duplicate of bug 219333 ***