Bug 217425 - Crash of Plasma during login...
Summary: Crash of Plasma during login...
Status: RESOLVED DUPLICATE of bug 217316
Alias: None
Product: plasma4
Classification: Plasma
Component: widget-battery (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
: 217617 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-12-05 11:36 UTC by Christof Debaes
Modified: 2009-12-06 19:13 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Christof Debaes 2009-12-05 11:36:17 UTC
Application that crashed: plasma-desktop
Version of the application: 0.3
KDE Version: 4.3.4 (KDE 4.3.4)
Qt Version: 4.6.0
Operating System: Linux 2.6.31-gentoo x86_64

What I was doing when the application crashed:
After reinstall to KDE SC 4.3.4 and some other updates KDE became unusable. It crashes everytime I login in. I have already tried on two user accout, with exactly the samen result. Manually starting 'plasma-desktop' gives the following:

cdebaes@haken ~ $ plasma-desktop
QDBusObjectPath: invalid path ""
QLayout: Attempting to add QLayout "" to QWidget "", which already has a layout
QGraphicsLinearLayout::removeAt: invalid index 0
QGraphicsLinearLayout::removeAt: invalid index 0
Object::connect: No such signal SystemTray::Manager::jobStateChanged(SystemTray::Job*)
cdebaes@haken ~ $ KCrash: Application 'plasma-desktop' crashing...
sock_file=/home/cdebaes/.kde4/socket-haken/kdeinit4__0
QDBusObjectPath: invalid path ""
QLayout: Attempting to add QLayout "" to QWidget "", which already has a layout
QGraphicsLinearLayout::removeAt: invalid index 0
QGraphicsLinearLayout::removeAt: invalid index 0
Object::connect: No such signal SystemTray::Manager::jobStateChanged(SystemTray::Job*)

I have no idea what exactly is going. I'm more than willing to probe things more in detail...

 -- Backtrace:
Application: Plasma Workspace (kdeinit4), signal: Segmentation fault
Traceback (most recent call last):
  File "/usr/share/gdb/auto-load/usr/lib64/libgobject-2.0.so.0.2200.2-gdb.py", line 9, in <module>
    from gobject import register
  File "/usr/share/glib-2.0/gdb/gobject.py", line 3, in <module>
    import gdb.backtrace
ImportError: No module named backtrace
[Current thread is 1 (Thread 0x7f6ea11ca760 (LWP 2355))]

Thread 2 (Thread 0x7f6e81afd710 (LWP 2358)):
#0  0x00007f6ea098722c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#1  0x00007f6ea0c0ef74 in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib64/qt4/libQtCore.so.4
#2  0x00007f6e9f847686 in QHostInfoAgent::run() () from /usr/lib64/qt4/libQtNetwork.so.4
#3  0x00007f6ea0c0e0c7 in QThreadPrivate::start(void*) () from /usr/lib64/qt4/libQtCore.so.4
#4  0x00007f6ea0982884 in start_thread () from /lib/libpthread.so.0
#5  0x00007f6e9d594f9d in clone () from /lib/libc.so.6
#6  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f6ea11ca760 (LWP 2355)):
[KCrash Handler]
#5  0x00007f6ea0d077c8 in QVariant::toDouble(bool*) const () from /usr/lib64/qt4/libQtCore.so.4
#6  0x00007f6e8521a408 in HalPower::brightness(QString const&) () from /usr/lib64/kde4/solid_hal_power.so
#7  0x00007f6e8831fbe8 in Solid::Control::PowerManager::brightness(QString const&) () from /usr/lib64/libsolidcontrol.so.4
#8  0x00007f6e8677af8b in Battery::initExtenderItem(Plasma::ExtenderItem*) () from /usr/lib64/kde4/plasma_applet_battery.so
#9  0x00007f6e9818e61e in Plasma::ExtenderPrivate::loadExtenderItems() () from /usr/lib64/libplasma.so.3
#10 0x00007f6e9818f5f0 in Plasma::Extender::Extender(Plasma::Applet*) () from /usr/lib64/libplasma.so.3
#11 0x00007f6e981576ae in Plasma::Applet::extender() const () from /usr/lib64/libplasma.so.3
#12 0x00007f6e8677e129 in Battery::init() () from /usr/lib64/kde4/plasma_applet_battery.so
#13 0x00007f6e9817c1da in Plasma::Corona::loadLayout(QString const&) () from /usr/lib64/libplasma.so.3
#14 0x00007f6e9817d224 in Plasma::Corona::initializeLayout(QString const&) () from /usr/lib64/libplasma.so.3
#15 0x00007f6e9499fdf3 in PlasmaApp::corona() () from /usr/lib64/libkdeinit4_plasma-desktop.so
#16 0x00007f6e949a00aa in PlasmaApp::setupDesktop() () from /usr/lib64/libkdeinit4_plasma-desktop.so
#17 0x00007f6e949a088f in PlasmaApp::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib64/libkdeinit4_plasma-desktop.so
#18 0x00007f6ea0cfde9b in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib64/qt4/libQtCore.so.4
#19 0x00007f6ea0d04af1 in QSingleShotTimer::timerEvent(QTimerEvent*) () from /usr/lib64/qt4/libQtCore.so.4
#20 0x00007f6ea0cfabf8 in QObject::event(QEvent*) () from /usr/lib64/qt4/libQtCore.so.4
#21 0x00007f6e9e173e08 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib64/qt4/libQtGui.so.4
#22 0x00007f6e9e17b8d4 in QApplication::notify(QObject*, QEvent*) () from /usr/lib64/qt4/libQtGui.so.4
#23 0x00007f6e9f19cff2 in KApplication::notify(QObject*, QEvent*) () from /usr/lib64/libkdeui.so.5
#24 0x00007f6ea0cecbca in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib64/qt4/libQtCore.so.4
#25 0x00007f6ea0d1563c in QTimerInfoList::activateTimers() () from /usr/lib64/qt4/libQtCore.so.4
#26 0x00007f6ea0d124d9 in timerSourceDispatch(_GSource*, int (*)(void*), void*) () from /usr/lib64/qt4/libQtCore.so.4
#27 0x00007f6e9c9fab9d in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#28 0x00007f6e9c9fde69 in g_main_context_iterate () from /usr/lib/libglib-2.0.so.0
#29 0x00007f6e9c9fdfc8 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#30 0x00007f6ea0d12250 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/qt4/libQtCore.so.4
#31 0x00007f6e9e2024c2 in QGuiEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/qt4/libQtGui.so.4
#32 0x00007f6ea0ceb822 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/qt4/libQtCore.so.4
#33 0x00007f6ea0cebb73 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/qt4/libQtCore.so.4
#34 0x00007f6ea0cef2bb in QCoreApplication::exec() () from /usr/lib64/qt4/libQtCore.so.4
#35 0x00007f6e94987aa7 in kdemain () from /usr/lib64/libkdeinit4_plasma-desktop.so
#36 0x0000000000406fb3 in launch(int, char const*, char const*, char const*, int, char const*, bool, char const*, bool, char const*) ()
#37 0x0000000000407938 in handle_launcher_request(int, char const*) ()
#38 0x00000000004080d5 in handle_requests(int) ()
#39 0x0000000000408caa in main ()

Reported using DrKonqi
Comment 1 FiNeX 2009-12-05 12:40:18 UTC
The two user account you've used, are new clean or existing accounts?
Comment 2 Dario Andres 2009-12-05 13:48:31 UTC
The backtrace is in fact related to the one in bug 217316.
- Can you check if some of the details match your case (hardware specs...) ?
Thanks
Comment 3 Dario Andres 2009-12-05 21:25:36 UTC

*** This bug has been marked as a duplicate of bug 217316 ***
Comment 4 Beat Wolf 2009-12-06 19:13:53 UTC
*** Bug 217617 has been marked as a duplicate of this bug. ***