Bug 220055 - plasma-desktop crashes during start of KDE
Summary: plasma-desktop crashes during start of KDE
Status: RESOLVED DUPLICATE of bug 219333
Alias: None
Product: plasma4
Classification: Plasma
Component: widget-battery (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-12-25 16:06 UTC by PeterF
Modified: 2009-12-26 21:40 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description PeterF 2009-12-25 16:06:31 UTC
Application that crashed: plasma-desktop
Version of the application: 0.3
KDE Version: 4.3.4 (KDE 4.3.4)
Qt Version: 4.5.3
Operating System: Linux 2.6.31-1-686 i686
Distribution: Debian GNU/Linux unstable (sid)

What I was doing when the application crashed:
After a recent update of my Debian Squeeze (testing) installation on my Dell C640 Notebook the KDE Desktop crashes every time I log in to the system.


 -- Backtrace:
Application: Plasma-Arbeitsfläche (kdeinit4), signal: Segmentation fault
[Current thread is 1 (Thread 0xb58bf700 (LWP 2171))]

Thread 2 (Thread 0xa8b96b70 (LWP 2198)):
#0  0xb78d3424 in __kernel_vsyscall ()
#1  0xb60060a5 in pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/i386/i686/../i486/pthread_cond_wait.S:122
#2  0xb61c882d in __pthread_cond_wait (cond=0x9281ac0, mutex=0x9281aa8) at forward.c:139
#3  0xb76d85c2 in QWaitConditionPrivate::wait (this=0x9283ee8, mutex=0x9283ee4, time=4294967295) at thread/qwaitcondition_unix.cpp:87
#4  QWaitCondition::wait (this=0x9283ee8, mutex=0x9283ee4, time=4294967295) at thread/qwaitcondition_unix.cpp:159
#5  0xb5f19a9a in QHostInfoAgent::run (this=0x9283ed8) at kernel/qhostinfo.cpp:260
#6  0xb76d75e2 in QThreadPrivate::start (arg=0x9283ed8) at thread/qthread_unix.cpp:188
#7  0xb6002585 in start_thread (arg=0xa8b96b70) at pthread_create.c:300
#8  0xb61bb2be in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130

Thread 1 (Thread 0xb58bf700 (LWP 2171)):
[KCrash Handler]
#6  0xb7729417 in QtPrivate::QStringList_contains (that=0xbff71a1c, str=..., cs=Qt::CaseSensitive) at tools/qstringlist.cpp:318
#7  0xa8c1fcce in QStringList::contains (this=0x95eed10, device=...) at /usr/include/qt4/QtCore/qstringlist.h:171
#8  HalPower::brightness (this=0x95eed10, device=...) at ../../../solid/hal/halpower.cpp:393
#9  0xa8d53d04 in Solid::Control::PowerManager::brightness (device=...) at ../../../../libs/solid/control/powermanager.cpp:198
#10 0xa8c0e87d in Battery::initExtenderItem (this=0x9676238, item=0x99e2500) at ../../../../plasma/applets/battery/battery.cpp:406
#11 0xa8c12412 in Battery::init (this=0x9676238) at ../../../../plasma/applets/battery/battery.cpp:151
#12 0xb444c755 in DesktopCorona::saveDefaultSetup (this=0x92560d0) at ../../../../plasma/shells/desktop/desktopcorona.cpp:287
#13 0xb444da90 in DesktopCorona::qt_metacall (this=0x92560d0, _c=QMetaObject::InvokeMetaMethod, _id=46, _a=0xbff71f68) at ./desktopcorona.moc:71
#14 0xb77dd303 in QMetaObject::activate (sender=0x95eec50, from_signal_index=4, to_signal_index=4, argv=0x0) at kernel/qobject.cpp:3112
#15 0xb77ddf42 in QMetaObject::activate (sender=0x95eec50, m=0xb78b8d88, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3186
#16 0xb77e3007 in QSingleShotTimer::timeout (this=0x95eec50) at .moc/release-shared/qtimer.moc:76
#17 0xb77e312c in QSingleShotTimer::timerEvent (this=0x95eec50) at kernel/qtimer.cpp:298
#18 0xb77d839f in QObject::event (this=0x95eec50, e=0xbff723ec) at kernel/qobject.cpp:1074
#19 0xb6467a94 in QApplicationPrivate::notify_helper (this=0x9256690, receiver=0x95eec50, e=0xbff723ec) at kernel/qapplication.cpp:4065
#20 0xb646fbee in QApplication::notify (this=0x922f758, receiver=0x95eec50, e=0xbff723ec) at kernel/qapplication.cpp:3605
#21 0xb6eb162d in KApplication::notify (this=0x922f758, receiver=0x95eec50, event=0xbff723ec) at ../../kdeui/kernel/kapplication.cpp:302
#22 0xb77c81eb in QCoreApplication::notifyInternal (this=0x922f758, receiver=0x95eec50, event=0xbff723ec) at kernel/qcoreapplication.cpp:610
#23 0xb77f6e21 in QCoreApplication::sendEvent (this=0x9259274) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:213
#24 QTimerInfoList::activateTimers (this=0x9259274) at kernel/qeventdispatcher_unix.cpp:580
#25 0xb77f3317 in timerSourceDispatch (source=0x92592b0) at kernel/qeventdispatcher_glib.cpp:184
#26 idleTimerSourceDispatch (source=0x92592b0) at kernel/qeventdispatcher_glib.cpp:231
#27 0xb604db38 in g_main_dispatch (context=0x9258690) at /tmp/buildd/glib2.0-2.22.3/glib/gmain.c:1960
#28 IA__g_main_context_dispatch (context=0x9258690) at /tmp/buildd/glib2.0-2.22.3/glib/gmain.c:2513
#29 0xb60513d0 in g_main_context_iterate (context=0x9258690, block=<value optimized out>, dispatch=1, self=0x9256168) at /tmp/buildd/glib2.0-2.22.3/glib/gmain.c:2591
#30 0xb6051503 in IA__g_main_context_iteration (context=0x9258690, may_block=1) at /tmp/buildd/glib2.0-2.22.3/glib/gmain.c:2654
#31 0xb77f3041 in QEventDispatcherGlib::processEvents (this=0x9256450, flags=...) at kernel/qeventdispatcher_glib.cpp:407
#32 0xb6507305 in QGuiEventDispatcherGlib::processEvents (this=0x9256450, flags=...) at kernel/qguieventdispatcher_glib.cpp:202
#33 0xb77c683a in QEventLoop::processEvents (this=0xbff72660, flags=...) at kernel/qeventloop.cpp:149
#34 0xb77c6c82 in QEventLoop::exec (this=0xbff72660, flags=...) at kernel/qeventloop.cpp:201
#35 0xb77c90d9 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#36 0xb6467917 in QApplication::exec () at kernel/qapplication.cpp:3525
#37 0xb44535cd in kdemain (argc=1, argv=0x91f7698) at ../../../../plasma/shells/desktop/main.cpp:50
#38 0x0804e291 in launch (argc=1, _name=0x921bff4 "/usr/bin/plasma-desktop", args=0x921c00c "", cwd=0x0, envc=0, envs=0x921c010 "", reset_env=false, tty=0x0, avoid_loops=false, 
    startup_id_str=0x805105f "0") at ../../kinit/kinit.cpp:677
#39 0x0804ea15 in handle_launcher_request (sock=7, who=<value optimized out>) at ../../kinit/kinit.cpp:1169
#40 0x0804ee5b in handle_requests (waitForPid=0) at ../../kinit/kinit.cpp:1362
#41 0x0804f689 in main (argc=2, argv=0xbff72ed4, envp=0xbff72ee0) at ../../kinit/kinit.cpp:1793

Reported using DrKonqi
Comment 1 Dario Andres 2009-12-25 17:05:02 UTC
This is likely to be related to bug 217316. Was your "hal" package updated to 0.5.14 ?
Regards
Comment 2 PeterF 2009-12-25 21:09:08 UTC
Yupp, the hal package (now?) has version 0.5.14
I'll try to downgrade to see if that will fix the issue.
Any idea where to get a version 0.5.13?
There is only a 0.5.14 version on the Debian FTP server. :-(
Rgds
Comment 3 Dario Andres 2009-12-25 21:15:11 UTC
May be from some outdated mirror?
Comment 4 PeterF 2009-12-26 00:37:03 UTC
Found a version hal_0.5.13-6 and it fixes the issue.
Nevertheless I also found a Debian Bug report #561724 which claims that the actual problem is caused by a bug in kdebase-workspace (ref KDE Bug #219143) and should be fixed with version kdebase-workspace_4:4.3.4-2. 
(it also provides a link to a version 0.5.13-6 of hal

(http://martin-steigerwald.de/hal-workaround-debian-bug-561724/)

In todays repository I found:
kdebase-workspace       4:4.3.2-2
kdebase-workspace-bin   4:4.3.4-2
kdebase-workspace-data  4:4.3.4-2

Therefore I guess I keep hal_0.5.13-6 until a kdebase-workspace 4:4.3.4 comes along.

I guess this bug report therefore can be closed.

Thanks for your support
Comment 5 Dario Andres 2009-12-26 01:28:06 UTC
Merging with bug 217316. Thanks for the information about the Debian tracker

*** This bug has been marked as a duplicate of bug 217316 ***
Comment 6 Hugo Mildenberger 2009-12-26 01:43:47 UTC
hmm, this again looks more like bug 219333
Comment 7 Dario Andres 2009-12-26 02:01:02 UTC
Er, yes.. the backtrace is more similar.. Let's see if the reporter still experiences the issue after upgrading to the patched package.
Comment 8 Dario Andres 2009-12-26 21:40:54 UTC

*** This bug has been marked as a duplicate of bug 219333 ***