Bug 219809 - crash trying to listen the script "Radio Swiss" in amarok 2.2.0
Summary: crash trying to listen the script "Radio Swiss" in amarok 2.2.0
Status: RESOLVED DUPLICATE of bug 206579
Alias: None
Product: amarok
Classification: Applications
Component: general (show other bugs)
Version: 2.2.0
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Amarok Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-12-23 11:19 UTC by bossa
Modified: 2009-12-23 12:27 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description bossa 2009-12-23 11:19:41 UTC
Application that crashed: amarok
Version of the application: 2.2.0
KDE Version: 4.3.2 (KDE 4.3.2)
Qt Version: 4.5.2
Operating System: Linux 2.6.31-16-generic i686
Distribution: Ubuntu 9.10

What I was doing when the application crashed:
crash of the "Radio Swiss" plugin, tried several times, but doesn't work

 -- Backtrace:
Application: Amarok (amarok), signal: Segmentation fault
[Current thread is 1 (Thread 0xb773e710 (LWP 2698))]

Thread 18 (Thread 0xb5f38b70 (LWP 2699)):
#0  0x00688422 in __kernel_vsyscall ()
#1  0x01d08142 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib/tls/i686/cmov/libpthread.so.0
#2  0x007627e4 in pthread_cond_timedwait () from /lib/tls/i686/cmov/libc.so.6
#3  0x021789ff in ?? () from /usr/lib/libxine.so.1
#4  0x01d0380e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#5  0x007557ee in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 17 (Thread 0xb5737b70 (LWP 2700)):
#0  0x00688422 in __kernel_vsyscall ()
#1  0x00747ba6 in poll () from /lib/tls/i686/cmov/libc.so.6
#2  0x022e654b in g_poll () from /lib/libglib-2.0.so.0
#3  0x022d956b in ?? () from /lib/libglib-2.0.so.0
#4  0x022d9863 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#5  0x004c2067 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#6  0x00495c79 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#7  0x004960ca in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#8  0x003a3b73 in QThread::exec() () from /usr/lib/libQtCore.so.4
#9  0x087cb20a in ?? () from /usr/lib/qt4/plugins/phonon_backend/phonon_xine.so
#10 0x003a6e32 in ?? () from /usr/lib/libQtCore.so.4
#11 0x01d0380e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#12 0x007557ee in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 16 (Thread 0xb4f36b70 (LWP 2703)):
#0  0x00762b8c in ?? () from /lib/tls/i686/cmov/libc.so.6
#1  0x00747bb8 in poll () from /lib/tls/i686/cmov/libc.so.6
#2  0x05e95c3b in ?? () from /usr/lib/xine/plugins/1.26/xineplug_ao_out_alsa.so
#3  0x01d0380e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#4  0x007557ee in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 15 (Thread 0xb4735b70 (LWP 2704)):
#0  0x00688422 in __kernel_vsyscall ()
#1  0x01d07e15 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/tls/i686/cmov/libpthread.so.0
#2  0x0076278d in pthread_cond_wait () from /lib/tls/i686/cmov/libc.so.6
#3  0x021895ee in ?? () from /usr/lib/libxine.so.1
#4  0x01d0380e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#5  0x007557ee in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 14 (Thread 0xb3bffb70 (LWP 2705)):
#0  0x00688422 in __kernel_vsyscall ()
#1  0x01d07e15 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/tls/i686/cmov/libpthread.so.0
#2  0x0076278d in pthread_cond_wait () from /lib/tls/i686/cmov/libc.so.6
#3  0x021895ee in ?? () from /usr/lib/libxine.so.1
#4  0x01d0380e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#5  0x007557ee in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 13 (Thread 0xb33feb70 (LWP 2706)):
#0  0x00688422 in __kernel_vsyscall ()
#1  0x01d07e15 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/tls/i686/cmov/libpthread.so.0
#2  0x0076278d in pthread_cond_wait () from /lib/tls/i686/cmov/libc.so.6
#3  0x021895ee in ?? () from /usr/lib/libxine.so.1
#4  0x01d0380e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#5  0x007557ee in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 12 (Thread 0xb2309b70 (LWP 2709)):
#0  0x00688422 in __kernel_vsyscall ()
#1  0x01d07e15 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/tls/i686/cmov/libpthread.so.0
#2  0x0076278d in pthread_cond_wait () from /lib/tls/i686/cmov/libc.so.6
#3  0x003a7e67 in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib/libQtCore.so.4
#4  0x00e70b30 in ?? () from /usr/lib/libthreadweaver.so.4
#5  0x00e7319c in ?? () from /usr/lib/libthreadweaver.so.4
#6  0x00e6f1fb in ?? () from /usr/lib/libthreadweaver.so.4
#7  0x00e73292 in ?? () from /usr/lib/libthreadweaver.so.4
#8  0x00e70db3 in ?? () from /usr/lib/libthreadweaver.so.4
#9  0x00e713be in ?? () from /usr/lib/libthreadweaver.so.4
#10 0x00e719db in ThreadWeaver::Thread::run() () from /usr/lib/libthreadweaver.so.4
#11 0x003a6e32 in ?? () from /usr/lib/libQtCore.so.4
#12 0x01d0380e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#13 0x007557ee in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 11 (Thread 0xb1368b70 (LWP 2710)):
#0  0x00688422 in __kernel_vsyscall ()
#1  0x01d07e15 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/tls/i686/cmov/libpthread.so.0
#2  0x0076278d in pthread_cond_wait () from /lib/tls/i686/cmov/libc.so.6
#3  0x003a7e67 in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib/libQtCore.so.4
#4  0x00e70b30 in ?? () from /usr/lib/libthreadweaver.so.4
#5  0x00e7319c in ?? () from /usr/lib/libthreadweaver.so.4
#6  0x00e6f1fb in ?? () from /usr/lib/libthreadweaver.so.4
#7  0x00e73292 in ?? () from /usr/lib/libthreadweaver.so.4
#8  0x00e70db3 in ?? () from /usr/lib/libthreadweaver.so.4
#9  0x00e732b1 in ?? () from /usr/lib/libthreadweaver.so.4
#10 0x00e70db3 in ?? () from /usr/lib/libthreadweaver.so.4
#11 0x00e713be in ?? () from /usr/lib/libthreadweaver.so.4
#12 0x00e719db in ThreadWeaver::Thread::run() () from /usr/lib/libthreadweaver.so.4
#13 0x003a6e32 in ?? () from /usr/lib/libQtCore.so.4
#14 0x01d0380e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#15 0x007557ee in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 10 (Thread 0xb0b67b70 (LWP 2711)):
#0  0x00688422 in __kernel_vsyscall ()
#1  0x01d07e15 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/tls/i686/cmov/libpthread.so.0
#2  0x0076278d in pthread_cond_wait () from /lib/tls/i686/cmov/libc.so.6
#3  0x003a7e67 in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib/libQtCore.so.4
#4  0x00e70b30 in ?? () from /usr/lib/libthreadweaver.so.4
#5  0x00e7319c in ?? () from /usr/lib/libthreadweaver.so.4
#6  0x00e6f1fb in ?? () from /usr/lib/libthreadweaver.so.4
#7  0x00e73292 in ?? () from /usr/lib/libthreadweaver.so.4
#8  0x00e70db3 in ?? () from /usr/lib/libthreadweaver.so.4
#9  0x00e713be in ?? () from /usr/lib/libthreadweaver.so.4
#10 0x00e719db in ThreadWeaver::Thread::run() () from /usr/lib/libthreadweaver.so.4
#11 0x003a6e32 in ?? () from /usr/lib/libQtCore.so.4
#12 0x01d0380e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#13 0x007557ee in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 9 (Thread 0xa529ab70 (LWP 3173)):
#0  0x00688422 in __kernel_vsyscall ()
#1  0x0074e981 in select () from /lib/tls/i686/cmov/libc.so.6
#2  0x021a1be0 in xine_usec_sleep () from /usr/lib/libxine.so.1
#3  0x02186011 in ?? () from /usr/lib/libxine.so.1
#4  0x01d0380e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#5  0x007557ee in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 8 (Thread 0xa42a5b70 (LWP 3174)):
#0  0x00688422 in __kernel_vsyscall ()
#1  0x01d07e15 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/tls/i686/cmov/libpthread.so.0
#2  0x0076278d in pthread_cond_wait () from /lib/tls/i686/cmov/libc.so.6
#3  0x0217bfc2 in ?? () from /usr/lib/libxine.so.1
#4  0x02181d36 in ?? () from /usr/lib/libxine.so.1
#5  0x01d0380e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#6  0x007557ee in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 7 (Thread 0xa38d7b70 (LWP 3175)):
#0  0x00688422 in __kernel_vsyscall ()
#1  0x01d07e15 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/tls/i686/cmov/libpthread.so.0
#2  0x0076278d in pthread_cond_wait () from /lib/tls/i686/cmov/libc.so.6
#3  0x0217bfc2 in ?? () from /usr/lib/libxine.so.1
#4  0x02182d46 in ?? () from /usr/lib/libxine.so.1
#5  0x01d0380e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#6  0x007557ee in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 6 (Thread 0xa30d6b70 (LWP 3176)):
#0  0x00688422 in __kernel_vsyscall ()
#1  0x01d07e15 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/tls/i686/cmov/libpthread.so.0
#2  0x0076278d in pthread_cond_wait () from /lib/tls/i686/cmov/libc.so.6
#3  0x0218c51a in xine_event_wait () from /usr/lib/libxine.so.1
#4  0x0218c5a2 in ?? () from /usr/lib/libxine.so.1
#5  0x01d0380e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#6  0x007557ee in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 5 (Thread 0xa010fb70 (LWP 3191)):
#0  0x00688422 in __kernel_vsyscall ()
#1  0x01d07e15 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/tls/i686/cmov/libpthread.so.0
#2  0x0076278d in pthread_cond_wait () from /lib/tls/i686/cmov/libc.so.6
#3  0x003a7e67 in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib/libQtCore.so.4
#4  0x06808dea in ?? () from /usr/lib/libQtGui.so.4
#5  0x003a6e32 in ?? () from /usr/lib/libQtCore.so.4
#6  0x01d0380e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#7  0x007557ee in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 4 (Thread 0x9f90eb70 (LWP 3192)):
#0  0x00688422 in __kernel_vsyscall ()
#1  0x00747ba6 in poll () from /lib/tls/i686/cmov/libc.so.6
#2  0x022e654b in g_poll () from /lib/libglib-2.0.so.0
#3  0x022d956b in ?? () from /lib/libglib-2.0.so.0
#4  0x022d9863 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#5  0x004c2067 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#6  0x00495c79 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#7  0x004960ca in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#8  0x003a3b73 in QThread::exec() () from /usr/lib/libQtCore.so.4
#9  0x004786ab in ?? () from /usr/lib/libQtCore.so.4
#10 0x003a6e32 in ?? () from /usr/lib/libQtCore.so.4
#11 0x01d0380e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#12 0x007557ee in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 3 (Thread 0xa2083b70 (LWP 3193)):
#0  0x00688422 in __kernel_vsyscall ()
#1  0x01d07e15 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/tls/i686/cmov/libpthread.so.0
#2  0x0076278d in pthread_cond_wait () from /lib/tls/i686/cmov/libc.so.6
#3  0x003a7e67 in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib/libQtCore.so.4
#4  0x06808dea in ?? () from /usr/lib/libQtGui.so.4
#5  0x003a6e32 in ?? () from /usr/lib/libQtCore.so.4
#6  0x01d0380e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#7  0x007557ee in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 2 (Thread 0x9f10db70 (LWP 3194)):
#0  0x096e2e06 in clock_gettime () from /lib/tls/i686/cmov/librt.so.1
#1  0x004c3bf3 in ?? () from /usr/lib/libQtCore.so.4
#2  0x004c3de1 in ?? () from /usr/lib/libQtCore.so.4
#3  0x004c488c in ?? () from /usr/lib/libQtCore.so.4
#4  0x004c2210 in ?? () from /usr/lib/libQtCore.so.4
#5  0x022d8f90 in g_main_context_prepare () from /lib/libglib-2.0.so.0
#6  0x022d9351 in ?? () from /lib/libglib-2.0.so.0
#7  0x022d9863 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#8  0x004c2067 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#9  0x00495c79 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#10 0x004960ca in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#11 0x003a3b73 in QThread::exec() () from /usr/lib/libQtCore.so.4
#12 0x004786ab in ?? () from /usr/lib/libQtCore.so.4
#13 0x003a6e32 in ?? () from /usr/lib/libQtCore.so.4
#14 0x01d0380e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#15 0x007557ee in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 1 (Thread 0xb773e710 (LWP 2698)):
[KCrash Handler]
#6  0x003a1a69 in QMutex::lock() () from /usr/lib/libQtCore.so.4
#7  0x00497334 in QCoreApplication::postEvent(QObject*, QEvent*, int) () from /usr/lib/libQtCore.so.4
#8  0x0049763c in QCoreApplication::postEvent(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#9  0x004a6ab4 in QObject::deleteLater() () from /usr/lib/libQtCore.so.4
#10 0x00fa3a29 in CollectionTreeItemModelBase::queryDone() () from /usr/lib/libamaroklib.so.1
#11 0x00fa6bae in CollectionTreeItemModelBase::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libamaroklib.so.1
#12 0x00fbdb62 in SingleCollectionTreeItemModel::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libamaroklib.so.1
#13 0x004a5f0b in QMetaCallEvent::placeMetaCall(QObject*) () from /usr/lib/libQtCore.so.4
#14 0x004a75fe in QObject::event(QEvent*) () from /usr/lib/libQtCore.so.4
#15 0x062dbf54 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#16 0x062e367c in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#17 0x00b83bfa in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#18 0x004976cb in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#19 0x004982b2 in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /usr/lib/libQtCore.so.4
#20 0x0049847d in QCoreApplication::sendPostedEvents(QObject*, int) () from /usr/lib/libQtCore.so.4
#21 0x004c23ff in ?? () from /usr/lib/libQtCore.so.4
#22 0x022d5e88 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#23 0x022d9730 in ?? () from /lib/libglib-2.0.so.0
#24 0x022d9863 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#25 0x004c202c in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#26 0x0637cbe5 in ?? () from /usr/lib/libQtGui.so.4
#27 0x00495c79 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#28 0x004960ca in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#29 0x0049853f in QCoreApplication::exec() () from /usr/lib/libQtCore.so.4
#30 0x062dbdd7 in QApplication::exec() () from /usr/lib/libQtGui.so.4
#31 0x08051e49 in _start ()

This bug may be a duplicate of or related to bug 216178

Reported using DrKonqi
Comment 1 Myriam Schweingruber 2009-12-23 12:27:08 UTC
Please upgrade to Amarok 2.2.1

*** This bug has been marked as a duplicate of bug 206579 ***