Bug 216178 - Amarok "Swiss internet stations" plugin crash
Summary: Amarok "Swiss internet stations" plugin crash
Status: RESOLVED DUPLICATE of bug 206579
Alias: None
Product: amarok
Classification: Applications
Component: general (show other bugs)
Version: 2.2.0
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Amarok Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-11-26 00:04 UTC by hmms.janssen
Modified: 2009-11-26 07:40 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description hmms.janssen 2009-11-26 00:04:22 UTC
Application that crashed: amarok
Version of the application: 2.2.0
KDE Version: 4.3.3 (KDE 4.3.3)
Qt Version: 4.5.3
Operating System: Linux 2.6.31.5-127.fc12.i686 i686
Distribution: "Fedora release 12 (Constantine)"

What I was doing when the application crashed:
RadioSwiss script
106319-RadioSwiss.0.2.amarokscript.tar.gz

Stations are divided into categories, as soon you select a category you get a short view on all categories and then Amarok crashes. 
Reproducable.

In contrast, norsk_nettradio script behaves as expected,

Icecast streams crash too...

Kind regards,


 -- Backtrace:
Application: Amarok (amarok), signal: Segmentation fault
[Current thread is 1 (Thread 0xb781f7d0 (LWP 4800))]

Thread 10 (Thread 0xb55d5b70 (LWP 4801)):
#0  0x00bcb416 in __kernel_vsyscall ()
#1  0x007d9f72 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0x00a41884 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib/libc.so.6
#3  0x0213d6b5 in ?? () from /usr/lib/libxine.so.1
#4  0x007d5ab5 in start_thread () from /lib/libpthread.so.0
#5  0x00a3283e in clone () from /lib/libc.so.6

Thread 9 (Thread 0xb4bd4b70 (LWP 4802)):
#0  0x007d8ec8 in pthread_mutex_unlock () from /lib/libpthread.so.0
#1  0x00a41a36 in pthread_mutex_unlock () from /lib/libc.so.6
#2  0x02674f9c in g_main_context_check () from /lib/libglib-2.0.so.0
#3  0x02675794 in ?? () from /lib/libglib-2.0.so.0
#4  0x02675b74 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#5  0x059e9ba7 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#6  0x059bd2aa in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#7  0x059bd70a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#8  0x058caa54 in QThread::exec() () from /usr/lib/libQtCore.so.4
#9  0x01dae83b in Phonon::MediaSource::type() const () from /usr/lib/kde4/plugins/phonon_backend/phonon_xine.so
#10 0x058cdde3 in ?? () from /usr/lib/libQtCore.so.4
#11 0x007d5ab5 in start_thread () from /lib/libpthread.so.0
#12 0x00a3283e in clone () from /lib/libc.so.6

Thread 8 (Thread 0xb3fffb70 (LWP 4803)):
#0  0x00bcb416 in __kernel_vsyscall ()
#1  0x00a27e46 in poll () from /lib/libc.so.6
#2  0x060bb443 in poll_func (ufds=<value optimized out>, nfds=<value optimized out>, timeout=<value optimized out>, userdata=<value optimized out>) at pulse/thread-mainloop.c:75
#3  0x060a851a in pa_mainloop_poll (m=<value optimized out>) at pulse/mainloop.c:879
#4  0x060a9d94 in pa_mainloop_iterate (m=<value optimized out>, block=<value optimized out>, retval=<value optimized out>) at pulse/mainloop.c:961
#5  0x060a9e74 in pa_mainloop_run (m=<value optimized out>, retval=<value optimized out>) at pulse/mainloop.c:979
#6  0x060bb344 in thread (userdata=<value optimized out>) at pulse/thread-mainloop.c:94
#7  0x0235b653 in internal_thread_func (userdata=<value optimized out>) at pulsecore/thread-posix.c:72
#8  0x007d5ab5 in start_thread () from /lib/libpthread.so.0
#9  0x00a3283e in clone () from /lib/libc.so.6

Thread 7 (Thread 0xaf3feb70 (LWP 4804)):
#0  0x00bcb416 in __kernel_vsyscall ()
#1  0x007d9c45 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0x00a4182d in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libc.so.6
#3  0x0214f6d4 in ?? () from /usr/lib/libxine.so.1
#4  0x007d5ab5 in start_thread () from /lib/libpthread.so.0
#5  0x00a3283e in clone () from /lib/libc.so.6

Thread 6 (Thread 0xae7ffb70 (LWP 4805)):
#0  0x00bcb416 in __kernel_vsyscall ()
#1  0x007d9c45 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0x00a4182d in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libc.so.6
#3  0x0214f6d4 in ?? () from /usr/lib/libxine.so.1
#4  0x007d5ab5 in start_thread () from /lib/libpthread.so.0
#5  0x00a3283e in clone () from /lib/libc.so.6

Thread 5 (Thread 0xadbffb70 (LWP 4806)):
#0  0x00bcb416 in __kernel_vsyscall ()
#1  0x007d9c45 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0x00a4182d in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libc.so.6
#3  0x0214f6d4 in ?? () from /usr/lib/libxine.so.1
#4  0x007d5ab5 in start_thread () from /lib/libpthread.so.0
#5  0x00a3283e in clone () from /lib/libc.so.6

Thread 4 (Thread 0xac960b70 (LWP 4808)):
#0  0x00bcb416 in __kernel_vsyscall ()
#1  0x007d9c45 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0x00a4182d in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libc.so.6
#3  0x058cee5f in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib/libQtCore.so.4
#4  0x00b6c3d0 in ?? () from /usr/lib/libthreadweaver.so.4
#5  0x00b6eb0d in ?? () from /usr/lib/libthreadweaver.so.4
#6  0x00b6aa2c in ?? () from /usr/lib/libthreadweaver.so.4
#7  0x00b6ec0a in ?? () from /usr/lib/libthreadweaver.so.4
#8  0x00b6c664 in ?? () from /usr/lib/libthreadweaver.so.4
#9  0x00b6ec29 in ?? () from /usr/lib/libthreadweaver.so.4
#10 0x00b6c664 in ?? () from /usr/lib/libthreadweaver.so.4
#11 0x00b6cc86 in ?? () from /usr/lib/libthreadweaver.so.4
#12 0x00b6d2dc in ThreadWeaver::Thread::run() () from /usr/lib/libthreadweaver.so.4
#13 0x058cdde3 in ?? () from /usr/lib/libQtCore.so.4
#14 0x007d5ab5 in start_thread () from /lib/libpthread.so.0
#15 0x00a3283e in clone () from /lib/libc.so.6

Thread 3 (Thread 0xab6ebb70 (LWP 4809)):
#0  0x00bcb416 in __kernel_vsyscall ()
#1  0x007d9c45 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0x00a4182d in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libc.so.6
#3  0x058cee5f in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib/libQtCore.so.4
#4  0x00b6c3d0 in ?? () from /usr/lib/libthreadweaver.so.4
#5  0x00b6eb0d in ?? () from /usr/lib/libthreadweaver.so.4
#6  0x00b6aa2c in ?? () from /usr/lib/libthreadweaver.so.4
#7  0x00b6ec0a in ?? () from /usr/lib/libthreadweaver.so.4
#8  0x00b6c664 in ?? () from /usr/lib/libthreadweaver.so.4
#9  0x00b6cc86 in ?? () from /usr/lib/libthreadweaver.so.4
#10 0x00b6d2dc in ThreadWeaver::Thread::run() () from /usr/lib/libthreadweaver.so.4
#11 0x058cdde3 in ?? () from /usr/lib/libQtCore.so.4
#12 0x007d5ab5 in start_thread () from /lib/libpthread.so.0
#13 0x00a3283e in clone () from /lib/libc.so.6

Thread 2 (Thread 0xaaceab70 (LWP 4811)):
#0  0x00bcb416 in __kernel_vsyscall ()
#1  0x007d9c45 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0x00a4182d in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libc.so.6
#3  0x058cee5f in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib/libQtCore.so.4
#4  0x00b6c3d0 in ?? () from /usr/lib/libthreadweaver.so.4
#5  0x00b6eb0d in ?? () from /usr/lib/libthreadweaver.so.4
#6  0x00b6aa2c in ?? () from /usr/lib/libthreadweaver.so.4
#7  0x00b6ec0a in ?? () from /usr/lib/libthreadweaver.so.4
#8  0x00b6c664 in ?? () from /usr/lib/libthreadweaver.so.4
#9  0x00b6ec29 in ?? () from /usr/lib/libthreadweaver.so.4
#10 0x00b6c664 in ?? () from /usr/lib/libthreadweaver.so.4
#11 0x00b6cc86 in ?? () from /usr/lib/libthreadweaver.so.4
#12 0x00b6d2dc in ThreadWeaver::Thread::run() () from /usr/lib/libthreadweaver.so.4
#13 0x058cdde3 in ?? () from /usr/lib/libQtCore.so.4
#14 0x007d5ab5 in start_thread () from /lib/libpthread.so.0
#15 0x00a3283e in clone () from /lib/libc.so.6

Thread 1 (Thread 0xb781f7d0 (LWP 4800)):
[KCrash Handler]
#6  0x059be9bc in QCoreApplication::postEvent(QObject*, QEvent*, int) () from /usr/lib/libQtCore.so.4
#7  0x059becdd in QCoreApplication::postEvent(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#8  0x059ce405 in QObject::deleteLater() () from /usr/lib/libQtCore.so.4
#9  0x03b3e86a in CollectionTreeItemModelBase::queryDone() () from /usr/lib/libamaroklib.so.1
#10 0x03b419ee in CollectionTreeItemModelBase::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libamaroklib.so.1
#11 0x03b58a13 in SingleCollectionTreeItemModel::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libamaroklib.so.1
#12 0x059cd7fc in QMetaCallEvent::placeMetaCall(QObject*) () from /usr/lib/libQtCore.so.4
#13 0x059cef96 in QObject::event(QEvent*) () from /usr/lib/libQtCore.so.4
#14 0x06a55b24 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#15 0x06a5d281 in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#16 0x002d302b in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#17 0x059bed73 in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#18 0x059bf972 in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /usr/lib/libQtCore.so.4
#19 0x059bfb2e in QCoreApplication::sendPostedEvents(QObject*, int) () from /usr/lib/libQtCore.so.4
#20 0x059e9f40 in ?? () from /usr/lib/libQtCore.so.4
#21 0x02672118 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#22 0x02675a48 in ?? () from /lib/libglib-2.0.so.0
#23 0x02675b74 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#24 0x059e9b6d in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#25 0x06af5356 in ?? () from /usr/lib/libQtGui.so.4
#26 0x059bd2aa in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#27 0x059bd70a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#28 0x059bfbf7 in QCoreApplication::exec() () from /usr/lib/libQtCore.so.4
#29 0x06a559a8 in QApplication::exec() () from /usr/lib/libQtGui.so.4
#30 0x08051da1 in _start ()

This bug may be a duplicate of or related to bug 210270

Reported using DrKonqi
Comment 1 Myriam Schweingruber 2009-11-26 00:31:38 UTC
FWIW, the Swiss Radio Station Script is a 3rd-party application. But the bug you report has nothing to do with the script, is a query bug that is already fixed in Amarok 2.2.1, available for your distribution.

*** This bug has been marked as a duplicate of bug 206579 ***
Comment 2 hmms.janssen 2009-11-26 07:40:58 UTC
Thanks,

Apologize, I had to check updates before, the working version is already in the
update repository. I can confirm that Icecast works as desired, and
Swiss Radio works almost as desired: a number of stations from the
"Deutschschweiz"catagory does not collapse properly when pressing the "-"
icon, but that might be a script issue.

Thanks and kind regards