Bug 203322 - kbuildsycoca start initialization freeze kdeinit
Summary: kbuildsycoca start initialization freeze kdeinit
Status: RESOLVED DUPLICATE of bug 202871
Alias: None
Product: kdelibs
Classification: Frameworks and Libraries
Component: ksycoca (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: David Faure
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-08-10 16:37 UTC by Try Again
Modified: 2009-08-11 00:06 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Try Again 2009-08-10 16:37:33 UTC
Application that crashed: kbuildsycoca4
Version of the application: 1.1
KDE Version: 4.3.00 (KDE 4.3.0)
Qt Version: 4.5.2
Operating System: Linux 2.6.30-ARCH x86_64

What I was doing when the application crashed:
After two successful sessions, I log into KDM a third time but now I've got some issues... kdeinit takes too long, then the desktop appears, but Bugs Report assistant tells me kbuildsycoca has crashed.

 -- Backtrace:
Application: KBuildSycoca (kdeinit4), signal: Segmentation fault
[KCrash Handler]
#5  0x00007fa128d24390 in KSycocaEntry::offset () from /usr/lib/libkdecore.so.5
#6  0x00007fa11d46254d in KBuildMimeTypeFactory::savePatternLists () from /usr/lib/libkdeinit4_kbuildsycoca4.so
#7  0x00007fa11d462a03 in KBuildMimeTypeFactory::save () from /usr/lib/libkdeinit4_kbuildsycoca4.so
#8  0x00007fa11d45bd19 in KBuildSycoca::save () from /usr/lib/libkdeinit4_kbuildsycoca4.so
#9  0x00007fa11d45ea1b in KBuildSycoca::recreate () from /usr/lib/libkdeinit4_kbuildsycoca4.so
#10 0x00007fa11d45fe56 in kdemain () from /usr/lib/libkdeinit4_kbuildsycoca4.so
#11 0x0000000000406eae in _start ()

Reported using DrKonqi
Comment 1 Try Again 2009-08-10 20:44:41 UTC
One more thing: this bug doesn't occur with a clean home directory. There seems to be conflicts with some config files from older KDE versions or another desktop environnements (I also use GNOME and LXDE).
Comment 2 Dario Andres 2009-08-11 00:06:13 UTC
Merging with bug 202871. Thanks

*** This bug has been marked as a duplicate of bug 202871 ***