Bug 219396 - knetworkmanager crashes on startup
Summary: knetworkmanager crashes on startup
Status: RESOLVED DUPLICATE of bug 210878
Alias: None
Product: knetworkmanager
Classification: Miscellaneous
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Will Stephenson
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-12-20 10:03 UTC by Kai Blin
Modified: 2009-12-20 14:15 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kai Blin 2009-12-20 10:03:05 UTC
Application that crashed: knetworkmanager
Version of the application: v0.9
KDE Version: 4.3.2 (KDE 4.3.2)
Qt Version: 4.5.2
Operating System: Linux 2.6.31-15-generic i686
Distribution: Ubuntu 9.10

What I was doing when the application crashed:
when manually starting network-manager from the command line, knetworkmanager tries to start up and crashes. Restarting knetworkmanager manually works fine.

(To be honest, I'm pretty convinced this is a dup of the bug I marked this a possible dup of, which again is a dup of some other bug. Unfortunately I wasn't able to tell which bug would be used to track this, or why I'm even still filling out a detailed bug report.)

 -- Backtrace:
Application: KNetworkManager (knetworkmanager), signal: Segmentation fault
[KCrash Handler]
#6  QBasicAtomicInt::ref (this=0x9a66708) at /usr/include/qt4/QtCore/qatomic_i386.h:120
#7  QString (this=0x9a66708) at /usr/include/qt4/QtCore/qstring.h:712
#8  Knm::Activatable::deviceUni (this=0x9a66708) at /build/buildd/plasma-widget-networkmanagement-0.9~svn1029786+ag1/libs/internals/activatable.cpp:51
#9  0x001970f2 in compareDevices (first=0x9a4c340, second=0x9a66708) at /build/buildd/plasma-widget-networkmanagement-0.9~svn1029786+ag1/libs/service/sortedactivatablelist.cpp:264
#10 0x0019721c in activatableLessThan (first=0x9a4c340, second=0x9a66708) at /build/buildd/plasma-widget-networkmanagement-0.9~svn1029786+ag1/libs/service/sortedactivatablelist.cpp:173
#11 0x0019749d in qSortHelper<QList<Knm::Activatable*>::iterator, Knm::Activatable*, bool (*)(Knm::Activatable const*, Knm::Activatable const*)> (start=<value optimized out>, end=)
    at /usr/include/qt4/QtCore/qalgorithms.h:379
#12 0x00197697 in qSort<QList<Knm::Activatable*>::iterator, bool (*)(Knm::Activatable const*, Knm::Activatable const*)> (this=0x9a01e70, activatable=0x9a4c340)
    at /usr/include/qt4/QtCore/qalgorithms.h:204
#13 SortedActivatableList::handleAdd (this=0x9a01e70, activatable=0x9a4c340) at /build/buildd/plasma-widget-networkmanagement-0.9~svn1029786+ag1/libs/service/sortedactivatablelist.cpp:100
#14 0x00185d03 in ActivatableList::addActivatableInternal (this=0x9a33558, activatable=0x9a4c340)
    at /build/buildd/plasma-widget-networkmanagement-0.9~svn1029786+ag1/libs/service/activatablelist.cpp:94
#15 0x00185d9c in ActivatableList::addActivatable (this=0x9a33558, activatable=0x6) at /build/buildd/plasma-widget-networkmanagement-0.9~svn1029786+ag1/libs/service/activatablelist.cpp:82
#16 0x00189d95 in WirelessNetworkInterfaceActivatableProvider::handleAdd (this=0x9be14f0, addedConnection=0x9a4fde0)
    at /build/buildd/plasma-widget-networkmanagement-0.9~svn1029786+ag1/libs/service/wirelessnetworkinterfaceactivatableprovider.cpp:132
#17 0x0018a0d9 in WirelessNetworkInterfaceActivatableProvider::networkAppeared (this=0x9be14f0, ssid=...)
    at /build/buildd/plasma-widget-networkmanagement-0.9~svn1029786+ag1/libs/service/wirelessnetworkinterfaceactivatableprovider.cpp:176
#18 0x0018aa89 in WirelessNetworkInterfaceActivatableProvider (this=0x9be14f0, connectionList=0x99fea68, activatableList=0x9a33558, interface=0x9a50088, parent=0x9a4c118, 
    __in_chrg=<value optimized out>, __vtt_parm=<value optimized out>)
    at /build/buildd/plasma-widget-networkmanagement-0.9~svn1029786+ag1/libs/service/wirelessnetworkinterfaceactivatableprovider.cpp:76
#19 0x0018656c in NetworkInterfaceMonitor::networkInterfaceAdded (this=0x9a4c118, uni=...)
    at /build/buildd/plasma-widget-networkmanagement-0.9~svn1029786+ag1/libs/service/networkinterfacemonitor.cpp:71
#20 0x0017fa9b in NetworkInterfaceMonitor::qt_metacall (this=0x9a4c118, _c=QMetaObject::InvokeMetaMethod, _id=4, _a=0xbfe13528)
    at /build/buildd/plasma-widget-networkmanagement-0.9~svn1029786+ag1/obj-i486-linux-gnu/libs/service/moc_networkinterfacemonitor.cpp:69
#21 0x01d5f263 in QMetaObject::activate (sender=0x9a21880, from_signal_index=5, to_signal_index=5, argv=0xbfe13528) at kernel/qobject.cpp:3113
#22 0x01d5fec2 in QMetaObject::activate (sender=0x9a21880, m=0x21d6e0, local_signal_index=1, argv=0xbfe13528) at kernel/qobject.cpp:3187
#23 0x002048b3 in Solid::Control::NetworkManager::Notifier::networkInterfaceAdded(QString const&) () from /usr/lib/libsolidcontrol.so.4
#24 0x00205346 in ?? () from /usr/lib/libsolidcontrol.so.4
#25 0x002053c7 in ?? () from /usr/lib/libsolidcontrol.so.4
#26 0x01d5f263 in QMetaObject::activate (sender=0x9a28940, from_signal_index=13, to_signal_index=13, argv=0xbfe13688) at kernel/qobject.cpp:3113
#27 0x01d5fec2 in QMetaObject::activate (sender=0x9a28940, m=0x43f4a70, local_signal_index=1, argv=0xbfe13688) at kernel/qobject.cpp:3187
#28 0x043db143 in NMNetworkManager::networkInterfaceAdded(QString const&) () from /usr/lib/kde4/solid_networkmanager07.so
#29 0x043dc6a8 in NMNetworkManager::deviceAdded(QDBusObjectPath const&) () from /usr/lib/kde4/solid_networkmanager07.so
#30 0x043df87d in NMNetworkManager::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/kde4/solid_networkmanager07.so
#31 0x01d5f263 in QMetaObject::activate (sender=0x9a47050, from_signal_index=5, to_signal_index=5, argv=0xbfe13828) at kernel/qobject.cpp:3113
#32 0x01d5fec2 in QMetaObject::activate (sender=0x9a47050, m=0x43f5a80, local_signal_index=0, argv=0xbfe13828) at kernel/qobject.cpp:3187
#33 0x043ebe53 in ?? () from /usr/lib/kde4/solid_networkmanager07.so
#34 0x043ec385 in ?? () from /usr/lib/kde4/solid_networkmanager07.so
#35 0x002407b4 in QDBusConnectionPrivate::deliverCall (this=0x9a1d528, object=0x9a47050, msg=..., metaTypes=..., slotIdx=5) at qdbusintegrator.cpp:891
#36 0x00248197 in QDBusCallDeliveryEvent::placeMetaCall(QObject*) () from /usr/lib/libQtDBus.so.4
#37 0x01d595fe in QObject::event (this=0x9a47050, e=0x9b03a88) at kernel/qobject.cpp:1111
#38 0x00d5af54 in QApplicationPrivate::notify_helper (this=0x99682d8, receiver=0x9a47050, e=0x9b03a88) at kernel/qapplication.cpp:4056
#39 0x00d6267c in QApplication::notify (this=0xbfe14290, receiver=0x9a47050, e=0x9b03a88) at kernel/qapplication.cpp:3603
#40 0x0087dbfa in KApplication::notify (this=0xbfe14290, receiver=0x9a47050, event=0x9b03a88) at ../../kdeui/kernel/kapplication.cpp:302
#41 0x01d496cb in QCoreApplication::notifyInternal (this=0xbfe14290, receiver=0x9a47050, event=0x9b03a88) at kernel/qcoreapplication.cpp:610
#42 0x01d4a2b2 in QCoreApplication::sendEvent (receiver=0x0, event_type=0, data=0x994ee48) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:213
#43 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x994ee48) at kernel/qcoreapplication.cpp:1247
#44 0x01d4a47d in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1140
#45 0x01d743ff in QCoreApplication::sendPostedEvents (s=0x996ab20) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#46 postEventSourceDispatch (s=0x996ab20) at kernel/qeventdispatcher_glib.cpp:210
#47 0x025dce78 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#48 0x025e0720 in ?? () from /lib/libglib-2.0.so.0
#49 0x025e0853 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#50 0x01d7402c in QEventDispatcherGlib::processEvents (this=0x994ea30, flags=...) at kernel/qeventdispatcher_glib.cpp:327
#51 0x00dfbbe5 in QGuiEventDispatcherGlib::processEvents (this=0x994ea30, flags=...) at kernel/qguieventdispatcher_glib.cpp:202
#52 0x01d47c79 in QEventLoop::processEvents (this=0xbfe141f4, flags=) at kernel/qeventloop.cpp:149
#53 0x01d480ca in QEventLoop::exec (this=0xbfe141f4, flags=...) at kernel/qeventloop.cpp:201
#54 0x01d4a53f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#55 0x00d5add7 in QApplication::exec () at kernel/qapplication.cpp:3525
#56 0x08052905 in main (argc=1, argv=0xbfe143e4) at /build/buildd/plasma-widget-networkmanagement-0.9~svn1029786+ag1/monolithic/main.cpp:45

This bug may be a duplicate of or related to bug 217089

Reported using DrKonqi
Comment 1 Dario Andres 2009-12-20 14:15:20 UTC
Those bugs are being tracked at bug 210878 Thanks

*** This bug has been marked as a duplicate of bug 210878 ***