Bug 217089 - start of network-manager chrashes knetworkmanager
Summary: start of network-manager chrashes knetworkmanager
Status: RESOLVED DUPLICATE of bug 210878
Alias: None
Product: knetworkmanager
Classification: Miscellaneous
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Will Stephenson
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-12-02 17:15 UTC by Pascal d'Hermilly
Modified: 2009-12-02 20:25 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Pascal d'Hermilly 2009-12-02 17:15:03 UTC
Application that crashed: knetworkmanager
Version of the application: v0.9
KDE Version: 4.3.4 (KDE 4.3.4)
Qt Version: 4.5.2
Operating System: Linux 2.6.31-15-generic x86_64
Distribution: Ubuntu 9.10

What I was doing when the application crashed:
Knetworkmanaer chrashes when I start network-manager

 -- Backtrace:
Application: KNetworkManager (knetworkmanager), signal: Segmentation fault
[KCrash Handler]
#5  0x00007f1a781eec8a in Knm::Activatable::deviceUni() const () from /usr/lib/libknminternals.so.4
#6  0x00007f1a77fb5193 in ?? () from /usr/lib/libknmservice.so.4
#7  0x00007f1a77fb52b3 in ?? () from /usr/lib/libknmservice.so.4
#8  0x00007f1a77fb550e in ?? () from /usr/lib/libknmservice.so.4
#9  0x00007f1a77fb572c in SortedActivatableList::handleAdd(Knm::Activatable*) () from /usr/lib/libknmservice.so.4
#10 0x00007f1a77fa506b in ActivatableList::addActivatableInternal(Knm::Activatable*) () from /usr/lib/libknmservice.so.4
#11 0x00007f1a77fa85dd in WirelessNetworkInterfaceActivatableProvider::handleAdd(Knm::Connection*) () from /usr/lib/libknmservice.so.4
#12 0x00007f1a77fa6490 in NetworkInterfaceActivatableProvider::init() () from /usr/lib/libknmservice.so.4
#13 0x00007f1a77fa57d8 in NetworkInterfaceMonitor::networkInterfaceAdded(QString const&) () from /usr/lib/libknmservice.so.4
#14 0x00007f1a77f9f1fd in NetworkInterfaceMonitor::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libknmservice.so.4
#15 0x00007f1a76a05ddc in QMetaObject::activate (sender=0xc432f0, from_signal_index=<value optimized out>, to_signal_index=<value optimized out>, argv=0xba8eda) at kernel/qobject.cpp:3113
#16 0x00007f1a77b212c5 in Solid::Control::NetworkManager::Notifier::networkInterfaceAdded (this=0x7fff268f91d0, _t1=<value optimized out>) at ./networkmanager.moc:101
#17 0x00007f1a77b21c7c in Solid::Control::NetworkManagerPrivate::qt_metacall (this=0xc432f0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff268f9960)
    at ./networkmanager_p.moc:75
#18 0x00007f1a76a05ddc in QMetaObject::activate (sender=0xcab330, from_signal_index=<value optimized out>, to_signal_index=<value optimized out>, argv=0xba8eda) at kernel/qobject.cpp:3113
#19 0x00007f1a6a3f09c5 in NMNetworkManager::networkInterfaceAdded (this=0x7fff268f91d0, _t1=<value optimized out>) at ./manager.moc:128
#20 0x00007f1a6a3f1d84 in NMNetworkManager::deviceAdded (this=0xcab330, objpath=...) at ../../../solid/networkmanager-0.7/manager.cpp:199
#21 0x00007f1a6a3f4c39 in NMNetworkManager::qt_metacall (this=0xcab330, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff268f9b40) at ./manager.moc:105
#22 0x00007f1a76a05ddc in QMetaObject::activate (sender=0xba3d40, from_signal_index=<value optimized out>, to_signal_index=<value optimized out>, argv=0xba8eda) at kernel/qobject.cpp:3113
#23 0x00007f1a6a400282 in OrgFreedesktopNetworkManagerInterface::DeviceAdded (this=0x7fff268f91d0, _t1=<value optimized out>) at ./nm-manager-clientinterface.moc:149
#24 0x00007f1a6a4006ad in OrgFreedesktopNetworkManagerInterface::qt_metacall (this=0xba3d40, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff268f9fd0)
    at ./nm-manager-clientinterface.moc:96
#25 0x00007f1a76d07ad4 in QDBusConnectionPrivate::deliverCall (this=<value optimized out>, object=<value optimized out>, msg=<value optimized out>, metaTypes=..., slotIdx=<value optimized out>)
    at qdbusintegrator.cpp:891
#26 0x00007f1a76d0edef in QDBusCallDeliveryEvent::placeMetaCall(QObject*) () from /usr/lib/libQtDBus.so.4
#27 0x00007f1a76a000f9 in QObject::event (this=0xba3d40, e=0xd15700) at kernel/qobject.cpp:1111
#28 0x00007f1a770f4efc in QApplicationPrivate::notify_helper (this=0xb45c70, receiver=0xba3d40, e=0xd15700) at kernel/qapplication.cpp:4056
#29 0x00007f1a770fc1ce in QApplication::notify (this=0x7fff268fa970, receiver=0xba3d40, e=0xd15700) at kernel/qapplication.cpp:4021
#30 0x00007f1a7883fe56 in KApplication::notify (this=0x7fff268fa970, receiver=0xba3d40, event=0xd15700) at ../../kdeui/kernel/kapplication.cpp:302
#31 0x00007f1a769f0c2c in QCoreApplication::notifyInternal (this=0x7fff268fa970, receiver=0xba3d40, event=0xd15700) at kernel/qcoreapplication.cpp:610
#32 0x00007f1a769f180a in QCoreApplication::sendEvent (receiver=0x0, event_type=<value optimized out>, data=0xb204d0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:213
#33 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=<value optimized out>, data=0xb204d0) at kernel/qcoreapplication.cpp:1247
#34 0x00007f1a76a19533 in QCoreApplication::sendPostedEvents (s=<value optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#35 postEventSourceDispatch (s=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:210
#36 0x00007f1a72970bbe in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#37 0x00007f1a72974588 in ?? () from /lib/libglib-2.0.so.0
#38 0x00007f1a729746b0 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#39 0x00007f1a76a191a6 in QEventDispatcherGlib::processEvents (this=0xb1fd20, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:327
#40 0x00007f1a771894be in QGuiEventDispatcherGlib::processEvents (this=0x7fff268f91d0, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:202
#41 0x00007f1a769ef532 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#42 0x00007f1a769ef904 in QEventLoop::exec (this=0x7fff268fa8c0, flags=) at kernel/qeventloop.cpp:201
#43 0x00007f1a769f1ab9 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#44 0x000000000040d12f in _start ()

This bug may be a duplicate of or related to bug 215918

Reported using DrKonqi
Comment 1 Dario Andres 2009-12-02 20:25:57 UTC
This is reported at bug 210878. Thanks

*** This bug has been marked as a duplicate of bug 210878 ***