Bug 218206 - Starting the Nepomuk Semantic desktop pops up 12 error messages
Summary: Starting the Nepomuk Semantic desktop pops up 12 error messages
Status: RESOLVED DUPLICATE of bug 217111
Alias: None
Product: Akonadi
Classification: Frameworks and Libraries
Component: Nepomuk Feeder Agents (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Sebastian Trueg
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-12-11 00:21 UTC by Hans Bakker
Modified: 2010-02-22 22:35 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Hans Bakker 2009-12-11 00:21:29 UTC
Version:           1.0 (using 4.3.80 (KDE 4.3.80 (KDE 4.4 Beta1)), Kubuntu packages)
Compiler:          cc
OS:                Linux (i686) release 2.6.32-7-generic-pae

When enabling Nepomuk and Strigi from the System Settings on Kubuntu Lucid Lynx Alpha 1, 12 error messages pop up one after the other.

They are of two variants, both with the following general text:
"Nepomuk Indexing Agents Have Been Disabled
The Nepomuk service is not available or fully operational and attempts to rectify this have failed. Therefore indexing of all data stored in the Akonadi PIM service has been disabled, which will severely limit the capabilities of any application using this data.

The following problems were detected:"

Six message dialogs list this problem:
"Calling the Nepomuk storage service failed: 'Message did not receive a reply (timeout by message bus)'."

And the other six message dialogs list this problem:
"Nepomuk is not running."
Comment 1 Sebastian Trueg 2009-12-14 10:23:32 UTC
Changing the product to Akonadi for now since half of the dialogs come from Akonadi and I know about the issue now.
Comment 2 Thomas McGuire 2010-02-21 21:23:11 UTC
SVN commit 1093976 by tmcguire:

Disable the message box about Nepomuk not working.

I get at least one of those on every KDE startup, which is very annoying.
Please fix the race condition of this error message, Akonadi should start
Nepomuk properly (see bug 224668)

BUG: 218206
BUG: 217111



 M  +1 -1      nepomukfeederagentbase.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1093976
Comment 3 Thomas McGuire 2010-02-22 22:35:30 UTC

*** This bug has been marked as a duplicate of bug 217111 ***