Bug 217111 - Akonadi should open just one error dialog when Nepomuk is not running
Summary: Akonadi should open just one error dialog when Nepomuk is not running
Status: RESOLVED FIXED
Alias: None
Product: Akonadi
Classification: Frameworks and Libraries
Component: general (show other bugs)
Version: 4.3
Platform: Compiled Sources Unspecified
: NOR normal (vote)
Target Milestone: ---
Assignee: Volker Krause
URL:
Keywords:
: 218206 222218 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-12-02 20:40 UTC by Michal Vyskocil
Modified: 2010-02-23 09:18 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michal Vyskocil 2009-12-02 20:40:50 UTC
Version:            (using Devel)
Installed from:    Compiled sources

When I turn off Nepomuk (I'd like to switch from sesame2 to virtuoso Soprano backend), Akonadi shows up me several error dialogs tells me Nepomuk is not running. The one simple warning is enough.

BTW: And if it will use the new KDE's notification system, it'd be great.
Comment 1 Jakub 'Livio' Rusinek 2010-02-21 12:09:26 UTC
The same if you turn off Nepomuk completely - you get annoyed by messages regarding it.
Comment 2 Thomas McGuire 2010-02-21 21:23:11 UTC
SVN commit 1093976 by tmcguire:

Disable the message box about Nepomuk not working.

I get at least one of those on every KDE startup, which is very annoying.
Please fix the race condition of this error message, Akonadi should start
Nepomuk properly (see bug 224668)

BUG: 218206
BUG: 217111



 M  +1 -1      nepomukfeederagentbase.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1093976
Comment 3 Thomas McGuire 2010-02-22 22:35:30 UTC
*** Bug 218206 has been marked as a duplicate of this bug. ***
Comment 4 Thomas McGuire 2010-02-22 22:35:44 UTC
*** Bug 222218 has been marked as a duplicate of this bug. ***
Comment 5 Guido Pinkas 2010-02-23 09:18:37 UTC
Maybe warning messages like this could go into the Notification area, where it is not nearly as annoying.