Bug 217857 - Crash after copying and removing USB key
Summary: Crash after copying and removing USB key
Status: RESOLVED DUPLICATE of bug 211525
Alias: None
Product: dolphin
Classification: Applications
Component: general (show other bugs)
Version: 16.12.2
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Peter Penz
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-12-08 12:24 UTC by Daniel Anken
Modified: 2009-12-08 13:06 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel Anken 2009-12-08 12:24:04 UTC
Application that crashed: dolphin
Version of the application: 1.3
KDE Version: 4.3.3 (KDE 4.3.3)
Qt Version: 4.5.3
Operating System: Linux 2.6.31.6-145.fc12.x86_64 x86_64

What I was doing when the application crashed:
I had just ejected my USB key after having copied some files on the key, and was working on a splitted window (USB key and my home folder) when it crashed.

 -- Backtrace:
Application: Dolphin (dolphin), signal: Segmentation fault
82	T_PSEUDO (SYSCALL_SYMBOL, SYSCALL_NAME, SYSCALL_NARGS)
The current source language is "auto; currently asm".
[Current thread is 1 (Thread 0x7f3281053840 (LWP 1820))]

Thread 2 (Thread 0x7f327673d710 (LWP 2817)):
#0  pthread_cond_timedwait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:211
#1  0x0000003e97a134b1 in ?? () from /usr/lib64/libxine.so.1
#2  0x00000032c8606a3a in start_thread (arg=<value optimized out>) at pthread_create.c:297
#3  0x00000032c7eddf3d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#4  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f3281053840 (LWP 1820)):
[KCrash Handler]
#5  QUrl::QUrl (this=0x7fff335e62c0, other=...) at io/qurl.cpp:3936
#6  0x00000034364e3d99 in KUrl::KUrl(KUrl const&) () from /usr/lib64/libkdecore.so.5
#7  0x000000343ab37b70 in KFileItem::url() const () from /usr/lib64/libkio.so.5
#8  0x000000343ab26a54 in KDirModel::indexForItem(KFileItem const&) const () from /usr/lib64/libkio.so.5
#9  0x000000343b674a70 in KFilePreviewGenerator::Private::orderItems(KFileItemList&) () from /usr/lib64/libkfile.so.4
#10 0x000000343b678782 in KFilePreviewGenerator::Private::updateIcons(KFileItemList const&) () from /usr/lib64/libkfile.so.4
#11 0x000000343b6789df in KFilePreviewGenerator::Private::delayedIconUpdate() () from /usr/lib64/libkfile.so.4
#12 0x000000343b679a4d in KFilePreviewGenerator::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib64/libkfile.so.4
#13 0x0000003435b5408c in QMetaObject::activate (sender=0x2c8df80, from_signal_index=<value optimized out>, to_signal_index=<value optimized out>, argv=0x0) at kernel/qobject.cpp:3112
#14 0x0000003435b4e08e in QObject::event (this=0x2c8df80, e=0x7fff335e6ba0) at kernel/qobject.cpp:1074
#15 0x0000003436f8f65c in QApplicationPrivate::notify_helper (this=0x203a890, receiver=0x2c8df80, e=0x7fff335e6ba0) at kernel/qapplication.cpp:4065
#16 0x0000003436f968ce in QApplication::notify (this=<value optimized out>, receiver=0x2c8df80, e=0x7fff335e6ba0) at kernel/qapplication.cpp:4030
#17 0x0000003439c11a76 in KApplication::notify(QObject*, QEvent*) () from /usr/lib64/libkdeui.so.5
#18 0x0000003435b3ee6c in QCoreApplication::notifyInternal (this=0x7fff335e6ef0, receiver=0x2c8df80, event=0x7fff335e6ba0) at kernel/qcoreapplication.cpp:610
#19 0x0000003435b698d2 in sendEvent (event=<value optimized out>, receiver=<value optimized out>) at kernel/qcoreapplication.h:213
#20 QTimerInfoList::activateTimers (event=<value optimized out>, receiver=<value optimized out>) at kernel/qeventdispatcher_unix.cpp:580
#21 0x0000003435b6729d in timerSourceDispatch (source=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:165
#22 0x0000003430e3922e in g_main_dispatch (context=<value optimized out>) at gmain.c:1960
#23 IA__g_main_context_dispatch (context=<value optimized out>) at gmain.c:2513
#24 0x0000003430e3cc18 in g_main_context_iterate (context=0x2034120, block=<value optimized out>, dispatch=<value optimized out>, self=<value optimized out>) at gmain.c:2591
#25 0x0000003430e3cd3a in IA__g_main_context_iteration (context=0x2034120, may_block=1) at gmain.c:2654
#26 0x0000003435b671e6 in QEventDispatcherGlib::processEvents (this=0x200d7b0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:327
#27 0x0000003437021ffe in QGuiEventDispatcherGlib::processEvents (this=<value optimized out>, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:202
#28 0x0000003435b3d772 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#29 0x0000003435b3db44 in QEventLoop::exec (this=0x7fff335e6e40, flags=...) at kernel/qeventloop.cpp:201
#30 0x0000003435b3fcd9 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#31 0x0000000000437025 in _start ()

This bug may be a duplicate of or related to bug 213166

Reported using DrKonqi
Comment 1 Dario Andres 2009-12-08 13:06:31 UTC
Fixed recently. Thanks

*** This bug has been marked as a duplicate of bug 211525 ***