Bug 213166 - Dolphin, USB Stick, Unmounting after copying
Summary: Dolphin, USB Stick, Unmounting after copying
Status: RESOLVED DUPLICATE of bug 211525
Alias: None
Product: dolphin
Classification: Applications
Component: general (show other bugs)
Version: 16.12.2
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Peter Penz
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-11-05 00:06 UTC by Glenn
Modified: 2009-11-05 15:14 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Glenn 2009-11-05 00:06:16 UTC
Application that crashed: dolphin
Version of the application: 1.3
KDE Version: 4.3.2 (KDE 4.3.2)
Qt Version: 4.5.2
Operating System: Linux 2.6.31-14-generic x86_64
Distribution: Ubuntu 9.10

What I was doing when the application crashed:
Dolphin crashed after unmounting a usb stick after copying files to it.  If i unmount as soon as the copy finishes dolphin crashes, however if i wait 30 seconds after copy complete it does not crash,

 -- Backtrace:
Application: Dolphin (dolphin), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f927e08d750 (LWP 3012))]

Thread 2 (Thread 0x7f9267e79910 (LWP 3026)):
#0  0x00007f927634382d in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#1  0x00007f926d2f2c91 in ?? () from /usr/lib/libxine.so.1
#2  0x00007f927633ea04 in start_thread () from /lib/libpthread.so.0
#3  0x00007f927a38d7bd in clone () from /lib/libc.so.6
#4  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f927e08d750 (LWP 3012)):
[KCrash Handler]
#5  0x00007f927aa28720 in QUrl::QUrl(QUrl const&) () from /usr/lib/libQtCore.so.4
#6  0x00007f927bc76fc9 in KUrl::KUrl(KUrl const&) () from /usr/lib/libkdecore.so.5
#7  0x00007f927db1fec0 in KFileItem::url() const () from /usr/lib/libkio.so.5
#8  0x00007f927db106e4 in KDirModel::indexForItem(KFileItem const&) const () from /usr/lib/libkio.so.5
#9  0x00007f927d7b4920 in KFilePreviewGenerator::Private::orderItems(KFileItemList&) () from /usr/lib/libkfile.so.4
#10 0x00007f927d7b8622 in KFilePreviewGenerator::Private::updateIcons(KFileItemList const&) () from /usr/lib/libkfile.so.4
#11 0x00007f927d7b887f in KFilePreviewGenerator::Private::delayedIconUpdate() () from /usr/lib/libkfile.so.4
#12 0x00007f927d7b98f5 in KFilePreviewGenerator::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libkfile.so.4
#13 0x00007f927aa86ddc in QMetaObject::activate(QObject*, int, int, void**) () from /usr/lib/libQtCore.so.4
#14 0x00007f927aa80d83 in QObject::event(QEvent*) () from /usr/lib/libQtCore.so.4
#15 0x00007f927af04efc in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#16 0x00007f927af0c1ce in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#17 0x00007f927c239ab6 in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#18 0x00007f927aa71c2c in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#19 0x00007f927aa9c862 in ?? () from /usr/lib/libQtCore.so.4
#20 0x00007f927aa9a25d in ?? () from /usr/lib/libQtCore.so.4
#21 0x00007f927658fbbe in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#22 0x00007f9276593588 in ?? () from /lib/libglib-2.0.so.0
#23 0x00007f92765936b0 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#24 0x00007f927aa9a1a6 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#25 0x00007f927af994be in ?? () from /usr/lib/libQtGui.so.4
#26 0x00007f927aa70532 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#27 0x00007f927aa70904 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#28 0x00007f927aa72ab9 in QCoreApplication::exec() () from /usr/lib/libQtCore.so.4
#29 0x0000000000439555 in _start ()

This bug may be a duplicate of or related to bug 202464

Reported using DrKonqi
Comment 1 Dario Andres 2009-11-05 15:14:56 UTC
Merging with bug 211525. Thanks

*** This bug has been marked as a duplicate of bug 211525 ***