Bug 217617 - Plasma-desktop and kded4 crash on startup. No desktop at all
Summary: Plasma-desktop and kded4 crash on startup. No desktop at all
Status: RESOLVED DUPLICATE of bug 217425
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-12-06 18:40 UTC by felix
Modified: 2009-12-06 19:13 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description felix 2009-12-06 18:40:56 UTC
Version:            (using KDE 4.3.4)
OS:                Linux
Installed from:    Ubuntu Packages

Application that crashed: kded4
Version of the application: $Id: kded.cpp 1031638 2009-10-05 16:59:11Z lunakl $
KDE Version: 4.3.3 (KDE 4.3.3)
Qt Version: 4.6.0
Operating System: Linux 2.6.32-6-generic x86_64
Distribution: Ubuntu lucid (development branch)

What I was doing when the application crashed:
Crashes everytime  i start my KDE- Desktop. Crashing programs are kded4 and plasma-desktop. I still can use ALT+F2 to run programs but there is no taskbar (i think no plasma at all).

Happens on Kubuntu Lucid Lynx, all recent updates applied.

 -- Backtrace:
Application: KDE-Dienst (kdeinit4), signal: Segmentation fault
The current source language is "auto; currently c".
[KCrash Handler]
#5  qNumVariantToHelper<double> (this=0x0, ok=0x0) at kernel/qvariant.cpp:2361
#6  QVariant::toDouble (this=0x0, ok=0x0) at kernel/qvariant.cpp:2475
#7  0x00007f80d1470168 in HalPower::brightness (this=<value optimized out>, device=<value optimized out>) at ../../../solid/hal/halpower.cpp:396
#8  0x00007f80d1adbdcc in Solid::Control::PowerManager::brightness (device=<value optimized out>) at ../../../../libs/solid/control/powermanager.cpp:205
#9  0x00007f80d1adc341 in Solid::Control::PowerManager::setBrightness (brightness=<value optimized out>, device=<value optimized out>) at ../../../../libs/solid/control/powermanager.cpp:180
#10 0x00007f80d1d38f65 in PowerDevilDaemon::applyProfile (this=0x163ad10) at ../../../powerdevil/daemon/PowerDevilDaemon.cpp:486
#11 0x00007f80d1d39519 in PowerDevilDaemon::acAdapterStateChanged (this=0x163ad10, state=2, forced=160) at ../../../powerdevil/daemon/PowerDevilDaemon.cpp:459
#12 0x00007f80d1d3c3f5 in PowerDevilDaemon (this=0x163ad10, parent=<value optimized out>) at ../../../powerdevil/daemon/PowerDevilDaemon.cpp:246
#13 0x00007f80d1d41637 in KPluginFactory::createInstance<PowerDevilDaemon, QObject> (parentWidget=<value optimized out>, parent=<value optimized out>, args=...)
    at /usr/include/KDE/../kpluginfactory.h:461
#14 0x00007f80e3d8549c in KPluginFactory::create (this=0x1641300, iface=0x7f80e3dca720 "KDEDModule", parentWidget=<value optimized out>, parent=0x14f86c0, args=..., keyword=<value optimized out>)
    at ../../kdecore/util/kpluginfactory.cpp:191
#15 0x00007f80d7a07b55 in KPluginFactory::create<KDEDModule> (this=0x14f86c0, s=<value optimized out>, onDemand=<value optimized out>) at ../../kdecore/util/kpluginfactory.h:491
#16 Kded::loadModule (this=0x14f86c0, s=<value optimized out>, onDemand=<value optimized out>) at ../../kded/kded.cpp:380
#17 0x00007f80d7a09295 in Kded::initModules (this=0x14f86c0) at ../../kded/kded.cpp:238
#18 0x00007f80d7a0b190 in KDEDApplication::newInstance (this=<value optimized out>) at ../../kded/kded.cpp:860
#19 0x00007f80e2d475a6 in KUniqueApplicationAdaptor::newInstance (this=0x16090d0, asn_id=<value optimized out>, args=...) at ../../kdeui/kernel/kuniqueapplication.cpp:459
#20 0x00007f80e2d47be6 in KUniqueApplicationAdaptor::qt_metacall (this=0x16090d0, _c=QMetaObject::InvokeMetaMethod, _id=-491956576, _a=0x7fff7e668cb0) at ./kuniqueapplication_p.moc:81
#21 0x00007f80e00ec276 in QDBusConnectionPrivate::deliverCall (this=<value optimized out>, object=<value optimized out>, msg=<value optimized out>, metaTypes=..., slotIdx=<value optimized out>)
    at qdbusintegrator.cpp:904
#22 0x00007f80e00ed57f in QDBusConnectionPrivate::activateCall (this=<value optimized out>, object=0x16090d0, flags=337, msg=...) at qdbusintegrator.cpp:809
#23 0x00007f80e00ee05d in QDBusConnectionPrivate::activateObject (this=<value optimized out>, node=<value optimized out>, msg=..., pathStartPos=<value optimized out>) at qdbusintegrator.cpp:1368
#24 0x00007f80e00ee2f8 in QDBusActivateObjectEvent::placeMetaCall (this=0x1618060) at qdbusintegrator.cpp:1481
#25 0x00007f80e4191789 in QObject::event (this=0x7fff7e669a50, e=0x1618060) at kernel/qobject.cpp:1260
#26 0x00007f80e204f3fd in QApplication::event (this=0x7fff7e669a50, e=0x1618060) at kernel/qapplication.cpp:2344
#27 0x00007f80e204af2c in QApplicationPrivate::notify_helper (this=0x14f9430, receiver=0x7fff7e669a50, e=0x1618060) at kernel/qapplication.cpp:4242
#28 0x00007f80e205153d in QApplication::notify (this=0x7fff7e669a50, receiver=0x7fff7e669a50, e=0x1618060) at kernel/qapplication.cpp:4125
#29 0x00007f80e2d403e6 in KApplication::notify (this=0x7fff7e669a50, receiver=0x7fff7e669a50, event=0x1618060) at ../../kdeui/kernel/kapplication.cpp:302
#30 0x00007f80e4181abc in QCoreApplication::notifyInternal (this=0x7fff7e669a50, receiver=0x7fff7e669a50, event=0x1618060) at kernel/qcoreapplication.cpp:704
#31 0x00007f80e4184237 in QCoreApplication::sendEvent (receiver=0x0, event_type=<value optimized out>, data=0x1478140) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#32 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=<value optimized out>, data=0x1478140) at kernel/qcoreapplication.cpp:1345
#33 0x00007f80e41ab513 in QCoreApplication::sendPostedEvents (s=<value optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#34 postEventSourceDispatch (s=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:276
#35 0x00007f80e0b3cd4e in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#36 0x00007f80e0b40718 in ?? () from /lib/libglib-2.0.so.0
#37 0x00007f80e0b40840 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#38 0x00007f80e41ab053 in QEventDispatcherGlib::processEvents (this=0x1479740, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:407
#39 0x00007f80e20f93de in QGuiEventDispatcherGlib::processEvents (this=0x0, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:202
#40 0x00007f80e41803e2 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#41 0x00007f80e41807bc in QEventLoop::exec (this=0x7fff7e6699a0, flags=) at kernel/qeventloop.cpp:201
#42 0x00007f80e41844fb in QCoreApplication::exec () at kernel/qcoreapplication.cpp:981
#43 0x00007f80d7a09db7 in kdemain (argc=<value optimized out>, argv=<value optimized out>) at ../../kded/kded.cpp:936
#44 0x0000000000406da8 in launch (argc=1, _name=<value optimized out>, args=<value optimized out>, cwd=<value optimized out>, envc=0, envs=<value optimized out>, reset_env=false, tty=0x0, 
    avoid_loops=false, startup_id_str=0x40a279 "0") at ../../kinit/kinit.cpp:677
#45 0x0000000000408cc0 in main (argc=<value optimized out>, argv=<value optimized out>, envp=<value optimized out>) at ../../kinit/kinit.cpp:1740

An https://bugs.kde.org berichten
Comment 1 Dario Andres 2009-12-06 18:53:25 UTC
- What is your HAL version ? 
This is probably bug 217316. Thanks
Comment 2 Maciej Mrozowski 2009-12-06 19:04:46 UTC
Yes, that's most likely duplicate.
Comment 3 felix 2009-12-06 19:09:01 UTC
hal: 0.5.14-0ubuntu1

there is no 0.5.13 version availabe in ubuntu repos to downgrade.
Comment 4 Dario Andres 2009-12-06 19:10:00 UTC
Yes, it is the same. Merging

*** This bug has been marked as a duplicate of bug 217316 ***
Comment 5 Beat Wolf 2009-12-06 19:13:53 UTC

*** This bug has been marked as a duplicate of bug 217425 ***