Bug 217127 - Segmentation fault while browsing a samba share
Summary: Segmentation fault while browsing a samba share
Status: RESOLVED DUPLICATE of bug 211525
Alias: None
Product: dolphin
Classification: Applications
Component: general (show other bugs)
Version: 16.12.2
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Peter Penz
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-12-02 22:44 UTC by Nicolas Galler
Modified: 2009-12-04 00:43 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Nicolas Galler 2009-12-02 22:44:30 UTC
Application that crashed: dolphin
Version of the application: 1.3
KDE Version: 4.3.2 (KDE 4.3.2)
Qt Version: 4.5.2
Operating System: Linux 2.6.31-14-generic x86_64
Distribution: Ubuntu 9.10

What I was doing when the application crashed:
I was editing some file on a samba share (accessed via smb://....).  The crash occurred when I hit backspace (to go up)

 -- Backtrace:
Application: Dolphin (dolphin), signal: Segmentation fault
The current source language is "auto; currently c".
[KCrash Handler]
#5  QUrl (this=0x7fff7a5fba20, other=...) at io/qurl.cpp:3936
#6  0x00007f081832bfc9 in KUrl (this=0x7fff7a5fba20, _u=...) at ../../kdecore/io/kurl.cpp:468
#7  0x00007f081a1d4ec0 in KFileItem::url (this=<value optimized out>) at ../../kio/kio/kfileitem.cpp:1271
#8  0x00007f081a1c56e4 in KDirModel::indexForItem (this=0xa22df0, item=...) at ../../kio/kio/kdirmodel.cpp:919
#9  0x00007f0819e69920 in KFilePreviewGenerator::Private::orderItems (this=0xa0b620, items=...) at ../../kfile/kfilepreviewgenerator.cpp:1023
#10 0x00007f0819e6d622 in KFilePreviewGenerator::Private::updateIcons (this=0xa0b620, items=...) at ../../kfile/kfilepreviewgenerator.cpp:508
#11 0x00007f0819e6d87f in KFilePreviewGenerator::Private::delayedIconUpdate (this=0xa0b620) at ../../kfile/kfilepreviewgenerator.cpp:1088
#12 0x00007f0819e6e8f5 in KFilePreviewGenerator::qt_metacall (this=0xa0b420, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff7a5fbd00) at ./kfilepreviewgenerator.moc:95
#13 0x00007f081713bddc in QMetaObject::activate (sender=0xa0b5f0, from_signal_index=<value optimized out>, to_signal_index=<value optimized out>, argv=0x2e9) at kernel/qobject.cpp:3113
#14 0x00007f0817135d83 in QObject::event (this=0xa0b5f0, e=0x10) at kernel/qobject.cpp:1075
#15 0x00007f08175b9efc in QApplicationPrivate::notify_helper (this=0x75e190, receiver=0xa0b5f0, e=0x7fff7a5fc300) at kernel/qapplication.cpp:4056
#16 0x00007f08175c11ce in QApplication::notify (this=0x7fff7a5fc650, receiver=0xa0b5f0, e=0x7fff7a5fc300) at kernel/qapplication.cpp:4021
#17 0x00007f08188eeab6 in KApplication::notify (this=0x7fff7a5fc650, receiver=0xa0b5f0, event=0x7fff7a5fc300) at ../../kdeui/kernel/kapplication.cpp:302
#18 0x00007f0817126c2c in QCoreApplication::notifyInternal (this=0x7fff7a5fc650, receiver=0xa0b5f0, event=0x7fff7a5fc300) at kernel/qcoreapplication.cpp:610
#19 0x00007f0817151862 in QCoreApplication::sendEvent (this=0x755f50) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:213
#20 QTimerInfoList::activateTimers (this=0x755f50) at kernel/qeventdispatcher_unix.cpp:572
#21 0x00007f081714f25d in timerSourceDispatch (source=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:165
#22 0x00007f0812c44bbe in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#23 0x00007f0812c48588 in ?? () from /lib/libglib-2.0.so.0
#24 0x00007f0812c486b0 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#25 0x00007f081714f1a6 in QEventDispatcherGlib::processEvents (this=0x72fd20, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:327
#26 0x00007f081764e4be in QGuiEventDispatcherGlib::processEvents (this=0x7fff7a5fba20, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:202
#27 0x00007f0817125532 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#28 0x00007f0817125904 in QEventLoop::exec (this=0x7fff7a5fc5a0, flags=) at kernel/qeventloop.cpp:201
#29 0x00007f0817127ab9 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#30 0x0000000000439555 in main (argc=<value optimized out>, argv=<value optimized out>) at ../../../../apps/dolphin/src/main.cpp:94

This bug may be a duplicate of or related to bug 216943

Reported using DrKonqi
Comment 1 Dario Andres 2009-12-04 00:43:24 UTC
Fixed in KDE SC 4.4 Thanks

*** This bug has been marked as a duplicate of bug 211525 ***