Bug 216943 - Crash while renaming a file over samba
Summary: Crash while renaming a file over samba
Status: RESOLVED DUPLICATE of bug 211525
Alias: None
Product: dolphin
Classification: Applications
Component: general (show other bugs)
Version: 16.12.2
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Peter Penz
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-12-01 14:58 UTC by Rado
Modified: 2009-12-18 11:09 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rado 2009-12-01 14:58:40 UTC
Application that crashed: dolphin
Version of the application: 1.3
KDE Version: 4.3.3 (KDE 4.3.3)
Qt Version: 4.5.3
Operating System: Linux 2.6.31.6-145.fc12.x86_64 x86_64

What I was doing when the application crashed:
I tried to rename a file over samba; it crashed after typing Enter

 -- Backtrace:
Application: Dolphin (dolphin), signal: Segmentation fault
82	T_PSEUDO (SYSCALL_SYMBOL, SYSCALL_NAME, SYSCALL_NARGS)
The current source language is "auto; currently asm".
[KCrash Handler]
#5  QUrl::QUrl (this=0x7fff912f1af0, other=...) at io/qurl.cpp:3936
#6  0x0000003e67ae3d99 in KUrl::KUrl (this=0x7fff912f1af0, _u=<value optimized out>) at /usr/src/debug/kdelibs-4.3.3/kdecore/io/kurl.cpp:468
#7  0x0000003e9f137b70 in KFileItem::url (this=<value optimized out>) at /usr/src/debug/kdelibs-4.3.3/kio/kio/kfileitem.cpp:1271
#8  0x0000003e9f126a54 in KDirModel::indexForItem (this=0x221b600, item=<value optimized out>) at /usr/src/debug/kdelibs-4.3.3/kio/kio/kdirmodel.cpp:919
#9  0x0000003ea0274a70 in KFilePreviewGenerator::Private::orderItems (this=0x2291bd0, items=...) at /usr/src/debug/kdelibs-4.3.3/kfile/kfilepreviewgenerator.cpp:1023
#10 0x0000003ea0278782 in KFilePreviewGenerator::Private::updateIcons (this=0x2291bd0, items=...) at /usr/src/debug/kdelibs-4.3.3/kfile/kfilepreviewgenerator.cpp:508
#11 0x0000003ea02793f5 in KFilePreviewGenerator::Private::updateIcons (this=0x2291bd0, topLeft=<value optimized out>, bottomRight=...)
    at /usr/src/debug/kdelibs-4.3.3/kfile/kfilepreviewgenerator.cpp:555
#12 0x0000003ea0279ac7 in KFilePreviewGenerator::qt_metacall (this=0x2291a60, _c=InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff912f1e80)
    at /usr/src/debug/kdelibs-4.3.3/x86_64-redhat-linux-gnu/kfile/kfilepreviewgenerator.moc:86
#13 0x00000038db15408c in QMetaObject::activate (sender=0x221b600, from_signal_index=<value optimized out>, to_signal_index=<value optimized out>, argv=0x7fff912f1e80) at kernel/qobject.cpp:3112
#14 0x00000038db189657 in QAbstractItemModel::dataChanged (this=<value optimized out>, _t1=<value optimized out>, _t2=) at .moc/release-shared/moc_qabstractitemmodel.cpp:126
#15 0x0000003e9f126114 in KDirModelPrivate::_k_slotRefreshItems (this=0x2222930, items=<value optimized out>) at /usr/src/debug/kdelibs-4.3.3/kio/kio/kdirmodel.cpp:571
#16 0x0000003e9f127eca in KDirModel::qt_metacall (this=0x221b600, _c=InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff912f21d0)
    at /usr/src/debug/kdelibs-4.3.3/x86_64-redhat-linux-gnu/kio/kdirmodel.moc:84
#17 0x00000038db15408c in QMetaObject::activate (sender=0x221b470, from_signal_index=<value optimized out>, to_signal_index=<value optimized out>, argv=0x7fff912f21d0) at kernel/qobject.cpp:3112
#18 0x0000003e9f10bca5 in KDirLister::refreshItems (this=<value optimized out>, _t1=<value optimized out>) at /usr/src/debug/kdelibs-4.3.3/x86_64-redhat-linux-gnu/kio/kdirlister.moc:296
#19 0x0000003e9f10cbab in KDirLister::Private::emitItems (this=0x221b490) at /usr/src/debug/kdelibs-4.3.3/kio/kio/kdirlister.cpp:2317
#20 0x0000003e9f118c20 in KDirListerCache::renameDir (this=<value optimized out>, oldUrl=<value optimized out>, newUrl=<value optimized out>)
    at /usr/src/debug/kdelibs-4.3.3/kio/kio/kdirlister.cpp:1412
#21 0x0000003e9f11de88 in KDirListerCache::slotFileRenamed (this=0x1f7e0d0, _src=<value optimized out>, _dst=...) at /usr/src/debug/kdelibs-4.3.3/kio/kio/kdirlister.cpp:891
#22 0x0000003e9f11e1d4 in KDirListerCache::qt_metacall (this=0x1f7e0d0, _c=InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff912f28e0)
    at /usr/src/debug/kdelibs-4.3.3/x86_64-redhat-linux-gnu/kio/kdirlister_p.moc:94
#23 0x00000038db15408c in QMetaObject::activate (sender=0x1f822f0, from_signal_index=<value optimized out>, to_signal_index=<value optimized out>, argv=0x7fff912f28e0) at kernel/qobject.cpp:3112
#24 0x0000003e9f129527 in OrgKdeKDirNotifyInterface::FileRenamed (this=<value optimized out>, _t1=<value optimized out>, _t2=)
    at /usr/src/debug/kdelibs-4.3.3/x86_64-redhat-linux-gnu/kio/kdirnotify.moc:97
#25 0x0000003e9f129654 in OrgKdeKDirNotifyInterface::qt_metacall (this=0x1f822f0, _c=InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff912f2bb0)
    at /usr/src/debug/kdelibs-4.3.3/x86_64-redhat-linux-gnu/kio/kdirnotify.moc:79
#26 0x00000038db622e84 in QDBusConnectionPrivate::deliverCall (this=<value optimized out>, object=<value optimized out>, msg=<value optimized out>, metaTypes=..., slotIdx=<value optimized out>)
    at qdbusintegrator.cpp:891
#27 0x00000038db62a61f in QDBusCallDeliveryEvent::placeMetaCall(QObject*) () from /usr/lib64/libQtDBus.so.4
#28 0x00000038db14e401 in QObject::event (this=0x1f822f0, e=0x21e2fe0) at kernel/qobject.cpp:1110
#29 0x0000003e9d98f65c in QApplicationPrivate::notify_helper (this=0x1e4ae40, receiver=0x1f822f0, e=0x21e2fe0) at kernel/qapplication.cpp:4065
#30 0x0000003e9d9968ce in QApplication::notify (this=<value optimized out>, receiver=0x1f822f0, e=0x21e2fe0) at kernel/qapplication.cpp:4030
#31 0x0000003e9e611a76 in KApplication::notify (this=0x7fff912f3550, receiver=0x1f822f0, event=0x21e2fe0) at /usr/src/debug/kdelibs-4.3.3/kdeui/kernel/kapplication.cpp:302
#32 0x00000038db13ee6c in QCoreApplication::notifyInternal (this=0x7fff912f3550, receiver=0x1f822f0, event=0x21e2fe0) at kernel/qcoreapplication.cpp:610
#33 0x00000038db13fa42 in sendEvent (event=<value optimized out>, receiver=<value optimized out>) at kernel/qcoreapplication.h:213
#34 QCoreApplicationPrivate::sendPostedEvents (event=<value optimized out>, receiver=<value optimized out>) at kernel/qcoreapplication.cpp:1247
#35 0x00000038db167573 in sendPostedEvents () at kernel/qcoreapplication.h:218
#36 postEventSourceDispatch () at kernel/qeventdispatcher_glib.cpp:210
#37 0x0000003ba9e3922e in g_main_context_dispatch () from /lib64/libglib-2.0.so.0
#38 0x0000003ba9e3cc18 in ?? () from /lib64/libglib-2.0.so.0
#39 0x0000003ba9e3cd3a in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#40 0x00000038db1671e6 in QEventDispatcherGlib::processEvents (this=0x1e207b0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:327
#41 0x0000003e9da21ffe in QGuiEventDispatcherGlib::processEvents (this=<value optimized out>, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:202
#42 0x00000038db13d772 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#43 0x00000038db13db44 in QEventLoop::exec (this=0x7fff912f34a0, flags=...) at kernel/qeventloop.cpp:201
#44 0x00000038db13fcd9 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#45 0x0000000000437025 in _start ()

Reported using DrKonqi
Comment 1 Frank Reininghaus 2009-12-01 17:46:55 UTC
Thanks for the bug report! It looks like the file you've renamed was in KFilePreviewGenerator's list of recently modified files. The file item in this list became invalid after the rename, and accessing it caused a crash.

This is similar to bug 211525, but maybe not exactly a duplicate, because the item is renamed and not removed in your case. Maybe we also have to listen to KDirModel's dataChanged(const QModelIndex&, const QModelIndex&) signal to fix this...
Comment 2 Rado 2009-12-01 18:06:22 UTC
Thanks for the quick response. Actually it was a directory and i believe that I have never accessed it since I installed the new OS (Fedora 12)...

---------------------------
The received letter on Tuesday 01 of December 2009 was:
From: Frank Reininghaus <frank78ac@googlemail.com>
To: rado.kljucevsek@ksec.si
Cc: 
Subject: [Bug 216943] Crash while renaming a file over samba

https://bugs.kde.org/show_bug.cgi?id=216943


Frank Reininghaus <frank78ac@googlemail.com> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 CC|                            |frank78ac@googlemail.com




--- Comment #1 from Frank Reininghaus <frank78ac googlemail com>  2009-12-01 17:46:55 ---
Thanks for the bug report! It looks like the file you've renamed was in
KFilePreviewGenerator's list of recently modified files. The file item in this
list became invalid after the rename, and accessing it caused a crash.

This is similar to bug 211525, but maybe not exactly a duplicate, because the
item is renamed and not removed in your case. Maybe we also have to listen to
KDirModel's dataChanged(const QModelIndex&, const QModelIndex&) signal to fix
this...
Comment 3 Peter Penz 2009-12-18 11:09:09 UTC

*** This bug has been marked as a duplicate of bug 211525 ***