Bug 216857 - KWin global shortcuts do not work after login
Summary: KWin global shortcuts do not work after login
Status: RESOLVED UPSTREAM
Alias: None
Product: kwin
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Unspecified
: VHI normal with 1 vote (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
: 217457 217590 217657 217697 217774 219717 220777 221222 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-11-30 21:06 UTC by András Manţia
Modified: 2010-01-04 12:14 UTC (History)
16 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description András Manţia 2009-11-30 21:06:02 UTC
Version:            (using Devel)
Installed from:    Compiled sources

Recently with trunk I noticed the following behavior: alt-tab, alt-shift-tab doesn't work after login. Actually none of the kwin global shortcuts work. killall kwin;kwin solves the problem, that's why I opened the report against kwin.
Comment 1 Martin Flöser 2009-11-30 21:10:48 UTC
this is a problem reported quite often recently.

You can use kwin --replace instead of killing kwin btw
Comment 2 Andreas Pakulat 2009-11-30 21:50:24 UTC
I also have this here, I posted to the kwin mailinglist on the weekend, see http://lists.kde.org/?t=125934817000001&r=1&w=2

It seems to be fixed by some patch applied to kde-qt's master/4.6-patched as I can't reproduce it with kde-qt instead of official qt here.
Comment 3 Martin Flöser 2009-12-05 17:27:46 UTC
*** Bug 217457 has been marked as a duplicate of this bug. ***
Comment 4 Martin Flöser 2009-12-06 15:03:10 UTC
*** Bug 217590 has been marked as a duplicate of this bug. ***
Comment 5 Thomas Lübking 2009-12-07 00:17:54 UTC
*** Bug 217657 has been marked as a duplicate of this bug. ***
Comment 6 thomas coopman 2009-12-07 14:27:23 UTC
I have this problem also with opensuse kde4 unstable repo.
Comment 7 Ben Kevan 2009-12-07 19:49:54 UTC
I also experience, and can confirm that reloading kwin with killall kwin;kwin fixes the issue for the logged on sessoin.
Comment 8 Thomas Lübking 2009-12-07 22:12:15 UTC
*** Bug 217774 has been marked as a duplicate of this bug. ***
Comment 9 Stefan Majewsky 2009-12-09 00:48:45 UTC
I can confirm. My KWin comes from the openSUSE 11.2 package kwin-4.3.81svn1058695-3.2.i586.
Comment 10 Matthias Dahl 2009-12-10 10:45:51 UTC
The bug is also present w/ KDE 4.3.4 and Qt 4.6.0 (todays nokia trunk). The bug surfaced sometime during the last 2-3 weeks. Possibly w/ KDE 4.3.4 but I am unsure about that. I have been running regular Qt 4.6 checkouts for quite a while now (at least 2 month) and just now ran into this problem.

System is an up2date Gentoo ~amd64 (gcc 4.4.2, ...).
Comment 11 Andreas Pakulat 2009-12-10 12:58:16 UTC
(In reply to comment #10)
> The bug is also present w/ KDE 4.3.4 and Qt 4.6.0 (todays nokia trunk). The bug
> surfaced sometime during the last 2-3 weeks. Possibly w/ KDE 4.3.4 but I am

The bug is IMHO caused by Qt4.6, as I said above I can even avoid it by switching from official Qt to the kde-qt repositories master.
Comment 12 András Manţia 2009-12-10 13:11:14 UTC
Thiago wrote on IRC that this is a bug in Qt 4.6+, that is, it should not be present in 4.6.0 as released, but it is in 4.6 branch. I couldn't confirm this, as I didn't test with 4.6.0.
Comment 13 Andreas Pakulat 2009-12-10 15:13:09 UTC
I've had this with 4.6 branch before 4.6.0 was tagged (and with a commit _after_ 4.6rc1). But I'll double-check later tonight with the 4.6.0 tag to be 100% sure.
Comment 14 Andreas Pakulat 2009-12-11 09:08:47 UTC
(In reply to comment #13)
> I've had this with 4.6 branch before 4.6.0 was tagged (and with a commit
> _after_ 4.6rc1). But I'll double-check later tonight with the 4.6.0 tag to be
> 100% sure.

Apparantly the 4.6 branch I've used was already 'newer' than the 4.6.0 tag... So I can confirm Thiago's conclusion, 4.6.0 doesn't have the problem but 4.6 branch has.

From that I'd think its a Qt problem, so the bugreport could be closed as UPSTREAM...
Comment 15 Martin Flöser 2009-12-11 09:14:04 UTC
(In reply to comment #14)
> From that I'd think its a Qt problem, so the bugreport could be closed as
> UPSTREAM...
agreed
Comment 16 Will Stephenson 2009-12-11 11:13:42 UTC
openSUSE users seeing this bug should disable the Qt:46 repo (that has a post-4.6.0 snapshot) and make sure the 4.6.0 libqt4 packages from KDE:KDE4:Factory:Desktop are installed instead.
Comment 17 Matthias Dahl 2009-12-11 11:25:14 UTC
Is there an official open bug report w/ the Qt bug tracker and is the cause of this Qt regression already known (git bisected)?
Comment 18 Marco Martin 2009-12-12 17:37:15 UTC
*** Bug 217697 has been marked as a duplicate of this bug. ***
Comment 19 Blackpaw 2009-12-21 12:11:44 UTC
Still seeing this bug and I have Qt 4.6.1

 kde4-config --version
Qt: 4.6.1
KDE Development Platform: 4.3.85 (KDE 4.3.85 (KDE 4.4 Beta2)) "release 3"
kde4-config: 1.0
Comment 20 Martin Flöser 2009-12-22 19:33:07 UTC
*** Bug 219717 has been marked as a duplicate of this bug. ***
Comment 21 Arkadiusz Miskiewicz 2009-12-23 22:44:05 UTC
Martin Gräßlin: you resolved it as fixed upstream. Do you know which commit actually fixes this?
Comment 22 Martin Flöser 2009-12-23 22:57:16 UTC
(In reply to comment #21)
> Martin Gräßlin: you resolved it as fixed upstream. Do you know which commit
> actually fixes this?
the meaning of RESOLVED UPSTREAM is that it is not a bug in this application but in an upstream application kwin depends on - in this case Qt. It does not imply that there is a fix for it.
Comment 23 Arkadiusz Miskiewicz 2009-12-25 23:08:17 UTC
thiago said on irc that the fix for http://bugreports.qt.nokia.com/browse/QTBUG-5979 caused shortcut regression
Comment 24 lucas 2009-12-31 13:25:07 UTC
*** Bug 220777 has been marked as a duplicate of this bug. ***
Comment 25 Martin Flöser 2010-01-04 12:14:12 UTC
*** Bug 221222 has been marked as a duplicate of this bug. ***