Bug 215902 - Organize files function missing
Summary: Organize files function missing
Status: RESOLVED FIXED
Alias: None
Product: amarok
Classification: Applications
Component: general (show other bugs)
Version: 2.2.1
Platform: Ubuntu Linux
: NOR wishlist with 20 votes (vote)
Target Milestone: ---
Assignee: Amarok Developers
URL:
Keywords:
: 222085 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-11-23 23:34 UTC by Heddy Boubaker
Modified: 2010-02-27 03:13 UTC (History)
6 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Heddy Boubaker 2009-11-23 23:34:30 UTC
Version:           2.2.1 (using KDE 4.3.3)
OS:                Linux
Installed from:    Ubuntu Packages

The useful function Organize files disapeared in 2.2.1
Comment 1 Myriam Schweingruber 2009-11-24 00:26:48 UTC
We removed it deliberately, since it caused problems and data loss for quite a few users. It will come back once the worst bugs are eliminated.
Comment 2 Heddy Boubaker 2009-11-24 00:29:26 UTC
(In reply to comment #1)
> We removed it deliberately, since it caused problems and data loss for quite a
> few users. It will come back once the worst bugs are eliminated.

Thanks for answer.

But this should had been notified in the Release Notes.
Comment 3 Alexander Kandaurov 2009-12-06 14:41:31 UTC
(In reply to comment #1)
> We removed it deliberately, since it caused problems and data loss for quite a
> few users. It will come back once the worst bugs are eliminated.

Why then it is still accessible through the drag'n'drop menu?
Comment 4 Casey Link 2010-02-07 17:25:13 UTC
Resolved. The Organize feature is back.
Comment 5 Casey Link 2010-02-07 17:28:36 UTC
*** Bug 222085 has been marked as a duplicate of this bug. ***
Comment 6 Frantisek Boranek 2010-02-26 12:50:02 UTC
This bug was marked as Resoved but I don't see target version.
Comment 7 Heddy Boubaker 2010-02-26 12:58:17 UTC
Yes the feature is back in 2.2.0 but with a lot of lost of functionalities in the naming scheme (conditionals ...), we maybe need to create a new bug entry(?)
Comment 8 Casey Link 2010-02-26 18:04:33 UTC
Lost functionality.. What functionality is lost?

Conditional naming still works when using the Advanced mode.
Comment 9 Myriam Schweingruber 2010-02-26 18:06:55 UTC
Resetting bug status to FIXED. Heddy, this is solved in the upcoming Amarok 2.3. There are no backports made to versions as old as yours...
Comment 10 Heddy Boubaker 2010-02-26 19:24:51 UTC
I'm really sorry I make a great mistake, in fact I reinstalled totaly my system 2 days ago and I'm now back to 2.2.0 so still with the old buggy organize file system (and no the conditional doesn't seems to work with it, but I still didn't made a lot of efforts to test it). I'll try to upgrade but don't remember which repository I have to add to get the latest amarok (I'm on kubuntu). And sorry too for changing the status this not intentional too - this is a bad day today :(
Comment 11 Myriam Schweingruber 2010-02-27 03:13:17 UTC
No problem. To get the newer stable version, have a look here: http://kubuntu.org/news/amarok-2.2.2
If you want to try the 2.3 beta version, have a look here: http://kubuntu.org/news/amarok-2.3-beta