Bug 214597 - Amarok: Tooltip of systemtray icon doesn't update on change in title within same playlist entry
Summary: Amarok: Tooltip of systemtray icon doesn't update on change in title within s...
Status: RESOLVED DUPLICATE of bug 211748
Alias: None
Product: amarok
Classification: Applications
Component: general (show other bugs)
Version: 2.2.0
Platform: Ubuntu Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Amarok Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-11-15 00:48 UTC by Bassio
Modified: 2009-11-23 19:47 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Bassio 2009-11-15 00:48:26 UTC
Version:           2.2.0 (using KDE 4.3.3)
OS:                Linux
Installed from:    Ubuntu Packages

If you open a radio station that updates its title (as the song continues on the next), this change is not reflected in the system tray icon tooltip.

My guess: is that the tooltip updates on progress wihtin the playlist entries ... but if the track info changes within a radio station (which is basically one playlist entry), the change is not reflected.

I am listening to Radio Swiss Classic now ... the station opened whilst playing Serenata Nocturne by Galuppi. The station has been on for a while now, and the tooltip still displays Galuppi ... while the station is playing Puccini now ;)


Update: I confirm the tooltip updates, but it is always one name-change late!

For example:
* Song a is playing
* name changed to Song b .... tooltip now updates to display "Song a"
* name changed to Song c .... tooltip now updates to display "Song b"
Comment 1 Myriam Schweingruber 2009-11-15 21:45:15 UTC
Not sure this is not already solved in 2.2.1
Comment 2 Myriam Schweingruber 2009-11-23 19:47:13 UTC

*** This bug has been marked as a duplicate of bug 211748 ***