Bug 211748 - Music metadata does not refresh in the systray.
Summary: Music metadata does not refresh in the systray.
Status: RESOLVED NOT A BUG
Alias: None
Product: amarok
Classification: Unclassified
Component: general (show other bugs)
Version: 2.2.1
Platform: Ubuntu Packages Linux
: NOR normal with 20 votes (vote)
Target Milestone: ---
Assignee: Amarok Developers
URL:
Keywords:
: 209966 214597 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-10-25 08:08 UTC by nascentmind
Modified: 2010-05-19 09:19 UTC (History)
6 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description nascentmind 2009-10-25 08:08:36 UTC
Version:           4.3.2 (using KDE 4.3.2)
OS:                Linux
Installed from:    Ubuntu Packages

Music metadata does not refresh in the systray.

Steps to reproduce:
1) Select a radio station.
2) It would set the initial track being played when you hover the mouse on the systray.
3) Wait until the track changes.
4) After the track changes the metadata would show the initial song set and not the changed track.
Comment 1 Mark Kretschmann 2009-10-27 18:45:32 UTC
commit bc1c9e6af80fd0442a81bbf317d1777c939c6fa8
Author: Mark Kretschmann <kretschmann@kde.org>
Date:   Tue Oct 27 18:40:44 2009 +0100

    Systray information now updates correctly for streams.

    The problem was that we used engineNewMetadata(), and then took the metadata
    from current track. At that point there is no guarantee that Meta itself
    has already updated, as the observer call order is random. The right way is to use
    Meta::Observer::metadataChanged(). NOTE: The same bug exists in other places.
    BUG: 211748
Comment 2 Myriam Schweingruber 2009-10-27 18:49:38 UTC
Doesn't this also solve bug 209966?
Comment 3 Mark Kretschmann 2009-10-27 18:54:35 UTC
*** Bug 209966 has been marked as a duplicate of this bug. ***
Comment 4 Piotr 'piter' Hlawski 2009-11-17 09:45:15 UTC
I'm sorry but it seems to be not fixed at all. I've installed 2.2.1 and on http://nerdcologne.de:8000/fresh.ogg it behaves like last time - track title is not changed.
Comment 5 xapeiron 2009-11-17 14:25:59 UTC
(In reply to comment #4)
> I'm sorry but it seems to be not fixed at all. I've installed 2.2.1 and on
> http://nerdcologne.de:8000/fresh.ogg it behaves like last time - track title is
> not changed.


Same to me, the metadata still does not refresh when track in stream is changed.
---------------------------------------------
KDE 4.3.3
Amarok 2.2.1

OS: Linux x64
Installed from: Fedora 11 - testing packages
---------------------------------------------
Comment 6 Lydia Pintscher 2009-11-17 14:31:41 UTC
reopening based on comments
Comment 7 Mike 2009-11-23 09:39:25 UTC
Bug 214597 looks to be a duplicate of this bug.
Comment 8 Myriam Schweingruber 2009-11-23 19:47:13 UTC
*** Bug 214597 has been marked as a duplicate of this bug. ***
Comment 9 Nikolaj Hald Nielsen 2010-01-03 15:50:07 UTC
Something seems to be very odd with that particular stream (http://nerdcologne.de:8000/fresh.ogg) as it does not seem to update metadata at all. For all other streams I have tried it works just fine. This measn that it is either abackend (or phonon) issue, or an issue with the stream itself as far as I can tell.
Comment 10 David 2010-05-19 09:19:31 UTC
I get this problem in amarok 2.3.0.  It updates correctly everywhere except:
- the systray popout
- the top scroller above the play progress/seek bar
- the status bar at the bottom

right now, i have one song in the status bar, which matches the systray, a second in the top scroller, and a third everywhere else (and these are correct).