Bug 214197 - Marble search auto-jumps to the first prefix match
Summary: Marble search auto-jumps to the first prefix match
Status: RESOLVED FIXED
Alias: None
Product: marble
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Debian testing Linux
: NOR minor (vote)
Target Milestone: 0.8 (KDE 4.3)
Assignee: marble-bugs
URL:
Keywords:
: 262767 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-11-12 00:02 UTC by Alex Dănilă
Modified: 2013-10-20 08:02 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alex Dănilă 2009-11-12 00:02:18 UTC
Version:            (using KDE 4.3.2)
OS:                Linux
Installed from:    Debian testing/unstable Packages

When entering a name in the search field, Marble will simply jump to the first match instead of waiting for me to press enter, or at least delaying the jump.

This is confusing, because if you are looking over some part of the world, and then search for a city in that area, the map will jump away, thus leaving you in front of an unexpected zone. This is worse if the searched place is not even listed.

Example: 
-Navigate to  26° 21' 32.1"E,  47° 11' 14.0"N
-Start searching for "Siret"
-Notice that when you type 'S' the map already jumps to   3° 42'E,  36° 37' 47.5"N (Saabat) which is some place in Algeria, way far from NE of Romania. Now, you've completely lost the area you where searching for, and got the first match for the prefix.
Comment 1 Dennis Nienhüser 2011-01-10 21:04:08 UTC
*** Bug 262767 has been marked as a duplicate of this bug. ***
Comment 2 Thibaut Gridel 2011-01-27 22:25:41 UTC
SVN commit 1217551 by tgridel:

Delay by 500ms before jumping after a search text is input

CCBUG: 214197
REVIEW: 6390

 M  +6 -7      NavigationWidget.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1217551