Bug 214012 - Upon closing Kile, it crashes unexpectedly.
Summary: Upon closing Kile, it crashes unexpectedly.
Status: RESOLVED DUPLICATE of bug 200450
Alias: None
Product: kile
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Michel Ludwig
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-11-10 18:23 UTC by Andrey Rukhin
Modified: 2009-11-10 22:30 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andrey Rukhin 2009-11-10 18:23:08 UTC
Application that crashed: kile
Version of the application: 2.0.83
KDE Version: 4.3.2 (KDE 4.3.2)
Qt Version: 4.5.2
Operating System: Linux 2.6.31-14-generic x86_64
Distribution: Ubuntu 9.10

What I was doing when the application crashed:
Apparently similar to the previous bug-reports, Kile crashes unexpectedly upon closing.

 -- Backtrace:
Application: Kile (kile), signal: Segmentation fault
[KCrash Handler]
#5  KateSmartCursor::setPositionInternal (this=0x2884d70, pos=..., internal=true) at ../../kate/smart/katesmartcursor.cpp:186
#6  0x00007f395180c0cf in KateSmartCursor::translate (this=0x2884d70, edit=...) at ../../kate/smart/katesmartcursor.cpp:305
#7  0x00007f395181135c in KateSmartGroup::translateChanged (this=0x215bd10, edit=...) at ../../kate/smart/katesmartmanager.cpp:464
#8  0x00007f3951814a9b in KateSmartManager::slotTextChanged (this=0x2424c90, edit=0x2c05a80) at ../../kate/smart/katesmartmanager.cpp:368
#9  0x00007f3951814e1c in KateSmartManager::qt_metacall (this=0x2424c90, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffee2d8ef0) at ./katesmartmanager.moc:74
#10 0x00007f395fb7bddc in QMetaObject::activate (sender=0x2487c90, from_signal_index=<value optimized out>, to_signal_index=<value optimized out>, argv=0x2884d70) at kernel/qobject.cpp:3113
#11 0x00007f39517e6b5f in KateEditHistory::editDone (this=0x7fffee2d8c50, _t1=0x2c05a80) at ./kateedit.moc:78
#12 0x00007f39517bfb7b in KateDocument::closeUrl (this=0x2435890) at ../../kate/document/katedocument.cpp:3606
#13 0x00000000006cd30d in _start ()

This bug may be a duplicate of or related to bug 213205

Reported using DrKonqi
Comment 1 Dario Andres 2009-11-10 22:30:02 UTC

*** This bug has been marked as a duplicate of bug 200450 ***