Bug 213205 - Kile crashed during closing it
Summary: Kile crashed during closing it
Status: RESOLVED DUPLICATE of bug 200450
Alias: None
Product: kile
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Michel Ludwig
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-11-05 08:57 UTC by Piotr Sniady
Modified: 2009-11-05 11:16 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Piotr Sniady 2009-11-05 08:57:49 UTC
Application that crashed: kile
Version of the application: 2.0.83
KDE Version: 4.3.2 (KDE 4.3.2)
Qt Version: 4.5.2
Operating System: Linux 2.6.31-14-generic i686
Distribution: Ubuntu 9.10

What I was doing when the application crashed:
Kile crashed during closing it. It happened for a couple of times already.

 -- Backtrace:
Application: Kile (kile), signal: Segmentation fault
[KCrash Handler]
#6  0x03021e6a in KateSmartCursor::setPositionInternal (this=0x955235c, pos=..., internal=true) at ../../kate/smart/katesmartcursor.cpp:186
#7  0x03022242 in KateSmartCursor::translate (this=0x955235c, edit=...) at ../../kate/smart/katesmartcursor.cpp:305
#8  0x030276af in KateSmartGroup::translateChanged (this=0x8f1bac8, edit=...) at ../../kate/smart/katesmartmanager.cpp:464
#9  0x0302afcf in KateSmartManager::slotTextChanged (this=0x8ec9ad0, edit=0x8eebd90) at ../../kate/smart/katesmartmanager.cpp:368
#10 0x0302b38f in KateSmartManager::qt_metacall (this=0x8ec9ad0, _c=QMetaObject::InvokeMetaMethod, _id=5, _a=0xbfec7548) at ./katesmartmanager.moc:74
#11 0x05c28263 in QMetaObject::activate (sender=0x9051790, from_signal_index=4, to_signal_index=4, argv=0xbfec7548) at kernel/qobject.cpp:3113
#12 0x05c28ec2 in QMetaObject::activate (sender=0x9051790, m=0x3136b64, local_signal_index=0, argv=0xbfec7548) at kernel/qobject.cpp:3187
#13 0x02ff9523 in KateEditHistory::editDone (this=0x9051790, _t1=0x8eebd90) at ./kateedit.moc:78
#14 0x02fcf937 in KateDocument::closeUrl (this=0x8eaac28) at ../../kate/document/katedocument.cpp:3606
#15 0x082d4ef0 in _start ()

This bug may be a duplicate of or related to bug 208033

Reported using DrKonqi
Comment 1 Michel Ludwig 2009-11-05 11:16:49 UTC

*** This bug has been marked as a duplicate of bug 200450 ***