Bug 213775 - Crash when starting NetworkManager from console
Summary: Crash when starting NetworkManager from console
Status: RESOLVED DUPLICATE of bug 210878
Alias: None
Product: knetworkmanager
Classification: Miscellaneous
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Will Stephenson
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-11-08 23:13 UTC by Francisco Gonzalez
Modified: 2009-11-10 02:51 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Francisco Gonzalez 2009-11-08 23:13:11 UTC
Application that crashed: knetworkmanager
Version of the application: v0.9
KDE Version: 4.3.2 (KDE 4.3.2)
Qt Version: 4.5.2
Operating System: Linux 2.6.31-15-generic-pae i686
Distribution: Ubuntu 9.10

What I was doing when the application crashed:
After  running:
# stop NetworkManager ( >= karmic - aka upstart)
sudo stop network-manager

# restart modemmanager with --debug and put output in /tmp/modem.log.txt
sudo killall modem-manager; sudo modem-manager --debug 2>&1 | tee /tmp/modem.log.txt

# start networkmanager and put log in /tmp/nm.log.txt
sudo NetworkManager --no-daemon 2>&1 | tee /tmp/nm.log.txt

knetworkmanager crashes.

 -- Backtrace:
Application: KNetworkManager (knetworkmanager), signal: Segmentation fault
[KCrash Handler]
#6  QBasicAtomicInt::ref (this=0x99ad7c0) at /usr/include/qt4/QtCore/qatomic_i386.h:120
#7  QString (this=0x99ad7c0) at /usr/include/qt4/QtCore/qstring.h:712
#8  Knm::Activatable::deviceUni (this=0x99ad7c0) at /build/buildd/plasma-widget-networkmanagement-0.9~svn1029786+ag1/libs/internals/activatable.cpp:51
#9  0xb71a60c1 in compareDevices (first=0x99ad7c0, second=0x99b3628) at /build/buildd/plasma-widget-networkmanagement-0.9~svn1029786+ag1/libs/service/sortedactivatablelist.cpp:263
#10 0xb71a621c in activatableLessThan (first=0x99ad7c0, second=0x99b3628) at /build/buildd/plasma-widget-networkmanagement-0.9~svn1029786+ag1/libs/service/sortedactivatablelist.cpp:173
#11 0xb71a64e2 in qSortHelper<QList<Knm::Activatable*>::iterator, Knm::Activatable*, bool (*)(Knm::Activatable const*, Knm::Activatable const*)> (start=<value optimized out>, end=)
    at /usr/include/qt4/QtCore/qalgorithms.h:384
#12 0xb71a6697 in qSort<QList<Knm::Activatable*>::iterator, bool (*)(Knm::Activatable const*, Knm::Activatable const*)> (this=0x993eb90, activatable=0x99b3628)
    at /usr/include/qt4/QtCore/qalgorithms.h:204
#13 SortedActivatableList::handleAdd (this=0x993eb90, activatable=0x99b3628) at /build/buildd/plasma-widget-networkmanagement-0.9~svn1029786+ag1/libs/service/sortedactivatablelist.cpp:100
#14 0xb7194d03 in ActivatableList::addActivatableInternal (this=0x9964b00, activatable=0x99b3628)
    at /build/buildd/plasma-widget-networkmanagement-0.9~svn1029786+ag1/libs/service/activatablelist.cpp:94
#15 0xb7194d9c in ActivatableList::addActivatable (this=0x9964b00, activatable=0x1) at /build/buildd/plasma-widget-networkmanagement-0.9~svn1029786+ag1/libs/service/activatablelist.cpp:82
#16 0xb7198d95 in WirelessNetworkInterfaceActivatableProvider::handleAdd (this=0x998e480, addedConnection=0x99358f8)
    at /build/buildd/plasma-widget-networkmanagement-0.9~svn1029786+ag1/libs/service/wirelessnetworkinterfaceactivatableprovider.cpp:132
#17 0xb71990d9 in WirelessNetworkInterfaceActivatableProvider::networkAppeared (this=0x998e480, ssid=...)
    at /build/buildd/plasma-widget-networkmanagement-0.9~svn1029786+ag1/libs/service/wirelessnetworkinterfaceactivatableprovider.cpp:176
#18 0xb7199a89 in WirelessNetworkInterfaceActivatableProvider (this=0x998e480, connectionList=0x98b5cf0, activatableList=0x9964b00, interface=0x9935220, parent=0x99800a8, 
    __in_chrg=<value optimized out>, __vtt_parm=<value optimized out>)
    at /build/buildd/plasma-widget-networkmanagement-0.9~svn1029786+ag1/libs/service/wirelessnetworkinterfaceactivatableprovider.cpp:76
#19 0xb719556c in NetworkInterfaceMonitor::networkInterfaceAdded (this=0x99800a8, uni=...)
    at /build/buildd/plasma-widget-networkmanagement-0.9~svn1029786+ag1/libs/service/networkinterfacemonitor.cpp:71
#20 0xb718ea9b in NetworkInterfaceMonitor::qt_metacall (this=0x99800a8, _c=QMetaObject::InvokeMetaMethod, _id=4, _a=0xbfbda488)
    at /build/buildd/plasma-widget-networkmanagement-0.9~svn1029786+ag1/obj-i486-linux-gnu/libs/service/moc_networkinterfacemonitor.cpp:69
#21 0xb6615263 in QMetaObject::activate (sender=0x99541b0, from_signal_index=5, to_signal_index=5, argv=0xbfbda488) at kernel/qobject.cpp:3113
#22 0xb6615ec2 in QMetaObject::activate (sender=0x99541b0, m=0xb71326e0, local_signal_index=1, argv=0xbfbda488) at kernel/qobject.cpp:3187
#23 0xb71198b3 in Solid::Control::NetworkManager::Notifier::networkInterfaceAdded (this=0x99541b0, _t1=...) at ./networkmanager.moc:101
#24 0xb711a346 in Solid::Control::NetworkManagerPrivate::_k_networkInterfaceAdded (this=0x99541b0, uni=...) at ../../../../libs/solid/control/networkmanager.cpp:197
#25 0xb711a3c7 in Solid::Control::NetworkManagerPrivate::qt_metacall (this=0x99541b0, _c=QMetaObject::InvokeMetaMethod, _id=10, _a=0xbfbda5e8) at ./networkmanager_p.moc:75
#26 0xb6615263 in QMetaObject::activate (sender=0x995ac60, from_signal_index=13, to_signal_index=13, argv=0xbfbda5e8) at kernel/qobject.cpp:3113
#27 0xb6615ec2 in QMetaObject::activate (sender=0x995ac60, m=0xb3ac1a70, local_signal_index=1, argv=0xbfbda5e8) at kernel/qobject.cpp:3187
#28 0xb3aa8143 in NMNetworkManager::networkInterfaceAdded (this=0x995ac60, _t1=...) at ./manager.moc:128
#29 0xb3aa96a8 in NMNetworkManager::deviceAdded (this=0x995ac60, objpath=...) at ../../../solid/networkmanager-0.7/manager.cpp:199
#30 0xb3aac87d in NMNetworkManager::qt_metacall (this=0x995ac60, _c=QMetaObject::InvokeMetaMethod, _id=20, _a=0xbfbda788) at ./manager.moc:105
#31 0xb6615263 in QMetaObject::activate (sender=0x997ab08, from_signal_index=5, to_signal_index=5, argv=0xbfbda788) at kernel/qobject.cpp:3113
#32 0xb6615ec2 in QMetaObject::activate (sender=0x997ab08, m=0xb3ac2a80, local_signal_index=0, argv=0xbfbda788) at kernel/qobject.cpp:3187
#33 0xb3ab8e53 in OrgFreedesktopNetworkManagerInterface::DeviceAdded (this=0x997ab08, _t1=...) at ./nm-manager-clientinterface.moc:149
#34 0xb3ab9385 in OrgFreedesktopNetworkManagerInterface::qt_metacall (this=0x997ab08, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0xbfbda9ec) at ./nm-manager-clientinterface.moc:96
#35 0xb67147b4 in QDBusConnectionPrivate::deliverCall (this=0x98e6970, object=0x997ab08, msg=..., metaTypes=..., slotIdx=5) at qdbusintegrator.cpp:891
#36 0xb671c197 in QDBusCallDeliveryEvent::placeMetaCall(QObject*) () from /usr/lib/libQtDBus.so.4
#37 0xb660f5fe in QObject::event (this=0x997ab08, e=0x99ade40) at kernel/qobject.cpp:1111
#38 0xb6885f54 in QApplicationPrivate::notify_helper (this=0x9847df8, receiver=0x997ab08, e=0x99ade40) at kernel/qapplication.cpp:4056
#39 0xb688d67c in QApplication::notify (this=0xbfbdb1f0, receiver=0x997ab08, e=0x99ade40) at kernel/qapplication.cpp:3603
#40 0xb73d8bfa in KApplication::notify (this=0xbfbdb1f0, receiver=0x997ab08, event=0x99ade40) at ../../kdeui/kernel/kapplication.cpp:302
#41 0xb65ff6cb in QCoreApplication::notifyInternal (this=0xbfbdb1f0, receiver=0x997ab08, event=0x99ade40) at kernel/qcoreapplication.cpp:610
#42 0xb66002b2 in QCoreApplication::sendEvent (receiver=0x0, event_type=0, data=0x982ce48) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:213
#43 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x982ce48) at kernel/qcoreapplication.cpp:1247
#44 0xb660047d in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1140
#45 0xb662a3ff in QCoreApplication::sendPostedEvents (s=0x984ea90) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#46 postEventSourceDispatch (s=0x984ea90) at kernel/qeventdispatcher_glib.cpp:210
#47 0xb5c68e78 in g_main_dispatch (context=0x9849820) at /build/buildd/glib2.0-2.22.2/glib/gmain.c:1960
#48 IA__g_main_context_dispatch (context=0x9849820) at /build/buildd/glib2.0-2.22.2/glib/gmain.c:2513
#49 0xb5c6c720 in g_main_context_iterate (context=0x9849820, block=<value optimized out>, dispatch=1, self=0x9847940) at /build/buildd/glib2.0-2.22.2/glib/gmain.c:2591
#50 0xb5c6c853 in IA__g_main_context_iteration (context=0x9849820, may_block=1) at /build/buildd/glib2.0-2.22.2/glib/gmain.c:2654
#51 0xb662a02c in QEventDispatcherGlib::processEvents (this=0x982ca30, flags=...) at kernel/qeventdispatcher_glib.cpp:327
#52 0xb6926be5 in QGuiEventDispatcherGlib::processEvents (this=0x982ca30, flags=...) at kernel/qguieventdispatcher_glib.cpp:202
#53 0xb65fdc79 in QEventLoop::processEvents (this=0xbfbdb154, flags=) at kernel/qeventloop.cpp:149
#54 0xb65fe0ca in QEventLoop::exec (this=0xbfbdb154, flags=...) at kernel/qeventloop.cpp:201
#55 0xb660053f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#56 0xb6885dd7 in QApplication::exec () at kernel/qapplication.cpp:3525
#57 0x08052905 in main (argc=1, argv=0xbfbdb344) at /build/buildd/plasma-widget-networkmanagement-0.9~svn1029786+ag1/monolithic/main.cpp:45

This bug may be a duplicate of or related to bug 209092

Reported using DrKonqi
Comment 1 Jonathan Thomas 2009-11-10 02:51:30 UTC

*** This bug has been marked as a duplicate of bug 210878 ***